[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud


#61

dognmonkey works your image with the 4tb version?.. i want to try ist later at home with my totally bricked and now blank wd 4tb my cloud hard drive and with the help from yout youtube video tutorial and how work it with a sata to usb divice


#62

Hi guys, I restored my WD My Cloud 2TB successfuly :slight_smile:

I was playing with linux over SSH little more and after installation some depedencies packages it felt down. I was not able to perform any command, only the SMB and FTP access was luckly accessible.

So what I did:

Really helpful:   https://github.com/utessel/mycloud/ 

  1. run on my Win PC VirtualBox with Ubuntu. There I installed TFTP server. After this I compiled rawping.c from GitHub and run it with device MAC Address.

2) downloaded GPL Sources from WD website  http://support.wdc.com/product/download.asp?groupid=904&sid=211&lang=en  (gpl-source-wd_my_cloud-03.04.01-230a.zip). Then you need to follow instructions from GitHub Readme file and build-sys.sh. You need to build single file uImage … it was little fun but successful. You need to install few libraries and correct some files, but simple.

3) then you need to reboot device. If your pinging was successful, your device will request DHCP address and TFTP will try to get startup.sh file. You need to fill it with startup-uImage.sh. Parallely with startup.sh file you need to have generated uImage file. Then device will boot into special small Linux compilation accessible via telnet.

  1. there you can access all files, mount the partitions (SDA1,2 - RAID of system, SDA3 - swap, SDA4 - main data). In my case data was untouched so I backed it up.

And then you need to download latest firmware from  http://support.wdc.com/product/download.asp?groupid=904&sid=211&lang=en and unzip .deb file, there will be 1.9GB file rootfs.img. You need to dd image to SDA1 and SDA2.

dd if=rootfs.img of=/dev/sda1

dd if=rootfs.img of=/dev/sda2

 After this, device will boot normally with configuration as after factory reset. I suggest to perform totally factory reset and then update firmware from file with downloaded .deb archive.

Hope be helpful :slight_smile:

Blažej


#63

Hey. I bricked my 3 Tb Version with the script provided here. I unbrick it by another guide.

After i started the script, its downloading some stuff, installs and breaks with an error. I havnt the errormessage, but after that my nas was bricked.

Ive the my cloud 3tb and newest fw.

What was wrong with it? As i read, many ppl using your script with the newest firmware. But in my case it doesnt work.

After that, i can not writing any command with ssh without getting this error.

So i unbricked my device, but i wont use this crappy twonky server. It cant serve my hd files without buffering, so i tried the minidlna guide.

I will try it again and hope it works. Otherwise i have the errormessage for you.


#64

I’ve unbricked my cloud  with the tut on first page, only with the 250gb image.

now i have only 250gb instead of 4 tb.

it not will change over to 4 tb.

what can i do?

and if i upgrade the firmware on my cloud, it will bricked again, how can i solve this?

with the 250gb image i installed v3.


#65

pbpromotion wrote:

I’ve unbricked my cloud  with the tut on first page, only with the 250gb image.

 

now i have only 250gb instead of 4 tb.

Did you perform Step 19 from the first page tutorial and do a Quick Factory Restore from the Dashboard?

“(3TB/4TB Drives) Once you get to the dashboard, do a Quick Factory Restore.  This reformats your data partition for the full size.  Once it reboots, DON’T PANIC.  It will show as only 2GB for a short time… eventually, it’ll wise up.”


#66

yes i have done.

but nothing happens with the space.


#67

I had the same. Its easy to fix. 

  • connect your hdd from mycloud to a pc (i did this over an usb->s-ata controller)

  • Start the systemrescue cd (as described in the guide)

  • type “gparted” in the terminal (without quotes)

  • Go to devices and choose your drive

  • check the last partition on it, you can see wich is correct, because its the biggest and last partition on the device with ext4 fileformat

  • click on it and choose “resize”

  • take the maximum capacity and hit “apply” - (the green hook)

Then gparted will fill your partition and fix it to the maximum space.

Reassemble your mycloud an check it.

Thats what i did. Unbricked with the guide and fixed that space issue by gparted.


#68

That i’ve done the last time, then i have 2 TB but the last 2TB are away.

The second 2TB nobody (win+ubuntu+rescue cd) will find.

What can i do?

A Complete System restore on the mycloud?

And the Update problem?

What can i do in there?


#69

hello and thank you in advance
not find a disk image of 2TB, can someone reupload one? please
Thank you very much to all
sorry for my inglish


#70

Please, could anybody upload or share any hdd image for the unbricking process? I’ve searching for it for hours and it’s impossible… I need the 3tb, but I read that the 2TB is good as well.

Thank you very much!


#71

Answer myself:

http://community.wd.com/t5/My-Cloud/GUIDE-Debrick-a-completely-dead-MyCloud/td-p/704480


Unbrick My Cloud 2TB with no success
#72

Here is a mirror for the 2TB image.

https://www.dropbox.com/s/ue7dxzyt8hwm3e3/mycloud2tb.7z


#73

So you didn’t have to disassemble the My Cloud?

Is there any way to do this without disassembling the My Cloud? I’m a complete novice and I don’t want to risk it, also I would have to buy a SATA/USB connector as I have a laptop but no PC… What size is the hard drive inside?


#74

Sorry, folks.  I’ve been away,

I’m 95% done with a new system for unbricking, and the last hold up is the compression settings to make a tiny package.  (I would LOVE to know what was used for the original tiny image!)  Stay tuned, it’ll be done in a week or two, once my real life settles down again.


#75

Hi eriffoorp,

I heard for a lot of guys, only your image (250gb was working). I wanted to try it out but your image link doesn’t seem to be up. Can you or someone please repost the image?

Tnx a lot!


#76

Anyone have an image for Dl2100 ??  I’m Bricked with Blue Lights right now


#77

Hey, does anyone have any advice for using a SATA to USB connector and using a laptop to unbrick the Cloud? Also, can someone please tell me the size of the hard drive so I can get this started…


#78

Hey everyone… I’m about at the end of my tether with this! I’ve followed your guide to the letter and when I turn my WD My Cloud on at the end, all I get is the solid white LED (no change), no idea what I’ve done wrong. I’ve tried both the 2TB image in the original post and the 1TB image posted by one of the other posters.

Any help would be greatly appreciated.

EDIT: It flashes every 60 seconds.

EDIT2: Just tried to reformat /dev/sdb4 as ext4 and retry it (as worked for a previous user) - this did not work! Going to use the 250GB image now, if this doesn’t work I’m going to wipe it and set it up as a headless server.

EDIT3: The 250GB image did not work for me either, I must be doing something terribly wrong… I give up, I’m out of time sadly.


#79

Hi Montelukast,

Can you please post teh 250GB image and the 1TB image?

THanks a lot!


#81

Hi Redactie, my post has be been hidden, no idea why. I have tested the link in this post. It should work…Hope you can get yours fixed.


WD My Cloud 2TB virgin disk image