[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud


#102

How’d it go, were you able to get the image working?


#103

Hi VaBeachGuy,

At the Moment my My Cloud. has to wait a couple of day’s. I’m shure I can do it. But at the Moment I have first to do some other thinks. It can take 1-2 Week max.
Will update You then.

Regards
Erwin


#104

I’m extremely happy i found this page as i have had a bricked 2tb since i got it a while ago. But im wondering if anyone knows a way to do this without a blank cd becasue i dont have one. Im going to end up doing it with my laptop if that makes a difference


#105

You can use a USB thumb drive/flash drive rather than a Boot CD if your computer supports booting from a USB thumb drive/flash drive.

Here is one set of general direction for creating a bootable USB thumb drive/flash drive that will boot Ubuntu:
http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows

One can use the Universal USB Installer to install a Linux OS to a USB thumb drive/flash drive.
http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/


#106

Hi VaBeachGuy,

sorry but I can not make it.The 2 TB Disk contains Windows-7 data’s. I’m not really sure if I have to format this HD and when so with Windows or with Linux. But I hope it will be done when the File from the USB-Stick copy’s to the HD works. I’m still not sure if the File to put on this USB-Stick is ok. Meanwhile I have blowing up my Computer. !TB & 2 TB completely blank HI. I have no Idea how this cut happened., but he is so fare OK again only my very important Data all gone.I hope I will find the solution soon. My DSL is fast, so I can receive a lot via that way.

Sorry I cannot say it is working again.

Regards Erwin


#107

Hi VaBeachGuy,

was starting direct as the first one this day. Did it exact so as in the manual and yes it was working the first time. So I’m very happy. I’m busy now to install all the variables.
He is also busy to update the OS.
Thanks for al the help. For You also much pleasure with your WD.
All the best VaBeachGuy.

Erwin


#108

I’m glad you got it working, and glad that I could help in any way.

Be sure to bookmark this thread so that you can refer back to it if you decide to upgrade your hard drive in the future.

Kevin


#109

Awesome guide!

I have a my cloud without a hard drive. Picked up a 3tb wd red and followed the guide. The hard drive had no partitions (3tb unallocated)
I cant get the right partitions, all steps works great accept the parted ones since I only get one partition when Im done.

Should I add a gpt partition table before starting the steps in the guide or a msdos and format it as a ntfs disk?!

Pls help me out!!


#110

User Fox_exe has put together some instructions. You will need to know what My Cloud version (v3.x/v4.x or v2.x) you are using as the files needed are different.

First Gen v3.x/v4.x replacing HDD: https://drive.google.com/file/d/0B_6OlQ_H0PxVbzZac0plbkZKeGM/view

Second Gen v2.x unbricking: https://drive.google.com/file/d/0B_6OlQ_H0PxVQVhnLVJOdDZISUU/view

Or see their main My Cloud section: https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXF4aFpYS2dzMEE


#111

Thnx for the info!
Sadly I dont know which version I have.
The case P/N is wdbctl0030hwt-00 and the mainboard have: Rev 04P


#112

Generally if the P/N ends with “-00” it is the first gen v3.x/v4.x. For gen 2 which uses v2.x firmware, the P/N generally ends with “-10”.


#113

Re tryed this guide and voila!! Blue light finally :heart:


#114

Just wanted to share my image of a brand new/virgin 6TB MyCloud hdd.
In case anyone wants to restore their 6TB device.

Download: wd-my-cloud-6tb.img.xz (1.2GB)
https://mega.nz/#!atxDTAxI!Quv3s09WkwYubh-mlqJ8U-SPi4X9z1O1zA-BmIBlJSk
md5sum: 23a8a6620c2e17bf69047927bfdc1aa6

Restore (as root): xz -c wd-my-cloud-6tb.img.xz | pv -s 6001175126016 | dd of=/dev/sdX

Have fun!


#115

Hey guys,
I tried to follow this instruction, but unfortunately I had to skip #14 and 15 because I didn’t received an error. After typing in unit s + p, I only got an overview about 2 existing sectors (not 4 as it’s written here). Furthermore, the start sector of the last partition (which was 2 in my case) was 77056s.

I continued with step 16 (but didn’t got a warning again) and finished the instruction, but currently I only get a permanent white LED and can’t connect with the software.
Does somebody has an idea what I’m doing wrong?
Thanks and best regards!


#116

Take care: I’ve used this method, but, after about 2 minutes, dd stops without error, but the partition table of my disk has been wiped and contains no partition!


#117

Hi I’m hoping some clever person could help me… I’ve tried several times to get the mycloud up and running with a WD Red 3TB drive (and the drive proves to be fine). I get all the said partitions and everything looks correct to my untrained eye, but when I reassemble the Mycloud and plug it back in, I get a flashing blue light for about 5 seconds which then changes to a red flashing light. Any ideas what I might be doing wrong?
I’ve tried several virgin images all with the same result.
Please help me before I take a bat to it :cricket_bat_and_ball:


#118

Same here. Tried unbricking following fox_exe unbricking_en.txt (both ways) and i only get red blinking led. With the usb way i get a working telnet, but nothing more. Every Help is appreciated

UPDATE

I’m able to unbrick my MyCloud to the CleanOS Debian. My failure was to do the mkfs.ext4 command on my laptop with connect hdd. You MUST DO the mkfs.ext4 command on the mycloud device. Otherwise you’re not able to mount the ext4 paritions on mycloud. After doing this, i followed fox_exe instruction and extraxt jessie…tar and copied uImage und uRamdisk as described. My NAS is working again.
In my opinion, if i followed the unbricking_ex.txt and do the mkfs.ext4 on the NAS (via Telnet within RecoveryMode) i would be able to restore stock firmware.

Maybe this information helps someone


#119

Hi all,

I have 3TB WD MyCloud and it was bricked. I followed the steps mentioned by Ouglee and I run into different scenario when dd command is issued. Instead of Bootable CD, I use Bootable USB. It writes only 2.5GB and returns. Below is the snippet. Can someone plz help me?

5282833+0 records in
5282833+0 records out
2704809984 bytes (2.7 GB, 2.5 GiB) copied,124.904 s, 21.7 MB/s


#120

I think that is all it is supposed to write. Did you then try to put the My cloud back and boot?

RAC


#121

Hi RAC,

Thanks for your reply. Shouldn’t it be 5GiB as per the steps? Anyways, when I put the disk back and boot, full White LED which blinks once in a min is seen.