[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

despite the img of the disk is not longer avaliable, i have found a different solution based on the points 12 to 17 of the first post:
i had actived the ssh daemon from the user interface, connected with putty at the ip of the nas, connected using the temporary password (root / welc0me) , and after changed the root password i followed the instruction on gparted to wipe and recreate the partition 4 (with the same start and end point of the previous partition!!), then i had a factory reset and now the NAS has again 4TB instead of 2GB!!

I have a 3TB My Cloud, probably Gen1 since I got it from around 2015. I’ve been updating the OS over the years - I had been using OS5 at the time. Anyway, it crashed while I was trying to copy some large files from the My Cloud to an internal hard drive. Just flashing blue lights, absolutely no way to access it from the interface, online dashboard, or app. Support said it was rebooting or rebuilding its index, but this went on for over a week with no progress. Deciding it was bricked, I removed it from the enclosure and connected it to my PC via SATA, then copied the files over. So I’ve got my files backed up, but no disk image.

I use Ubuntu, so I thought I could follow these unbricking guides using the Gnome Disks utility. I downloaded a copy of WDMyCloud3TBVDI.img from one of these support threads, and used the “restore disk image” option in Disks to write it to the My Cloud HDD. I couldn’t mount the HDD on Ubuntu, but the partitions looked right on the GUI so I decided to proceed. Once I reattached the board and all the cables, I got the typical green lights on the Ethernet port but a flashing red light on the front. I was totally unable to access the drive via any network tools and the light stayed flashing red for hours. I tried the 40-second reboot and power cycling, no change.

Next I tried downloading a more recent firmware image, extracting rootfs.img, and using “restore disk image” on Gnome Disks to write that to both Raid partitions. The results were the same - red blinking, no network access. I then used “restore disk image” from the Gnome Disks to once again write WDMyCloud3TBVDI.img to the HDD, just to undo that last RAID edit. Per an earlier comment in this thread, I tried reformatting the filesystem on partition 3. This seemed to make some difference, as I was able to mount the drive on Ubuntu. But once again, red blinking and no network access once I attached the hdd to the board and cables.

Anyone have any ideas? Could it be an incompatible disk image, something wrong with the board, wrong choice of tool (Gnome Disks vs command line)?

One must know the version because the files used and methods used to unbrick may not be the same. The gen 2 single bay My Cloud has different hardware and uses different firmware that is incompatible with the gen 1 firmware.

Look at the bottom of the single bay/single drive My Cloud enclosure for the P/N number.
First gen v4.x firmware: P/N: WDBCTLxxxxxxx- 00
Second gen v2.x firmware: P/N: WDBCTLxxxxxxx- 10

When partitioning the hard drive for use in the single bay My Cloud enclosure, its important to use the exact values. Do not adjust them in any way or round them off.

Note: The My Cloud Home is not the same as a My Cloud unit. The My Cloud Home uses different firmware and has a different operating system.

good catch. so i can confirm i have gen 2 then.

i ended up following the directions and using the recovery files in the google drive in this thread,

specifically, i used the “alternative way” listed in the _Unbricking_en.txt file to create partitions and move the boot files to the drive.

i can at least see an ip address now on my ISP’s network monitor tool. and when i go to it, it gives me the option to upload new firmware. it’s taking forever, but seems to be working. thanks for pointing me in the right direction!

Great. Now I’m having this issue. Anyone know what firmware I should use?

Another unbrick method that couldn’t hurt to try. Note that WD is blocking the downloading of older firmware (like the one used in the directions below) now, so one will have to use the current/latest 2nd gen v2.x firmware which can be downloaded from the WD Support website.

This has helped me recover my 3TB MyCloud, thank you so much!!!

Hi Ouglee,
I have finished all the above steps. MyCloud is 2TB. So after step 09 I had started step 18.
now my HDD showing as below :


but when I have attached my hdd to mycloud then Red Light is continus blinking. even cant find by network (useing Mycloud desktop apps). I tried to reset by pressing reste button but still same. Please help me.
Thanks
Ashim

Is this working with WD 2TB HDD.
Thanks
Ashim

Note that user Ouglee last post was Feb 16, 2017.

Are you trying to unbrick a first gen v4.x firmware single bay My Cloud model (P/N # ends with “-00”) or a second gen v2.x firmware single bay My Cloud model (P/N # ends with “-10”)? The directions for the second gen model are not the same as the directions for a first gen model.

If the directions above do not work, one can try using the unbrick directions from user Fox_Exe that some have used with success.

User Fox_exe repositories:
Main Repository: https://fox-exe.ru/WDMyCloud/
First Gen: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/
Second Gen: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

First gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD.txt
File(s) used in first gen:
original_v03.04.01-230.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
original_v04.01.02-417.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz
Latest first gen firmware: http://support.wdc.com/downloads.aspx?g=904

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
usbrecovery.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate method files:
uImage-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery
Latest second gen firmware: http://support.wdc.com/downloads.aspx?g=904

Notes on running unbrick directions on a first gen single bay My Cloud: After successful unbrick one can update the My Cloud to the latest v4.x firmware. When running the first gen unbrick directions from User Fox_exe one may get one or two errors, which one can try bypassing on a first gen. The unbrick process typically completes despite these errors. Places where one may get errors or warning when unbricking a first gen:

  • Step 8. The command ‘mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2’ sometimes throws an error. One can typically just ignore the error and continue to the next entry command in step 8.
  • Step 12. When using the original_v04.01.02-417.tar.gz file, one may get a out of space error when running the command ‘dd if=kernel.img of=/dev/sdb5’. One can try ignoring this error and proceed to the next entry command in step 12. When using the original_v03.04.01-230.tar.gz extracted files one typically won’t get the out of space error message on sdb5.
  • When booting the My Cloud for the first time after unbricking the hard drive one may eventually get a red front LED after the bootup completes. One should attempt to access the My Cloud Dashboard. If one can access the Dashboard, go to Settings > Utilities > System Factory Restore > System Only restore and run the system only restore. This typically fixes the 0K capacity and the failed mount issue that typically happens with this unbrick procedure.

wow this is an old post with a lot of replays .

any idea what are the numbers for 8TB ?
and there is new way to do that ?

Generally one doesn’t change the partition size values if using the Fox_exe directions. One would enter the values in exactly. I’ve used the Fox_exe directions to unbrick a 12TB drive as a test in a first gen single bay My Cloud. After doing a system factory restore after first boot the My Cloud worked fine and utilized the full space of the hard drive.

The bigger factor is ensuring you use the correct directions for the version (first or second gen) of the single bay My Cloud (not My Cloud Home that is a different device).

i having a problem with this thing :

  1. Install original WD recovery and reboot:
    mkdir -p /mnt/usb /mnt/root
    mount /dev/sda3 /mnt/root
    mount /dev/sdb1 /mnt/usb
    cp -r /mnt/usb/boot /mnt/root/
    cd /mnt/root/boot
    rm uImage uRamdisk
    mv uImage-wdrecovery uImage
    mv uRamdisk-wdrecovery uRamdisk
    cd /
    umount /mnt/root /mnt/usb
    sync
    reboot -f

Blockquote

somehow it not working for me .



Look at the terminal screen capture you posted. Look at the name of the files. They are case sensitive in Linux. You are missing the upper cased letter in each of the files when you issued the dd command:
uImage-wdrecovery
uRamdisk-wdrecovery

It should look something like this:
dd if=/mnt/usb/boot/uImage-wdrecovery of=/dev/sdc3

oh didnt know its that critical …
i did everything from the beginning with (Fox_exe file archive) direction,
all command work fine on terminal (i hope so)
what do i need to do in 7. ?
take out the USB and HD and connect them to the Mycloud board trying to login for firmware install ?

edit :

all work GOOD ! thx

I have a gen 2 my cloud the hard drive died on. I bought a new hard drive and had been attempting to fix by using the gen 1 instructions which hasn’t worked. I downloaded the firmware of version 4 on a usb this morning I’m wondering if I still need to do the other recovery image and if so could someone send a valid link as the link above took me to a not secure message

Why are you trying to “unbrick” a gen 2 single bay My Cloud hard drive with gen 1 directions? The gen 2 My Cloud uses different hardware and different firmware than the gen 1 unit. The v4.x firmware is not for the gen 2 units, it is for gen 1 only. See my post above for user Fox_exe’s directions for the gen 2 units that some have used to install a new hard drive into a gen 2 single bay My Cloud.

WD for what ever reason decided to confuse people with the firmware version numbering scheme with the single bay My Cloud. V4.x firmware is not “newer” than v2.x firmware. It is just intended for a different device, the first gen single bay My Cloud. Likewise the v2.x firmware cannot be run on a first gen single bay My Cloud.

I had failed to scroll all through the comments to see that there were other instructions. I checked yesterday and saw I have the 2nd gen one.

So today I made the usb with the boot folder and followed the instructions by putting the usb in the my cloud and plugging it in. It constantly flashes red and when I plugged it into my network there is no IP showing as it doesn’t appear to actually boot. The cat 5 shows green flashing light as if data is transferring but my device list of my router shows no IP address sunder that Ethernet port.

So I then tried the second way and used my virtual machine and launched Ubuntu and plugged the hard drive in via a usb mount but none of the usb drives show up in Ubuntu.

Can I do this on my Mac? Does anyone have instructions to do for gen 2 on a Mac using terminal?

Also can someone tell me the proper firmware version I need to download? They have 2,4 or 5 as an option.

As previously explained, the v4.x firmware is for the FIRST gen single bay My Cloud (P/N number ends with “-00”) NOT the second gen single bay My Cloud (P/N number ends with “-10”). The second gen single bay My Cloud supports v2.x firmware. Once one has the latest v2.x firmware installed on their second gen single bay My Cloud one can update that firmware to OS5’s v5.x firmware.

If you cannot use Linux commands with Mac Terminal (not a Mac guy, no idea if it can run Linux commands), one can create a Linux boot disk or boot USB flash drive and boot their computer with it. For example Ubuntu has directions for creating a Ubuntu boot disk/flash drive on a Mac.

Thanks I booted to Linux and was able to partition the new drive without any issues and have downloaded the needed files onto a usb that is plugged in but I can’t seem to find instructions on how to copy the files from the usb to the drive in Linux? I did the cp uImage-Ed recovery /mnt/boot/boot/uImage and get the error cannot stat ‘uImage-wdrecovery’ no such file or directory

How do I write the files from the usb drive to the disk in Linux?