[GUIDE] Debrick a completely dead MyCloud


#21

Thanks for the info djh816. I followed the instructions but I just get a solid white light (it seems to blink once every 30-45 seconds).  I originally started on this procedure after a botched crashplan/java install (I was on v4 of the WD firmware). I was attempting to restart the device via ssh and when the device came back online I was unable to SSH or access the dashboard (though I was still able to view the fileshare). SSH gave me a connection refused. After the restore, the device isn’t recognized by SSH, dashboard or fileshare. Any ideas where to go from here?


#22

I was able to restore my MyCloud! Thanks to everyone here for their instructions!

If anyone is having issues, you can try the following.

  1. Make sure you are using the right disk image! I was using for my 2TB drive:

https://mega.co.nz/#!PElwgSyJ!Aicrq1FKKojLVjJgBAz37Sa-9F1KaPeeyMhZ3lN2vpg

  1. Make sure that that the extracted mycloud2tb.img file is 5.24 GB in size. 

MD5 (mycloud2tb.img) = 1172e8a5c0157c820a3c089006f12992

  1. Ensure your flash drive can support large files. I used an old flash drive with FAT32 to transfer the file. THIS WILL NOT WORK because the FAT32 system has a 4GB limit. Unfortunately, my Mac didn’t warn me when copying the file and just truncated it. Reformatting my flash drive to NTFS was required. (I used  http://www.paragon-software.com/home/ntfs-mac/ 10-day trial to get NTFS support on my mac)

4). I’m sure that once all of the above works, you can just copy the files using the dd command within any linux liveCD. However, I booted up UbuntuLive from a CD and used the Disks utility to write the img file to disk. I chose this route because although I was able to write the image to the drive using dd, I was getting strange output from umount. Umount would say “unable to umount /dev/sda device is busy”. However, listing the mount points didn’t show anything.

If you use Ubuntu, I think the OS will automatically mount the swap partition on the drive. So if you try and write the image using the disks command, you will get a similar device in use error (i can’t remember the exact error). I think Ubuntu automatically utilizes the swap partition on the drive, so before you write the disk image, besure to right click on the swap partition on your mybook drive, and select “Swapoff”. Once you do this, just select the gear icon in the upper right of the disk utility and choose restore image, and choose your .img file. 

After all of this I got a blue light! Thank you to everyone in the forums for posting their experience and advice.


#23

Congrats on the fix Ryan. Sorry I didn’t get a chance to reply until now, swamped with my own IT work :stuck_out_tongue: I never ran into that issue because I was using NTFS usb stick from the beginning but that’s a good catch, I’ll mention that FAT32 is not a good format in the OP. Thanks for the info and report back on success :slight_smile:


#24

For anyone wondering, there /shouldn’t/ be any software difference between the software handling the 2TB, 3TB and 4TB disks, and it should be possible to restore a broken disk from any image. In case that your partition layout hasn’t been changed, it is sufficient to use the kpartx linux tool to mount the image of your choice, and restore partition by partition. For those willing to retain their data partition, just avoid to restore sd*4, but just do sd*1 and sd*2 (which contains the firmware), sd*5 and sd*6 (which contains the kernel) and sd*7 and sd*8 (which contains the configuration). sd*3 is swap space, so it doesn’t need to be restored.


#25

do you have a link alternative for the mycloud 4 terabyte


#26

why are people restoring the whole image of the drive for bricked deivces? or have you all managed to screw up your partiton tables?

I’ve bricked mine 4times now. Most recently this week and have always just restored by copying the roots.img file over the 2 raid partitions, retaining everything.


#27

Hi, everyone!

I`ve got a 3 Tb version of MyCloud, with latest firmware 4+

I tried to install Transmision via SSH (Terminal, Mac OS X).

In progress of installation, I saw, what some of packages were lost and installation was not complete.

After that I lost a connection with USB port in MyCloud. In UI were an error, what usb server have problems.

I`ve tried to reboot my device via UI and where is another problem - MyCloud UI wrote that the reboot is not possible.

After that, I have a connection to my files, but when I am trying to get UI, I see a message - reading system information…and nothing more.

Access via SSH is not impossible, where is access denied. So now I don`t know how I can fix this issue and get back my device in good working condition.

In fact, I don`t have a brick. I have access via SMB. Problems with my Debian part (or UI)

Guys, anyone have an ideas?

I don`t want to open plastic case, maybe I can directly connect MyCloud in my PC and update a firmware?


#28

Greetings AAleksey.s,

Can you restore the firmware using the reset button on the back? That should let you restore the entire stock set of software, assuming that image is still in tact. I believe the procedure was to power it off, then hold that reset button as you plug it in and power on. If that fails, and all you have is SMB access, I would say without SSH the procedure mentioned in the original post would be the next step (or you might just want to try talking to Western Digital for a replacement if you just used their WebUI and no SSH). Point being if you JUST have access to SMB, all that would let you do is copy and retrieve files to that specific share’s folder. I don’t think there would be a way to execute a file period.


#29

Tnx for your reply.

No, I don`t tried hard reset yet. Today, I will try and see what happens next.


#30

KUDOS!

My 2TB was unaccesible but not dead, so I had a chance to plug it to my Linux Ubuntu box and backup my valuable family stuff before re-imaging using your instructions. (I rendered it unusable by trying to install gcc to compile no-ip, big mistake)

Lessons learned:

  • Don’t try to install LInux stuff without a backup.
  • Backup constantly!

#31

A post was split to a new topic: Removed Post JAZST


#32

It worked for me. I downloaded the 3TB one and unzip it and copied it to a Ubuntu server I have and plug in the My Cloud 3TB green drive I have in. The blue drive I don’t like how it runs hot and loud. Beside I messed it up trying to install SQL in it. It would not boot then.

I just did this command then:

root@server:/media/6TB/MyCloud# dd if=/media/6TB/MyCloud/mycloud.img of=/dev/sdk

Don’t do the same as me all others will not be just the same command like were and to! Or if and of.

In about 15 min. I guess it came back with.

10240000+0 records in
10240000+0 records out
5242880000 bytes (5.2 GB) copied, 359.084 s, 14.6 MB/s

Went to it’s webpage and started to do a Update Firmware. Seems like it just stays at "Upgrading…(10%)

When I bought it it came with V04.01.03-421 and updated to V04.04.02-105. So maybe when it reboot’s it will say the V04.04.02-105

The DD image is v03.03.01-156

It’s only saying my 3TB is a 1.5TB I guess if this Firmware Update works it my know it’s a 3TB.

-Raymond Day


#33

OP has been updated with a new working 2tb link. I have both backed up so just PM me if the links break again.


#34

Sorry for my poor english. I’m Spanish.
Thanks for your article. I repair my WD My cloud 2Tb following your text. Only with one diference I use Always Linux for my personal works. I only connect de Harddisk to my PC system and write de the image mycloud2T.img with the dd command.
All OK y HAVE a new BLUE LIGHT on my NAS.
THANKS for all.:smiley:


#35

Hi. I used the 3tb img file from here and i fix my 3tb mycloud without any problems. I replaced my damage hdd and i follow instruction and after 40 mins, everything start immediately. After that i just updated my frimware from wd mycloud dashoard and thats it. Thanks a lot for this tutorial. Hope you fix yours wd mycloud same easily like me.


#36

SOLVED: I did a Quick Restore, SCP’d the sq-4 file to /nfs/Public, and installed from there. Everything was successful and I’m at latest v4 (Debian Jessie) now.

This restored image worked great on my 2TB drive! Now I’m trying to upgrade to v4 of the firmware, but I’m getting various errors. The first time I tried the automatic updater, it just stalled at 10% and never completed. Then I tried to use the manual updater via a file, but it complains that there is no room available for the update.

After that I did a built-in factory restore, then tried the auto-updater again. This time it seemed to complete and reboot, but it’s still at v03.00.03-413.

So it’s Debian Linux, why not use dpkg to install it manually…

dpkg: error processing sq-040405-101-20161110.deb (--install):
cannot copy extracted data for './CacheVolume/upgrade/rootfs.img' to '/CacheVolume/upgrade/rootfs.img.dpkg-new': failed to write (No space left on device)

Any thoughts on this issue and how I might fix it?


#37

Just wanted to share my image of a brand new/virgin 6TB MyCloud hdd.
In case anyone wants to restore their 6TB device.

Download: wd-my-cloud-6tb.img.xz (1.2GB)
https://mega.nz/#!atxDTAxI!Quv3s09WkwYubh-mlqJ8U-SPi4X9z1O1zA-BmIBlJSk
md5sum: 23a8a6620c2e17bf69047927bfdc1aa6

Restore (as root): xz -c wd-my-cloud-6tb.img.xz | pv -s 6001175126016 | dd of=/dev/sdX


#38

Thanks very much for the upload, any chance you could get a minimal image (2tb one in img form comes out to only 4.8GB) and format as .7z for sake of consistency? I’d love to mirror on my own account to ensure it sticks around but I can’t even expand your img file without filling up my 2tb HDD on my PC :P. Thanks!

Edit: To clarify, your raw image is wasting a lot of space by having the zeros included. If you could trim it and reupload I could extract and recreate a .7z on my end


#39

Hi djh816,

dd-images include all zeroes, yep. thats why it’s so big.
How did you produce your image? I’m surprised its so small.
I basically did a “dd if=/dev/sda | xz -c > img.xz”

Unfortunately, I already wiped my drive and re-used it someplace else, so I can’t take another image.


#40

Ah no worries. dd has a “conv=sparse” flag (and conv options available) for not including the zeros