[GUIDE] Debrick a completely dead MyCloud

Ok this is how I just resolve the same issue, I put a blank disk in bay 1, powered it down, got a pin held the reset button in while plugging the device in, wait 40 secs, let go, now goto the dashboard and flash your firmware.

Hi. I have my 3tb cloud dead. I have read a lot in these forums. I always have the same question. Do I have to completely format the hard drive or do I leave the partitions as they are now? I already have the value files backed up to another disk. Would it be better to format all partitions one by one and leave them with the default capacity or delete all partitions and leave the disk blank with a single 3tb partition? I await your help. Thank you.

It comes down to which method you use to unbrick a single bay/single drive My Cloud. And which generation of My Cloud you are unbricking. It also depends on if you are putting a new hard drive into the single bay enclosure.

For example if one follows user Fox_Exe’s method for unbricking, there are steps to create the partitions and then format a few of them.

One could try to just write (DD in Linux) the various img files to their respective partitions assuming one is using an already correctly partitioned and formatted existing single bay My Cloud drive and see if the device will boot. But in many cases it’s best to follow the directions, which may include deleting the existing partitions and recreating them, then writing the various files to them as indicated by the directions.

Generally the single bay/single drive My Cloud hard drives are partitioned in a specific way (values) and have a number of different partitions, one of which is the user partition. Most times if one follows the direction they will erase any existing partitions on the drive.

Thanks for answering. yes, my cloud is single bay and Gen 1. my purpose was to format each of the partitions and then follow the steps of installing a blank 3tb drive image. How is the dd function you mean? you know the link of those instructions ?? Thank you.

DD is generally a Linux command. Because the My Cloud hard drive operating system is a form of Linux, various unbrick directions, including the one in the very first post of this thread, use Linux to create the partitions, format the data partition, and copy the IMG files to the relevent partitions. Generally not all partitions need to be formatted, usually its just the data partition on the first gen that needs to formatted.

If one doesn’t want to use the unbrick methods detailed in this current thread, one can use various other methods.

The following directions are from user Fox_exe and many have used them to restore the My Cloud OS to a existing or new hard drive. Because there are two different single bay My Cloud versions the unbrick method is different for each. You cannot restore a first gen v3.x/v4.x My Cloud to use the newer second gen v2.x firmware. Check the P/N number on the bottom of the single bay/single drive My Cloud enclosure. P/N that ends with “-10” is a second gen v2.x firmware single bay My Cloud. A P/N that ends with “-00” is a first gen v3.x/v4.x firmware single bay My Cloud.

The main Fox_exe repositories for multiple My Cloud models can be found here:
https://fox-exe.ru/WDMyCloud/

First gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD.txt
The img files needed for the first gen Fox directions can be found in the WDMyCloud-Gen1/Backups folder in the main Fox_exe respoitory link above.

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
Various files used in the second gen Fox_exe unbrick directions can be found in the WDMyCloud/WDMyCloud-Gen2 repository.

As I told you yesterday, my cloud is 3tb gen1. I have followed the steps in this tutorial: [GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud and I had a serious problem. As I mentioned, I kept the original partitions on my disk although I could not access the cloud due to a power cut. use the 3tb disk copy that corresponds to mine. I downloaded that blank disk copy from the link there. I followed all the steps but once the whole process was finished I went to Gparted to see how everything had turned out and my surprise is that all the partitions had disappeared and I had a blank disk without a partition table and now it lets me create the partition table again . Would the disk be corrupt or would it have been damaged when doing the process?

Reboot the computer you are using to view the contents (using Gparted) of the My Cloud drive. If after reboot Gparted is still showing an empty drive then it would appear you did something wrong during the unbricking process using the directions you linked to.

If I understand that process in that thread it would appear its trying to write the img file; partitions, formats, and file data to the corresponding partitions of the My Cloud hard drive. As such if there is a problem with the process it could result in the process aborting or completing but with disc errors.

Reading through that : [GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud thread it would appear a great many had problems of one sort or another when trying to unbrick their My Cloud using the files linked to in that thread and the directions used in that thread.

Personally I’ve had issues in the past using the various methods to unbrick mentioned in this subforum. Most all have fail for me due to one cause or another. I’ve had good luck with the Fox_Exe directions posted above to unbrick a number of drives for my first gen v4.x single bay My Cloud. However its easy to make an error, usually I end up running the unbrick process two or three times before it works properly. But as with any unbrick direction one has to be careful on ensuring they are working with the right hard drive (/dev/sdx) and writing the files to that hard drive. Its why I usually remove all other hard drive other than the My Cloud hard drive from my system and use a Linux Boot Disc/Boot USB Flash Drive to boot and perform the unbrick process.

Dear Friend. the 3tb drive image may be corrupted because the result was a disaster. You spent quite a while doing the process of copying the image to disk with the correct instructions but it didn’t work. now I have a 3tb disk of footprint because there is no way to re-create a partition table on it, neither on linux nor on windows. I only have the option to buy a new second hand equipment and pray that it does not break down again with a blackout. thanks for your wise advice but i can’t retry the process with this hard drive anymore.

If Linux can access the 3tb drive then one can create the necessary partition structure on it. The Fox_exe directions I previously posted include the steps to create the partitions. When using Linux make sure to be in root user mode when issuing the various unbrick commands.

in linux it finds the disk but for example gparted when it tells it to create partition table it gets an I / O error message. Following Fox’s steps it won’t let me create the partitions because the unit doesn’t have a format of any kind, only gparted recognizes it but it won’t let me write anything in it. I think it has failed in the process I did earlier to pass the virgin 3tb image that must be corrupt.

What is the specific error message you are receiving?

Have you tried initializing the disk to GPT or MBR?

I only tried it in Gpt, not in mbr. tomorrow I will try it in mbr but I think it will not let me. in Msdos I tried and also failed.

There are any number of tools, if using Windows, that one can use to try and force format a drive or to find out what is wrong with a drive.

For example on Windows there are tools like the MiniTool Partition Wizard (free) that may offer more options than the built in Windows disk manager:
https://www.minitool.com/partition-manager/partition-wizard-home.html

Thank you bennor.

For first gen MyCloud (Single-drive) need GPT. MBR (msdos) not supported by bootloader.
Partition’s numbers is important too. Size not matter.
Use parted (console) or Gparted (graphical) and Ubuntu or Debian live-cd/usb.

The reaon I suggested using MBR was due to an earlier post where the person indicated they were getting I/O errors using Linux Gparted.

The idea was to just format and partition the drive using any method possible at that point since they were having trouble with the drive.

If I remember right, when they unbrick (using your directions) the Linux Parted program will destroy the MBR partition anyway and set it to GPT. At least I think it did that on several of the drives I’ve put into a first gen over the last couple of years.

So you recommend me to try to create a single partition in Mbr, format it in ntfs and then start all the steps? I think I understood that in mbr you could only partition units up to 2 tb and for more capacity the Gpt was created. is that so?

As previously asked; can you post the exact error message you are receiving when using Linux? Previously up thread you indicated you were getting an I/O error when trying to access the drive using Linux. If you are still getting that error please post the exact working of the error message.

If you are having trouble formatting the drive with Linux, try Windows and if that fails try one of the third party programs, like the one linked to above, for formatting a drive. The whole point is to get the drive into a usable state by the computer. From there one should be able to execute the unbrick directions (that include proper drive setup and partitioning) on the drive.

If one is using Fox_exe’s directions and starting from step one of the first gen directions (using the Linux command line interface), it really doesn’t matter HOW the drive is formatted or partitioned. During the unbrick steps one is removing the existing partitions anyway, and the directions specifically state to create a new drive table using GPT before creating the partitions (and their size) needed for the My Cloud. The specific portion of the directions are posted as follows, as an example:

1. Use fdisk -l (or parted -l) for see what name have you WD's HDD.
* For me - its /dev/sdb. Replace it to your hdd name!
2. Run parted utility:
parted /dev/sdb

3. Type "print" for see what partitions exist on disk
4. Remove all: Type "remove 1" (where 1 - number of partition)
5. Crete new table:
mklabel gpt
mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M 100%
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
set 1 raid on
set 2 raid on

6. Ok, type "quit"

Friend Bennor, thanks to your advice I resuscitated my hard drive with Mini tool partition wizar. With this application I was able to create a GPT partition and a single partition. I have followed all the steps in the FOX-EXE tutorial for unbrick my cloud. I have managed to make all the partitions, format the SDB4 in EXt4 and create the RAID 1 and 2. The problem is that I am stuck in the step of passing the firmware file to the / mnt folder within sdb4. I have that file downloaded to my USB stick and I don’t know how to go to that folder or use it from the USB stick. The step is as follows:

  1. Download one of arhive’s to / mnt folder:
    v3.04.01-230: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
    v4.01.02-417: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz

  2. Extract by console:
    tar xvfz original_v3.04.01-230.tar.gz

These are the Fox-exe instructions that I am following. Can you help me continue with that step? Giving that instruction does not start any type of download. I am using System RescueCD linux with Root access. Sorry for my ignorance but I do not know anything about Linux and I am starting for the first time.
regards

You can try to use the Linux copy command to copy ONE of the downloaded files from the USB drive to the /mnt folder. This assumes one is in the location on the USB drive where the file(s) have been downloaded. The command line command would be something like the following:

cp original_v03.04.01-230.tar.gz /mnt
OR
cp original_v04.01.02-417.tar.gz /mnt

Then one would navigate (cd /mnt) to the MNT directory and execute the unpacking command on the file as the directions indicate.

tar xvfz original_v03.04.01-230.tar.gz
OR
tar xvfz original_v04.01.02-417.tar.gz 

Once the files are extracted from the .tar.gz file one can proceed to the next step in the directions.

On a side note, I’ve generally used a Linux Boot Disc/Flash Drive to boot my PC to Linux and perform the unbrick process using the Linux Terminal (window. Don’t know if System RescueCD linux has all the proper modules that one uses during the unbrick process. Ubuntu is one popular Linux Disto with a boot disc/flash drive option.