General Error 500 on My Cloud 2TB

Hi all,

I’ve just purchased a 2TB My Cloud and have copied about 70gb of photos to the Public\Shared Pictures folder. I have 2 folders which I’m trying to view. Using the My Cloud app at home via wifi, One folder works fine but when I try to access the other one I get a “WD General network error 500” message. I’ve tried my iPad and 2 IPhones (all on ios8) with the same issue.
Firmware is upto date according to the app. Using a MacBook I can view all the files via Finder.

Any help on being able to access via the My Cloud app would be appreciated.

Hi juitz, welcome to the WD Community. Have you tried rescanning the media library? For the steps on how to do it, check page 103 of the manual for more information.

I too am getting this error on ipad and iphone app. Started happening after the last update. I persume its something WD have done in the lastest update?

As much as I like my mycloud device, its so hit and miss iand its been going on for over a year now. Are you actually going to ever sort this product out or withdraw it as it doesn’t function how advertise it functions. 

Also whilst i’m moaning the lack of support and abritiary responses I get from wd support make me think you guys dont actually care about the product nor the users you just want to flock this whomever and not bother about the consequences?

please fix the app and get some decent support 

Also i have tried all truble shooting soloutions from the guide but alas to no avail…

So I’ve jsut relsolved this issue i’m having.

I logged on to wd my cloud dashboard via a browser 

went to cloud access and deleted any devices i was having issues with, iphone / ipad in my case.

then on my iphone and ipad opened mycloud app and logged back in and it all worked fine.

let me know if this resolves your issues.

I have the same error on one of my folders, and it is the one where I backed up all of my data from my laptop before I swiped it clean.
Now I can’t access any of that data because of this error.
I have tried the “rescan” mentioned, and I have also tried removing devices from cloud access and logging them in again.
I still cannot get access to my data.

Not sure exactly what I did, but I now can access that folder from my MacBook laptop via wifi, but I still can’t access that folder from my iPhone or iPad.
The good news is that at least I know the data is not corrupted or lost.
The bad news is that I still can’t access it from my mobile devices.
Any ideas?