FTP only works with user admin but NOT with other users

Hello all,

I cannot access a BACKUP share via FTP with some particular user.  I got ‘Login failed’ error.

Instead, using the admin user (with its password), the FTP access is working properly from Windows 7. Both from ftp command line and also from Cobian Backup tool configuring the ftp access as the target.

With that particular user I can map the BACKUP share from Windows 7, using that user (username & password).  With a wrong password the Share cannot be mapped from Windows 7, so I have checked that the user password works and the share is no Public.

Is it a general known problem?   Does anybody can use local (not from external internet) FTP with any user other than admin, for a non public share?

Many thanks!

I just tested connecting via ftp locally using a non-admin account to a non-public share (called LizzieFiles) - had no problems at all. See screenshot below (if it doesn’t show up see this alternate link ->  http://imgur.com/WSq8u1t )

Thank you Cybernut1 for your answer.

Actually it was not working for me but now I have managed it to work with some strange steps.

I had the ‘Anonymous None’ seting in the FTP Access of the Share Access.  In this way when trying to ftp login usng CMD screen, I had the message  ‘331 Any password will work’.  This seems to occur when a user is not recognized by ftp.

Then I enabled ‘Anonymous Read / Write’ seting in the FTP Access of the Share Access.  Just to test access via Anonymous and it worked.  Then tested using my user and get  ftp message ‘331 User xxxx OK. Password required’.  So now it seems the non-admin user is recognized and login ftp succeded with the correct password.

Finally I disable Anonymous access  ‘Anonymous None’ in the FTP Access of the Share Access.

The ftp login of my user is still working.   So it seems something regarding ftp non-admin user validation access was ‘arranged’ by enable and disable Anonymous access.

I really wanted to secure the access via SFTP / SSH, but I have seen in some other threads that it is not possible without a hack of enable other users than SSHD to use SSH. Hope WD will enabled that, because I’m not willing to do such hack.

Thank you Cybernut1 for yout help.

For now you can just use FTP.

BTW, I never had to do anything like turn anonymous ftp access on and then off, to get mine to work. It worked normally for me. I actually figured out a hack to control the ftp access from the shell (different from my sftp hack). Basically, I have restricted ftp access to USB drives to specific users, which otherwise by default get opened to all ftp users, just like the Public share.

As for sftp/ssh, it was my hack about sftp that you must have seen ( http://community.wd.com/t5/WD-My-Cloud-EX2/SFTP-possible-on-EX2/td-p/715812 ). Yes, that hack is safe but isn’t that easy to do. I seriously doubt WD will implement sftp, but encourage you all the same to vote on the feature request for it. To vote, click the up arrow to the immediate left of the thread title in the linked page here -> http://community.wd.com/t5/Personal-Cloud-Ideas/Please-support-sftp/idi-p/650551