Firmware Update via SSH

Ok, I managed to work the script but I’m stuck on yellow light now… doesnt looks good from this pow :frowning:

I was going to suggest to send it off to be replaced under warranty but before I saw your post you already stated that you had taken your MBL apart. Personally, I’ve not tried that script on my MBL because if never got bricked, so no need for me to crack-out a Live Ubuntu and use the de-bricking script.

I pointed you to that script to run on your bricked MBL because from reading the comments and comments from other sources, it seems to do the trick, but you’ve got to follow instructions precisely.

I guess your MBL can still be recovered, but it needs more work and someone who’s a time served Linux/Unix guru.

Personally, I’ll be studying that script just on the off chance that one day I may have to de-brick my MBL, but I do back-up regularly so if it did die, it would just be a major inconvenience.

If I do come up with a solution, you’ll be one of the first to know.


you seem to be an intelligent chap to ask, assuming ssh is enabled and you can ftp into the drive, could you not just copy over a healthy working linux system from either a backup or from a working MBL? Not that I need too I just wondered!


I don’t see a reason why the OS can’t be cloned from a working MBL.  I was thinking about doing this once my own MBL’s warranty expires, and that is to take an image of all the partitions apart from the data partition in a view to simply copying back over a corrupt OS partition.

You would have to enable SSH and through Telnet and the Web UI do a little bit of a clean-up to re-establis users, shares and the configuration.

Thing is, in three years time there may be better offerings of network storage media so it may be better to open-up the MBL, get rid of the controller and keep the drive for use within a PC, if the drive is still healthy.

I would not even have to reformat my 1Tb drive.  If it’s a windows system, just install one of the few available NFS file system drivers.

A missed opportunity was the removal of the USB port and not having something programmed in the MBL’s BOOTROM where if it notices a particular file on the root of the USB storage media, to use that to unconditionally replace the OS partition and after doing that, boot-up off the restored OS and then run recovery procedures.

Another mistake is that the share and user configuration files are kept on the OS partition where they would be better stored on the data partition.

Just thoughts . . .  :smiley:

I seccessfully unbricked my mbl without ssh enabled. Will post detailed guide later.

4 hours later: Here is the guide.


@Myron, hmm yes sounds logical :slight_smile: so there was a USB port once? I have only just bought my MBL, previously I had used a HDD attached to my Netgear router which functioned as a basic media server but was slow and limited in what it could do. I understand what you mean about the USB port, could be used the same way I upgrade my non networked TV and BD player, put the firmware image on a USB stick, on startup when the unit finds the stick and a valid firmware image it updates/restores the system firmware. Fail safe?



At first I would like to thank you for this good guide.

I installed ext2fsd and can see all written in your messages…

But when I try to change disable to enable -I have message Disc protected from write.

I tried to open the access from tab properties of 3th and 4th partitipon of disc -I opened full acess to ALL USERS, Admins but despite of it the access to disc is denied, also I can’t copy the file with firmware to 5th partition the same reason.

Remarks: I haven’t the DATA VOLUMES as next lower level of 5th partition is SHARES/Public. Is  it normal?

Please inform me what you think about this protection? How I can  receive the access to disc?

Thanks in advance,

My UI stoped working, got SSH.

I did exactly as printed in the 1st anwser.

MyBookLive:~# /usr/local/sbin/ /DataVolume/shares/Public/apnc-021009-124-20111113.deb 10:52:21:: ( /DataVolume/shares/Public/apnc-021009-124-20111113.deb )

Then nothing happens. I read that there is no progressbar etc but I have waited 30 minutes and UI still does not work. The share is avaible 8as before) though, and I can ping it. What did I do wrong?

I have never had good results unless I did the following

  • copy the firmware into /CacheVolume and then rename to updateFile.deb

  • execute the following /CacheVolume/updateFile.deb

Remember to put the updateFile.debin that location first!

Not sure, but I think the update script does not perform the uopdate if the installed firmware is newer or the same?

I have used my previous post example to re-install the current firmware

which I have had to do from time to time, and it has at present, always saved the day

havent tried to do it with an upgrade though, I would imagine it could/should work for that also, not sure either

I have SSH enabled, and I’ve downloaded the .deb file I want and saved it in the Public folder, and changed the name in your script to the name of the file. Can you give me some idea as to how long this should take?  Should anything show up in Putty? When I ran your script, I got this:

MyBookLive:~# /usr/local/sbin/ /DataVolume/shares/Publi c/apnc-023205-046-20120910.deb 03:29:46:: ( /DataVolume/shares/Public/apnc-0 23205-046-20120910.deb )

 Then nothing.  The light on my MyBook turns purple, and we wait!  Nothing seems to happen until the connection finally times out.  What am I doing wrong?  I’vet tried with more than one update file, in case it’s the current version.  They all do the same thing.  Hints? Suggestions?

If you call up tech support 1-855-556-5117 and tell them your issue

  • transfer to level two tech support they’ll help you properly reset your WD Net drive

Apparently, after you updated the software the device didn’t reset properly leaving us all hanging.

Talk to level two and they’ll sort it out 

Mine works great now