Firmware Update - 12 hours and counting

Bought my MyCloud Duo 2 days into the outage… Finally started setting it up last night. The app found my unit (on the 2nd attempt)… said an essential firmware update needed to be conducted and to restart the app when that’s done… twelve hours in an the unit is still “updating”! Any suggestions*, hive mind? (*Suggestions that a technically-challenged layperson might be able to understand I may add.)


3 days since the outage gone, still updating. I have the same issue. I previously was able to use the app and device with the same internet connection and modem,ISP. nothing changed in my setup. Slow led breathing…


What versions were you running beforehand?

1 Like

Same issue! First Setup Not possible, the led dont stop Moving slow, the Message in the App is „ Firmware muss aktualisiert werden“


Stefan, I was having the same issue before the outage.

This is my last message in this forum and ever on any WD community.

My cloud home duo 16tb was working fine for 3 days, after 3 days (I have the same network,cable,ISP,settings etc.) it suddenly stopped working, then the outage happened. I’m trying to update its frimware for at least 3 weeks with no success.

I even took the white useless box to my mom’s home with an internet from whole different ISP. Let is stay there for 3 days and still no frimware update happened OTA as they promise.

When I connect to the tech agents they keep sending me useless links with useless information. And nothing helps…

Today I give up. Tomorrow my lawyer is going to sue WD office in my country + the reseller. I’m done with this company.

I hope you find a solution.


similar problem my cloud home duo… for 36 hours the device downloads 209 megabytes every 6 hours, breathes light and says that an update is in progress. The device is new, never had access. the problem is massive… mycloud gen2 os5 works…


I have a Home Duo 6TB and getting the same issue. Can’t even set it up because when I try to find it, it says that it’s in the process of upgrading the firmware. I can see it on the network, it has an IP address and I can find the “Public” and “TimeMachineBackup” folders (i’m on a MAC) but can’t log into it, can’t access it, can’t configure anything and it’s been doing this upgrade for 6 days now.

Has anyone found a resolution for this issue. Oh, and I did do the 60 second reset, multiple times.

I understand that the devices are new from the store or are there any that worked and broke after hacking?

In a civilized society, company representatives in such terrible situations highlight the problem itself and how to fix it, support customers … WD just abandoned everyone. We understand that an attack has been made, but we need to tell people what to do with their newly bought expensive devices that just waste energy and do not give any access … My Cloud Home was originally a very controversial device with a lot of problems, but now a joyful person coming from the store receives a box of plastic, which just glows and EVERYTHING!!! Support is silent, there is no information on the site … This is wrong! You need to either connect techno-bloggers or media…

1 Like

So, i’m assuming the answer is “No”, you have not resolved this issue.

1 Like

I spent 40 minutes on the phone the other day with Tech support in the UK… they walked me through a factory reset of my unit (since I bought it 3 days into the cyber attack I’ve yet to put anything on it), told me that, since I’d bought it from a "3rd party supplier " (! Currys!) it could indeed take several days for updates to be installed… I’m to ring them back tomorrow, watch this space!

1 Like

Everything from the Netherlands to Kazakhstan is littered with this non-working ■■■■, and they are still indignant that you bought it in the wrong place??? Shameless!!! And what few days? I have been showing a movie called “breathing of a white light” for 120 hours. 2023. comedy thriller. The most stupid creation of this HOME would be to make it like NEXT-GEN ex2 / mcgen2 / pro - you could manually download this firmware and install it - profit! Now imagine that everything will work, you want to store data in a device that can pick it up just like that??.. Not a HDD failure, not an electronics failure, but simply “firmware updating”… I’m not. And the end of the movie is still unknown, because. HOME boxes around the world are just being unboxed right now… by satisfied (so far) users.

Well, if without emotions, then this is how I see it technically. During the first 24 hours with an interval of 6 hours, the device downloads exactly 209 megabytes, then for 6 hours there is a small ping of several tens of kilobytes up / down . After analyzing the size of the firmware “WDMyCloudEX2Ultra_5.26.119_prod.bin” - 169 megabytes, in our case it is very likely that it is the firmware that is being downloaded, and it does not matter whether you reset the device or connect it for the first time after purchase. Then the downloaded firmware tries to do something (formation markup / raid / etc), but it fails. As a result, after 6 hours the process is repeated. And so 24 hours. Then it swings for the last time and the device hangs stupidly “firmware updating”.
So. If devices upgraded before hacking work fine, we conclude:

  • or wd gives our devices broken firmware
  • or wd prevents our devices from downloading the firmware completely
  • or wd stopped product activation for security reasons

It doesn’t matter what caused it - YOU ARE LEGALLY OBLIGED TO SUPPORT THE SOLD DEVICES!!! At least WRITE ON THE SITE that there is a problem and it is TRYING TO DECIDE (I would like to think …). The support service in my case is generally silent (boxes with a “surprise”, probably a lot of people bought in the country) …
You didn’t sell a car that didn’t have a light bulb, you sold a car that WON’T EVEN OPEN!!!

1 Like

In addition to the My cloud home duo brick, I have My Cloud EX2 Ultra on OS5, I have My cloud gen2 on OS5, they were updated before the attack and are fully functional, they allowed local access before and during the attack, also now. Even if I wanted to buy a new My Cloud EX2 Ultra from the store now - I would at least get local access, as a maximum (100 percent) - access from the outside, just by downloading the firmware. Home - other… The amount of firmware My Cloud EX2 Ultra cited in the message to understand what exactly My Cloud Home Duo can download every 6 hours when connected, this is very likely - the firmware.

1 Like

There are also several synologies that work simply and quickly without making you nervous. By the way, at the same time I wanted to say thank you to HOME for getting to know synology, when 3 years ago I bought the first My Cloud Home, I was horrified, pulled the disk out of it and threw the box into the trash… I thought that something had changed in 3 years … It turns out that it only got worse.


Still no change?

1 Like

No :slight_smile: still the same problem for almost %99 of mchd devices. I sued the local authority of wd and the reseller in my country, my lawyer is sure that Im gonna win and return the product for full refund, meanwhile I’m still having the same frimware update issue. At least it feels good to see people like me in wd forums and to know that Im not alone. I stopped counting the day, Its updating itself since the outage fixed(obviously its not fixed)

Here’s my update: came five days after the “factory reset” it was still giving that maddening slow blink… the help desk guy said: looks like it’s a defective unit. They could send a replacement (after I had sent them back my unit) – but any replacement they sent would be a “reconditioned” unit which had been sent in for repairs - in perfect working condition, I was assured. Ummmmm: nope. Back goes one £300 paperweight to the store where I bought it, and I’ve made sure the new NAS drive I’ve ordered is NOT from Western Digital.

I am not sure why MCH users don’t read the forum for more than a few minutes or use the search function. It is well known that the MCH which uses the same basic firmware as the Duo and Ibi, will not do back to back firmware updates. It will do update from factory to 7.16 then wait 1 week for files to finish indexing and then do the next firmware update.

The process is documented in the OTA update history in the debug_logs.tar.

does this mean that our devices have not become bricks? So I have to buy a device, turn it on and go away for 2 weeks, right? Was it with everyone who bought it?

The second question is: is there at least one person who has a new device working after the attack? Someone waited a week, as NoPlex wrote?