Firmware does not update from USB

My brand-new WD Live box won’t update its firmware even from a USB drive. I’ve noted that it won’t update from tne network as per  this note about firmware and NFS, so I tried to update from a USB drive.

I followed the instructions in the instruction web page for 1.10.x, but that does not work. I don’t have an icon that checks for the settings, and when I select “check firmware update” the SMP does not find the USB drive files. Instead, it looks online.

Please note that my current version is 1.01.43 – at least minor releases old – and when I check for updats, I get an offer to update to 1.03.07i via the oinline service. I’m doing all this via my web browser GUI.

My current guess is that someone has sold me a box that’s too old to be updated. Any ideas?

That’s correct;  the Check for Firmware Update function ONLY looks for the files on the server.

If you’ve got the correct files on the USB disk, there will be a NEW FIRMWARE tab pop up in the “Ribbon” at the bottom;  it’s orange.  It may take a minute for it to appear; longer if there’s a bunch of other files.

Your box must have been sitting on the shelf a LONG LONG time…  that version was the very first version shipped almost a year ago.  That’s not a minor release old; that’s 9 major releases old.  ;)

You must have at least three separate files on the USB disk…  a .ver, a .bin and a .fff  (the .info file isn’t really needed.  It’s just a README-type file that the WD will display – but not on the version you have now.)

If you plug in the USB drive and nothing appears to happen, wait a minute or two and then press the EJECT button on the remote.   If nothing happens then, either, then it’s most likely your SMP isn’t recognizing the drive itself, and you should try a different drive.

1 Like

Thanks for the ideas about firmware uipdates.

I did have a lot of files on the one USB drive; I left it plugged in overnight, but in the morning I didn’t see any “new firmware” popup in the ribbon.

I then tried a different blank USB drive with only the firmware files.

Your remark about the location of the icon, in the “ribbon,” proved crucial.  I remembered I had turned off the “auto detect firmware update” because I’d found the constant popup to be annoying when it didnot work… I re-enabled auto firmware update (in the Settings -> System menu), and immediately up popped 1.10.x as the firware update.

The update was successful. Thank you very much for pushing me to re-examine what I’d done!