Firmware 4.05.00-315 Discussion


#123

Similar behaviour here. Sometimes it sleeps for hours, sometimes only 20 minutes. I think it’s the best we can get for now.

Can you test this change at the end of the /usr/local/sbin/monitorio.sh script?

                touch /tmp/standby
                enterStandbyTime=`date +%s`
                echo "Enter standby"
	            # turn on solid blue if applicable
                ledCtrl.sh LED_EV_DISK_STBY LED_STAT_IN_PROG
                sleep 5			
                if [ "$1" == "debug" ]; then
                        echo "`date`: Enter standby "
                        dmesg -c > /dev/null
                fi
                for i in ${drivelist[@]}; do
                        hdparm -y $i >/dev/null
                done
                sleep 5		
    		break

I think calling ledCtrl.sh before hdparm could MAYBE avoid the 7/8 seconds sleep times. You need to reboot to make the changes work…


#124

That change may help. But in the past it was ledCtrl.sh, date, awk and others that I can’t remember. Also
you just need to /etc/rc2.d/S18monitorio restart
If you look at the cron jobs. You will see that every 8 hours (0,8,16) is does something. It wakes up at 3 in the morning to do housekeeping. Check for new firmware.
I was playing around with vmtouch to see if I could get rid of the 8 second sleeps. No luck so far. Also looking into running from USB. I think these things could work on the gen1. But the gen2 is a different ball game.


#125

Made the change, testing now. Going to give it a few hours to see what happens (if anything).


#126

Sleep is a bit better with the monitorio script modification in conjunction with mount tmpfs modification. Still getting wakeups though. The time in the snapshot below is a bit goofy because for some reason the time was off by six hours until I changed NTP to manual then back.

05 06 00:09:35 00:13:48   253  0:04:13
05 06 00:24:00 00:29:55   355  0:05:55
05 06 00:42:10 01:33:32  3081  0:51:21
05 06 02:10:24 02:14:11   227  0:03:47
05 06 13:50:24 13:53:12   168  0:02:48     <----- Reset NTP to fix time
05 06 14:07:29 14:08:08    38  0:00:38
05 06 14:18:21 14:20:28   127  0:02:07
05 06 14:30:40 14:37:40   420  0:07:00
05 06 14:47:53 16:01:10  4397  1:13:17
05 06 16:11:22 17:01:26  3003  0:50:03
05 06 17:11:38 17:30:23  1125  0:18:45
05 06 17:42:38 17:57:18   880  0:14:40

#127

Perhaps something “triggers” the network?

I get only longer sleeptimes at night with my raspberry, PC and Smart-TV turned off.

Also i disabled cronjobs.

05 06 02:28:37 07:51:51 19394  5:23:14 <--- everything else was off
05 06 08:31:20 08:33:04   103  0:01:43
05 06 08:53:29 08:59:54   384  0:06:24
05 06 09:20:19 10:17:34  3435  0:57:15
05 06 13:17:11 13:33:05   954  0:15:54
05 06 13:59:44 14:03:13   209  0:03:29
05 06 14:23:38 14:37:58   860  0:14:20
05 06 14:58:24 15:50:12  3107  0:51:47
05 06 16:10:37 16:42:33  1916  0:31:56
05 06 17:02:58 17:44:05  2467  0:41:07
05 06 18:04:30 23:01:48 17838  4:57:18 <--everything else off

But i can’t see 7 seconds wakeups in your logs, so maybe at least these are gone…


#128

Yes the 7 and 8 second wake ups seem to be gone. Will add stopping the cron jobs to see if that changes anything. I’m not sure what on my network would be polling as I typically have only one Windows 10 PC, one switch, one Roku 2 XS, an Android smartphone, and the broadband provider’s router (Arris NVG589) active on the local network. Will see if I can find past logs, pre 315 firmware update to see what they show and compare. Will continue to experiment.


#129

I’m curious. Are we trying to get the most sleep time or are we trying to fix the problem created
by the latest firmware? 100% sleep time is impossible. The cron jobs need to run. Are there
problems in the cron setup yes. I think the sleep times before this firmware upgrade of 70% to 80%
were fine with people. The 8 second sleep time is a different problem. Yes the 8 second sleep
will go away if you stop cron. But some cron jobs need to run.


#130

For me its a combination of both but more towards fixing a problem with the latest firmware. When I disable Samba in the latest firmware the sleep time jumps back to where it was with prior firmware.


#131

nothing is impossible Rac!!

we use to get 4 days of sleep or did you forget that? do the math, 4 days of sleep out of 24 hours is ?


#132

More data points. Left the device alone most of the day and finally got some respectable sleep times from it this afternoon (six hours).

05 07 07:18:47 07:22:01   194  0:03:14
05 07 07:32:13 07:34:12   119  0:01:59
05 07 07:44:24 07:52:01   457  0:07:37
05 07 08:02:14 08:05:10   176  0:02:56  <--- Streamed some video at 8:05 to 9:57
05 07 09:57:48 10:29:43  1915  0:31:55
05 07 10:39:55 11:21:40  2505  0:41:45
05 07 11:31:52 12:05:34  2022  0:33:42
05 07 12:32:09 16:15:03 13374  3:42:54
05 07 16:25:15 18:44:58  8383  2:19:43

#133

Interesting math. 96 hours of sleep out of 24 hours.


#134

additional data points:

05 07 18:56:12 19:03:29   437  0:07:17
05 07 19:13:42 19:32:07  1105  0:18:25
05 07 19:42:20 19:45:14   174  0:02:54
05 07 19:55:26 21:01:38  3972  1:06:12
05 08 22:46:04 04:26:39 20435  5:40:35
05 08 04:36:52 05:53:21  4589  1:16:29   <--- This is about the time I turned on a Win 10 PC and Roku at 5:53
05 08 06:10:41 06:44:05  2004  0:33:24

#135

No wake up at 03:00 ? Did you turn cron off?


#136

Yes, I turned off cron, per my earlier post above to see if it would help.


#137

Few more observations. Turned off the My Cloud last night, powered on this morning with a change in the user start script to remove stopping Cron. Not seeing any (so far) of the 7/8 second sleep/wake ups that plagued me earlier. However I did notice yesterday that when a Win 10 PC that has mapped shares wakes up the My Cloud in turn wakes up. Removed the mappings and rebooted the Wiin 10 PC. Today noticed several instances where that Win 10 PC (without any Share mappings) was woken up from sleep and the My Cloud in turn woke up from sleep.

05 09 06:11:43 06:12:38    55  0:00:55
05 09 06:22:50 06:38:11   921  0:15:21
05 09 09:26:09 09:32:16   367  0:06:07 <-- Sleeping PC wake up at 9:32
05 09 09:42:28 13:01:13 11925  3:18:45 <-- Sleeping PC wake up at 13:01
05 09 13:11:25 13:46:37  2112  0:35:12 
05 09 13:57:51 14:17:10  1158  0:19:18 <-- Sleeping PC wake up at 14:17
05 09 14:27:22 14:34:10   408  0:06:48
05 09 14:44:22 16:01:09  4607  1:16:47
05 09 16:11:22 17:47:07  5745  1:35:45 <-- Sleeping PC wake up at 17:47
05 09 17:57:19 18:13:15   956  0:15:56 
05 09 18:23:27 18:28:15   288  0:04:48
05 09 18:38:27 18:42:47   260  0:04:20
05 09 18:52:59 19:53:10  3611  1:00:11

So it appears some of the My Cloud wake ups on my end are tied to a Windows 10 PC coming out of sleep mode. Haven’t really given it much thought before that when a PC wakes up it is potentially triggering the the My Cloud to wake up.


#138

yeah I remember that… and the pc wakes up quite a bit too. Not sure about win 10 but I had quite a fight with win 7 with defender, defrag and so on… had to deactivate almost everything before it quiet down.

When I was fighting cloud sleep, I basically shut everything down on the network.

Today I can work on my mac without waking the clouds gen 2 because the whole system is on ramdisk. I can even ssh onto the clouds without waking up the drives (sometimes).

but if you are mapped… some things do wake up the cloud…


#139

Now your sleep times look pretty good. Can you post your user start script?


#140

The script I’m currently using:

# Attempts to fix sleep issue with Samba
/etc/init.d/samba stop
mount -t tmpfs -o mode=0700,noatime,size=2m tmpfs /etc/samba/msg.sock/
/etc/init.d/samba start

# Stop unwanted wakeups
mount -o remount,noatime,nodiratime /dev/root /

# Stop indexing services
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

# For OS3 firmware only - stop RESTSDK server daemon
/etc/rc2.d/S20restsdk-serverd stop

#141

My MC isn’t affected by W10 coming out of sleep mode.


#142

Very possible there is some software on my Win 10 PC that may be the culprit. Going to do some more experimenting with that PC.