Firmware 4.05.00-315 Discussion


#183

No idea. I’d assume that if one has the Share already mapped as SMB that Time Machine would treat it as SMB. But that’s just a wild guess.


#184

Short feedback: Running my mycloud with the settings i mentioned few weeks ago and i’m still content:

05 17 18:08:40 03:30:56 33736  9:22:16
05 17 04:01:34 12:09:53 29299  8:08:19
05 17 12:40:30 13:32:22  3112  0:51:52
05 18 15:31:57 03:34:57 43380 12:03:00
05 18 04:05:35 06:38:41  9186  2:33:06
05 18 07:09:20 07:43:45  2065  0:34:25
05 18 08:14:22 09:23:05  4123  1:08:43
05 18 09:53:43 12:08:35  8092  2:14:52
05 18 12:39:13 14:48:11  7738  2:08:58
05 18 16:27:51 20:37:31 14980  4:09:40
05 19 21:08:09 00:02:02 10433  2:53:53
05 19 00:32:40 05:08:34 16554  4:35:54
05 19 05:39:11 12:17:36 23905  6:38:25
05 19 12:48:14 13:05:21  1027  0:17:07
05 19 13:35:59 16:38:58 10979  3:02:59
05 20 17:09:35 12:15:04 68729 19:05:29
05 20 12:45:42 14:33:43  6481  1:48:01
Total Sleep Time: 250:48:01
Start 1493963007
End 1495283623
Total Up Time: 366:50:16 68% Sleep 32% Wake

#185

Has anyone had any luck getting NFS to work on their My Cloud? I had it working and then decided to update and now it’s not working. Everything in my house was reliant on NFS from my My Cloud.

Considering rolling back FW to another version but would prefer to stay on the newest and “most up-to-date” firmware version.

Thanks


#186

I also have a positive feedback after applying fixes mentioned earlier in this topic.
After problems with 4.05.00-315 I decided to revert back to the older firmware version. I followed this topic, and some days ago I decided to give it one more chance.
I edited my startup script (/CacheVolume/user-start) to the following:

# Attempts to fix sleep issue with Samba
/etc/init.d/samba stop
mount -t tmpfs -o mode=0700,noatime,size=2m tmpfs /etc/samba/msg.sock/
/etc/init.d/samba start
# Stop unwanted wakeups
mount -o remount,noatime,nodiratime /dev/root /
/etc/init.d/nfs-kernel-server stop
/etc/init.d/nfs-common stop
/etc/init.d/upnp_nas stop
/etc/init.d/mDNSResponder stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/restsdk-serverd stop
/etc/rc2.d/S20restsdk-serverd stop
/etc/init.d/cron stop

(Please note that I don’t use remote-access, only syncing files at my home WiFi, so I disabled all possible services).

Sleep times before Firmware 4.05.00-315:

05 12 18:43:00 00:52:41 22181 6:09:41
05 12 02:47:13 02:47:59 46 0:00:46
05 12 04:30:15 15:44:43 40468 11:14:28
05 12 16:01:00 16:12:54 714 0:11:54
05 12 16:28:10 17:47:25 4755 1:19:15
05 12 18:00:49 18:08:00 431 0:07:11
05 12 18:20:14 18:30:44 630 0:10:30
05 13 19:09:33 02:40:05 27032 7:30:32
05 13 04:29:40 04:29:48 8 0:00:08
05 13 04:39:58 10:35:00 21302 5:55:02
05 13 10:59:30 11:40:17 2447 0:40:47
05 13 11:50:28 18:02:10 22302 6:11:42
05 13 18:21:31 23:38:19 19008 5:16:48
05 14 00:32:28 01:14:52 2544 0:42:24
05 14 01:25:03 04:05:30 9627 2:40:27
05 18 16:05:48 16:10:14 266 0:04:26
05 18 16:20:25 16:24:17 232 0:03:52
05 18 16:34:28 16:54:17 1189 0:19:49
05 18 17:04:28 18:24:02 4774 1:19:34
05 18 18:35:14 22:09:51 12877 3:34:37
05 19 22:20:01 01:26:12 11171 3:06:11
05 19 01:39:26 01:43:05 218 0:03:38
05 19 02:03:26 02:06:19 173 0:02:53
05 19 02:26:41 02:34:47 486 0:08:06
05 19 02:44:58 04:40:17 6919 1:55:19
05 19 04:50:28 07:36:28 9960 2:46:00
05 19 08:29:52 08:29:59 7 0:00:07
05 19 08:40:10 15:54:15 26045 7:14:05
05 19 16:04:26 18:20:22 8156 2:15:56
05 20 18:32:36 01:51:37 26341 7:19:01
05 21 02:27:22 03:10:43 89001 24:43:21
05 21 03:56:41 11:13:51 26230 7:17:10
05 21 11:24:01 15:00:57 13016 3:36:56
05 21 15:12:09 16:50:59 5930 1:38:50
05 21 17:58:26 17:58:34 8 0:00:08
05 21 18:18:56 18:32:06 790 0:13:10
05 21 18:53:30 18:56:01 151 0:02:31
05 21 19:07:13 19:09:29 136 0:02:16
05 21 20:54:27 20:56:10 103 0:01:43
05 21 22:41:36 22:41:44 8 0:00:08
05 21 22:51:54 23:34:13 2538 0:42:18
05 22 23:44:25 13:27:59 49414 13:43:34

After 4.05.00-315:

05 23 22:55:24 05:58:40 25396 7:03:16
05 23 06:40:29 11:39:23 17934 4:58:54
05 23 11:50:35 15:35:14 13479 3:44:39
05 23 15:45:25 18:00:17 8092 2:14:52
05 23 18:11:29 18:19:12 463 0:07:43
05 23 18:31:25 19:03:06 1901 0:31:41
05 24 19:14:18 04:57:41 35003 9:43:23
05 24 05:08:54 07:14:38 7544 2:05:44
05 24 07:32:00 18:04:34 37954 10:32:34
05 25 18:15:46 02:40:48 30301 8:25:01

I noticed that My Cloud doesn’t wake up when no devices are attempting to use it. So basically, the “/etc/samba/msg.sock/” ramdisk solution fixed the sleep problem for me. It now works the same as in the previous versions.

Thanks to everyone who detects those issues and provides working fixes. It’s a really awesome community.

On the other hand, I wouldn’t recommend buying Wd My Could drives to anyone. In my opinion drive sleep is something that should be always working in the official firmware versions. It’s ridiculous that WD releases firmware which allow drive to sleep for only ~10-20 minutes without any wake up… It obviously affect the life of those HDDs (more than if it was running non-stop).


#187

You can’t blame WD for the problems with samba. Though WD should have known that samba was
effecting sleep. But WD thinks that since the disk drive is a red drive it is ok to run it 24/7.


#188

It’s not only about the samba. Please remember that on the older firmware versions several services had to be stopped in order to stop random wake-ups. I understand that the processes sometimes require disk I/O, but on WD My Cloud this “Sleep drive” option is totally pointless. Without changes everybody’s drive is waking up after maximum 20 minutes of sleep, sometimes faster. In best case It causes the drive to spin-down and spin-up about 72 times per day. There are many opinions saying that often drive spin downs/ups reduce their reliability and cause failures probability. Many users (if not most of them) don’t even know how to use the linux terminal to add process-stop fixes provided by WD community (although it’s very well explained in tutorial topics).
So since the drive sleep option officially doesn’t work on WD My Cloud - it shouldn’t be sold with this feature in the description. I must admit that if I knew earlier about those sleep problems I would pick a different product. I also can’t understand why the whole system is installed on the HDD, The network drive should have a separated flash memory for the firmware (like routers), and that would prevent HDD from being used when not needed. Simply, WD My Cloud drives design is broken and I personally would pick something else if I needed more NAS drives at home.


#189

In some respects we should remember that these single bay My Cloud units are low cost NAS units and as such will lack the features/hardware of more expensive NAS units. In most cases the single bay My Cloud costs $40 to $60 more than the bare WD Red hard drive itself. Other NAS manufacturers sell their units for often $100’s more than the single bay My Cloud units. Because of the low cost, sacrifices have to be made which often leads to various issues.

This is no excuse however for certain firmware problems and the notorious poor coding we’ve seen from time to time with the firmware releases. While some of the problems could definitely be solved by not having the firrmware reside on the hard drive or store logs on the hard drive, because of various decisions by WD and the firmware coders there are constant read/writes to the hard drive keeping the unit awake.

If one is concerned about the sleep issue then there are work arounds mentioned above (and in numerous other sleep thread discussions) that partially deal with the issue. Another option is to simply turn the sleep option off within the Dashboard and hope the drive doesn’t die a quick death due to constant use.

My suggestion either way is to keep a running backup of the My Cloud using Safepoint (or some other method like mirroring with Free File Sync - https://www.freefilesync.org/) just in case the My Cloud drive decides to fail due to the constant spin ups and downs.


#190

You can blame them for not configuring samba appropriately, though, which is the cause of the sleep problems people are having.

If you’re going to use open source software to develop your product, in order to save a lot of dev cost, you have to spend time and money understanding the behaviour of the open source software you are using. If you don’t, then it’s your fault if your product doesn’t work properly.


#191

As I said it is not WD’s fault that samba has this problem. In fact samba group didn’t know this was happening. When
I posted this problem they responded with the tmpfs solution. I don’t think WD even looks at the disk sleep times.
ON the Gen2 I don’t know of a way to get the sleep times.


#192

I understand that it’s a quite cheap NAS solution, but:

  • Prices outside U.S. are greater, so in some countries it can be perceived as a more expensive solution.
  • Some stores are selling WD My Cloud with a “drive sleep” feature in the description. I remember I was looking for these information before decided to buy it.
  • Sellers see the “drive sleep” option in the settings panel, so they are misleading customers, pretending that this option really works.

The “drive sleep” feature on Wd My Cloud should be called: “Spin down and up every 10 minutes”, because that’s how it works without any modifications. Basically, that’s the biggest problem. WD pretend that the drive has an option which simply doesn’t work for 99% of customers. It would be better if this option didn’t exist at all, so people who consider to buy a NAS with a working sleep mode wouldn’t be mislead. I’m pretty sure most of customers would pay extra ~30$ to have a drive with working “sleeping” mode, if they only knew that this feature doesn’t work in cheaper models.

I personally was going to return My Cloud after the first night when I heard that the drive wakes up every 10-20 minutes. Then thanks to this forum and @rac8006, @Bennor help I was able to get the satisfying sleep times.
However, now, after 4.05.00-315 update the problem returned (until you found the samba fix), This is not how firmware updates should work. A serious company should deeply test if every single option works as expected before releasing it to customers.

I suppose with the next firmware update this problem won’t be fixed by WD anyway. We can only hope that no new problems will be created.

That’s why, in the future I will not buy NAS servers from WD, and won’t recommend it to people who want to buy it (already told about those problems to a friend who was considering buying it). This is just my opinion and I’m not telling anyone to do the same.


#193

I’m afraid I still think that it’s WD’s problem.

If they want to use open source software, then they should have performed adequate regression testing of their product when they refreshed the version of Samba they were using, just as they should perform adequate regression testing of any of the software that they write themselves.

Regardless of the origin of the software, WD are ultimately responsible for the correct operation of their product

They take a similar laissez-faire attitude with Twonky, arguing that it’s a ‘third party piece of software’, and not their responsibility. Whereas it’s a built-in, advertised featured of their product, supplied directly by WD. Therefore, IFAIAC, the correct operation of Twonky, running on the MyCloud, is their responsibility. It only ceases to be their responsibility if I upgrade the version of Twonky from a genuine third party source, rather than using the version of Twonky supplied to me by WD as part of their firmware build.


#194

After I upgraded to this firmware, I noticed the media file counts in both the WD My Cloud UI (under Settings/Media) and the Twonky Server UI (under Status) don’t seem count my music files. The files are fully accessible via my various UPNP controllers and my custom trees are working just fine, and the files play normally. In short, everything seems to be working fine except the UI’s show that there are zero music files (when in fact there are tens of thousands). Anyone else experience this and anyone know of a fix?

And just now I tried Reset to Defaults via the Twonky Server UI (under Advanced) which of course changed the shared directory back to Public (all media types) whereas I normally only shared from a sub-directory I created called Public/Music (music media only). When I do this reset, the counters do count photo and video files that I have in sub-directories on Public, but they do not count music files. Strange…


#195

Hi everyone,

I just registered to this awesome community after following several discussions during the past years about firmware upgrades and the corresponding consequences to the sleep times or horrible NAS performance which made me suffer since I bought that device some years back. Since then I have been forced to become an eager learner and part time technician, as nothing in this device is working as intended. I’m sorry if I’m digging out this old thread but latest responds to newer threads in this forum gave me the impression, that this is the only thread supposed to give a comprehensive answer to the no sleep/random wake up issue in the latest firmware. I hope this assumption is correct, otherwise I would be grateful if you redirect me to the right conversation.

Having crawled through the full 192 posts in this thread I’m a bit overwhelmed due to my limited technical understanding of Linux and SSL. What I’m looking for, is the start up script helping my First Gen MyCloud to go into sleep mode and stay there until either I want to copy new files onto it or want to use the twonky streaming service (essentially using Twonky for watching videos and photos on my smart TV is the only use case for this device - I need no backup, cloud or remote access).

From what I understand of all your answers in this thread, there is no consensus on how to get there, correct?!? The methods suggested differ in whether to deactivate the cron job or not?! Or are there further differences (I don’t get what you say about the monitorio…)? While I’m not sure what the consequences of a deactivated cron job are, I understand that some users solved their sleep/wake up issue with killing the cron job, whereas some of you recommend no to do that but reach respectable sleep times without doing that.

Being aware that I might get different answers, it would really help me if you just repost or relink your final attempt scripts on the 1st gen myclouds and maybe outline what they do and how to apply them to my MyCloud: Would I have to copy a text file somewhere on the drive or do I have to enter some code lines in putty? Again, I’m sorry if this already had been answered and I’m just unable to filter this out of the various statement made in this thread.

Thanks to all of you for your great efforts to get this shitty piece of firmware to work!


Was sleep ever fixed on GEN 1 devices?