Files Suddenly Gone From MyWD Cloud

Well l probably won’t mess with SSH because it is beyond my expertise. The real question here is; " are my files there or not?". Even after hours of rebuilding I still cannot see my files. You can see from the pictures that there’s suppose to be 560 GB of video files. Even during rebuilding it counted 5603 videos that I cannot see in the folder. I only see 15 videos. Over 500 GB of video tutorials could possibly be gone. But WD tech support was no help at all with this strange situation.

Wait until all rebuilding is finished and the “Content Scan” says “Idle” … then reboot the MyCloud. Sometimes rebooting fixes anomalies that happen when Firmware updates have been loaded. I’m sure your files are there.

Do a subforum search, using the magnifying glass icon upper right, for “files missing”. There are several prior discussions from others who had files/folders go missing on their My Cloud. Its possible there may be a solution mentioned in one of those previous discussions.

After everything my files are still not there. I will search this forum for additional help but I might as well give up hope of getting my files back. Thanks to all and Merry Christmas.

1 Like


Here is the result of the rebuild and content scan. It now shows zero videos, zero photos, and zero music tracks. Thanks WD for the drive that keeps on giving, um, I mean keeps on taking.

It’s possible your data is still there. If you don’t have any other copy of your data, and you cannot reconstruct it, then you might want to see if you can recover the data. This will require opening the unit, and connecting the HDD to a linux computer, or a PC running a Linux LiveCD, or a Paragon extfs driver. See this thread:

I have another WD drive as a safe point backup that updates once a week at 2 am on Fridays. Well, guess what? The safe point updated as should thus erasing my only chance of recovering my files. I will be looking for another storage alternative because I lost a lot important art tutorials that took me a long time to accumulate. But what if I can revert to a previous firmware version?

HI All.
This is my first post and I am a bit of a novice but I am experiencing many of the symptoms listed above and I need to know what to do. I have a 4TB MyCloud (single drive) with 2x external hard drives attached (through an adaptor into the USB port). This has worked well for the last 12 months. Yesterday, I was alarmed to see that my drives, while still attached (and properties show are nearly full which is correct), WIndows Explorer does not show any of the files on the external hard drives and says that the folder is empty.
To make matters more confusing, if I unplug the external hard drives and plug them directly into my laptop, they work fine and I can see all of the files through Windows Explorer. This makes me believe that it is the WD MyCloud which is at fault. I use my laptop as a Plex Server and as my files are not visible, my Plex libraries are unavailable. Also, it is impracticle to have the external hard drives plugged directly into my laptop all of the time. The media server is on and the files are public (the same riights as my WD MyCloud drive which still works fine).
Please can anyone assist?

Also, to add to this, the file properties in WIndows Explorer are set to show Hidden files and the main folders appear in the shares section of my dashboard.

My my WD Mycloud and 2 x 4tb external hard drives are all accounted for here:

Yet when I access my files through Windows Explorer or the WD MuCloud explorer I see no files:

Update: I have tried unplugging everything and switching off / on. Despite trying this three times last night, I have tried again this morning at I now have my drives back and in working order. Maybe persistence is the key!!

Congrats. My situation keeps getting worse. Thanks WD. NOT!!

I now magically have a 5.3 TB free drive!!!

Do you have a USB external hard drive attached to your My Cloud? If so that may account for the increased free space, especially if you have USB Content Availability enabled under Dashboard > Settings > General > Cloud Access.

As I was backing up the files I had left in preparation for a complete drive erase, I notice that the files I thought were gone are actually still there. But when I try to follow the file path from the backup window I cannot see the files. I am sure that the last firmware update has screwed things up pretty bad.

What can you see if you use a simple file manager, like windows file explorer, or apple finder? Or login to the MyCloud linux operating system via SSH and have a look around /DataVolume to see what’s there.

I never use WD apps or SharePoint when operating locally; I use native file managers and third party backup tools. I don’t have enough faith in the WD apps…

I tried simple file manager and no luck there. Now how do I use MyCloud linux operating system?

Then connect via SSH using something like PuTTY.

I got the putty but I have no clue how to use it though. It ask me to “login as” ?

Did you read the note that appeared when you enabled SSH via the Dashboard? You agreed to accept the SSH user ‘root’ with password ‘welc0me’. Login as root, using that password. Google for basic linux directory navigation and listing commands, if you’re not familiar with linux. (cd and ls, for starters)

No luck here either. I type root for the login and nothing happens. I am not tech savvy with this stuff anyway. I might wait for the next firmware and hope for the best or just switch to another drive brand.