File access

I have been using a MyCloud with several folders for years. Cable connection to router. I now wish to access it from a new W10 PC, wireless, but the File explorer only lets me see the shared folders when doubleclicking the unit icon and I have forgotten how to set up the connection. I expected that doubleclickning should require a login the first time. However there is no request for a login and the \WDMYCLOUD Internet reference only takes me to the dashboard. Inactivating Norton makes no difference. How do I access the entire file structure (to which one WD-user has full rights?)

You need to map a drive letter using different credentials. By default Windows is accessing the Public share.

And, having made an association between a User (the Windows User) and the Public share, Windows will not allow Private shares to be mapped with the correct MyCloud User credentials.

So the OP will have to break the User:Share association using Windows Credentials Manager. See:

I would certainly map if there was a mappable \WDMYCLOUD network unit.
Let me repeat the case:

I have a setup with several shared non-public folders + the standard
Public (with a subfolder) etc. Two users. A has full rights to
everything. The system works (and has worked) perfectly from a number of
cable/WiFI-connected PCs (W10 and W7) and I am currently trying to
introduce a new W10 PC in the network. The PC is in the same work group
as the other units

In File Explorer the following happens

Computer : Network places: Doubleclicking WDMyCloud : EMPTY folder.
There is also no network unit to map.

Network Storage: Only option is the Dashboard of MYCLOUD

I should normally see all the resources under Computer and be able to
connect with a normal login to the resource if necessary. This is
exactly what I get in the other PCs. I have disabled Norton to eliminate
any firewall issues.

Den 2017-07-04 kl. 18:59, skrev Great_Scott:

If the computer is in the same workgroup have you tried rebooting your router?

Is this what you are missing? See image below. Click on, tap or activate image to enlarge it.

Have you connected the new computer?

Some images or information using Steps Recorder would help. See example image/information from Steps Recorder below.

1 Like

This is NOT what I see . Under Network two other PCs on the net are
present (with their shared files, accessable without problems). No
WDMYCLOUD. On these PCs where the MYCLOUD connection works I reach the
files through rightclicking and opening the Mycloud icon under
Network/Storage. This cannot be done from the current PC as the Open
option is not present, only the webpage (which has a fixed network adress).

So in Summary. Resources on the network are displayed and shared files
on PCs can be accessed without problems from any PC on the net. Shared
files on the MyCloud are displayed on “old” PCs but not on the one under
installation.

There is no credential info for the MYCLOUD on the “new” PC.

Puzzling…

Den 2017-07-05 kl. 15:31, skrev cat0w:

Sorry for the misunderstanding. I guess we all read this, and thought it meant you could access the files on the computer in question:

I now wish to access it from a new W10 PC, wireless, but the File explorer only lets me see the shared folders when doubleclicking the unit icon and I have forgotten how to set up the connection

Just for completeness, have you tried rebooting your router, as cat0w asked? This might cause a refresh of a DNS server. And rebooted the PC in question?

And have you forced a refresh of the view in ‘My Computer’?

I know these seem basic questions, but they really do sort out a lot of problems a lot of the time, so let’s just make sure you’ve gone through the basics.

Have you looked at the network settings of working and non-working PCs side-by-side? It appears to be a Windows configuration issue, not a MyCloud issue (since all the other PCs see the MyCloud without problem).

Have you run network diagnostics on the non-working PC?

1 Like

@TOTTE I am not a techie but I had the same problem of being unable to see MyCloud in my network after getting a new u-verse modem. WD tech support advised me to get a gigabit switch because the modem doesn’t offer plug-n-play., That solved my problem. Sorry, it might not solve yours since you can still see your stuff from other computers, but it might somehow be helpful.

1 Like

I cant find out how to continue the thread in the community so let me close
it here. With thanks. A few restarts of all units involved and TIME solved
the issue. I have noticed before that W is sometimes late in finding all
network units