Fast Losing Confidence

I am fast losing confidence in using my NAS unit MyBookLive 2Tb. I can see that various users in this community have had issues at one time or another I was just hoping that after initial setup missues the unit would work OK, but no such luck.  Here is my experience of owning this unit for just over 2 weeks.

21 Dec 2012 - unit delivered

22 Dec 2012 - unit attached to my home network.  No software used for the setup as my router allows me to see DHCP clients attached.  After booting up I was alerted by the alert/message bubble that there was a firmware update which I selected.  The update downloaded, installed and rebooted successfully.  The firmware updated to Version MyBookLive 02.32.05-046 : Core F/W. I then had various Dashboard ERROR 3xxxx when selecting menu options, although I could access and move files into the Public folder across my network. I downloaded WD QuickView which allowed me to shut down the drive while I trwaled through WD Community posts for a solution.

22 Dec 2012 - raised a case with WD support informing them of the Dashboard errors.

24 Dec 2012 - received email from WD support suggesting various possible solutions but none of them resolved the Dashboard ERRORS

29 Dec 2012 - I plucked up courage and followed WD community advice (many thanks nfodiz) to do a factory restore using PuTTY which seemed to have sorted out the Dashboard errors.

29 Dec 2012 to 6 Jan 2013 - moved media/photo files and did some backing up of data from older machines to the public folder.  All seemed well.

6 Jan 2013 - Installed WD2Go on ipad 2.  I tried to access photos in the shared photos folder via the ipad. Sometimes I was allowed to see the folder structure I have set up within public. Other times I was denied any view at all within the public folder with a message something like the device is unavailable/offline. (I have never encountered any issues accessing my itunes music library using the “remote” ipad app so I am confident my LAN is not causing the problem). I then lost all access to the Dashboard. When I did a mouse-over of WD QuickView it showed 0% of drive space used (I have used 4%).  Temperature showed as “Unknown” but it was still showing a green spot and the MyBookLive was flashing green.  I could still open the public folder from my main Acer X3200 PC. I then tried to access the Dashboard using the Opera browser (I usually use IE), still no joy.  I tried to power cycle the unit using WD Quick View “shutdown” option.  I tried this 3 times . It went to the warning/confirmation window but when I hit OK to shutdown but 3 times the unit failed to shut down. I removed the ethernet cable and then removed the power from the unit. After a short while I reconnected up and it failed to restart.  I got blue LED, then yellow LED then flashing yellow.  It would not progress to green LED.  I then held in the reset button for about 6 secs on the back of the unit, Still flashing yellow.  I held in reset again and this time it did eventually restart and I got back Dashboard access and access to the folders.

With Dashboard working I have now enabled SSH access via the browser and intend to leave it enabled.  Can someone please confirm that this is a good idea?

Why can’t I access the shared photos or other other inner folders within the public folder structure I have set up within the MyBookLive?

Can anyone reassure me that it is worthwhile persevering with this unit?

Try setting a static IP for the my book live.Enabling SSH shouldn’t cause any problems. 

I had reserved an IP address within the router admin. When I say I lost all access to the dashboard i mean  i could not  access the dashboard  UI because it had become unavailable. it was unavailable on and also unavailable on http://MyBookLive. The  files stored on the MBL were still accessible at this time until I tried restarting it and it failed to restart. Eventually it did restart and access to the dashboard became available again. 

OK I reluctantly set up the MBL with a static IP (rather than a permanently reserved IP by DHCP). The static IP is outside the router’s range of DHCP addresses.  I say I was reluctant because at the time dashboard access went awol I was still able to access the files on the MBL  This fact suggested to me that that the MBL had retained its IP address which had been served up by DHCP

It is too early to say whether this will prevent a repeat of the sudden unexpected loss of access to the Dashboard UI, because it only happened once in 3 weeks while connected via DHCP.

Incidentally “pietower” in the MBL Duo Community had a similar experience with loss of dashboard and unable to shutdown. See

I am unsure whether a static IP was supposed to help with the WD2Go problems but I can say now that it has not helped.  I deleted the original connection and re-paired up the ipad with the MBL. It does this automatically via the WD2Go app using the “Connect Now” button served up by the app.  Shortly after doing this you can see the connection via the Dashboard under Remote Access > Mobile Access > Mobile Devices “ipad WD2Go admin connected”  The configuration details show Remote Access enable and the Connection status as connected.

However I am still in the same position that I am allowed to see the folder structure on the MBL with the ipad but when I go within any folder where there are files I am denied any sight of them.  The processing icon rotates and I eventually get the message “Device is inaccessible/Offline”.  Any futher attempts to access the MBL via the ipad even denies sight of the folder structure with the message “Device is Offline”

Does anyone have any further ideas on how to get WD2Go working

After my last post I decided to leave the NAS powered up all day (I usually shut it down so I can visually monitor it when I am present).  It slept like a baby with a nice blue light.  It was in such a slumber I could not wake it up using an ipad.  Attempts to access the dashboard from the ipad did nothing.  I launched WD2Go but that would not wake it up.  I resorted  to using my main PC (Vista OS).  Even before the PC had fully booted up the NAS woke up.  I can only think that WD Quick View did this by queying the status of the NAS.

Anyway I was frustrated again that access to the Dashboard had vanished. I tried accessing it from 2 different browsers using its name and IP address but no response.

I did a mouse-over of WD Quick View and it reports, a green spot, the drive name, usage a 0% (I have actually used 4%), and temperature as unknown

I can however access the files stored on the NAS.

I am reluctant to do a reset in case I have further issues and lose my files, (last week I had to press and hold the reset button twice to recover this situation because it seemed to ignore my first request at a reset).

I’ve decided to give up with this drive.  I am going to return it to the retailer, but will I do any better with a replacement new drive?

One thing I do not know is whether the problems I have had already existed as soon as I pulled it out of the box, or did the firmware upgrade from the alert/message bubble set in motion my woes.  I did not try browsing any of the dashboard menus before selecting the upgrade from the alert bubble.   After the upgrade the dashboard was wrecked with ERROR 3xxxx messages. Can anyone shed any light on this or any of the other issues I have had.  Your advice would be greatly appreciated.