Failure in NVMe format using nvme-cli

i’m trying to format a brand new WDC SN730 SBQNTY-512G that came in a lenovo ThinkPad laptop. My goal is to change the LBA format to 4096B block size.

I’m using the linux tool nvme-cli v2.0 from systemrescuecd.

# nmve format --lbaf=1 --reset /dev/nvme0n1
NVMe Status: Invalid format: The LBA format specified is not supported (0x410a)

The issue has been reported before but in my case the suspend trick didn’t work.

Both nvme and smartctl report the device supports 4096B block sizes.

# smatctl -a /dev/nvme0
Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
0 +          512            0               2
1 -         4096            0               1
# nvme id-ns -H /dev/nvme0n1
LBA Format  0  :  Metadata Size: 0  bytes - Data Size: 512 bytes  -  Relative Performance: 0x2 Good (in use)
LBA Format  1  :  Metadata Size: 0  bytes - Data Size: 4096 bytes  -  Relative Performance: 0x1 better

I’ve tried changing ses and pi options on nvme format, with the same results. In fact, any formatting operation (even # nvme format /dev/nvme0n1) gives the same “Invalid format” result.

On the other hand, I could wipe the card using Lenovo ThinkShield Secure Wipe application embedded in the BIOS. But that won’t allow you to change the LBA.

Previous discussion of this issue (here and on other forums) suggest it might have something to do with the system protecting the storage somehow. But I there is no BIOS option that seems relevant (I’ve tried to change a few, even so).

Maybe there is some additional admin command I need to pass through to the SSD in order to unlock the format operation. Or maybe this is some issue with the Lenovo BIOS (after all, their tool works, but is feature lacking).

I would appreciate any help on this. Thanks!

Hi @GrandeGrabois,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: