Factory reset?


#1

Hello is there a complete factory reset mode on the MPW ?

The default two options on the UI do not perform a factory reset but just software reset for configuration …

I am asking this because right now my WPS does not display hdd usage on UI, it says ‘not enough space to do it’ when trying to upload older/newer firmeware, It says also that 's there is no more space when trying to upload file …but there is nothing on this drive !! I was just able to enable FTP (see my previous post) and thought that now I was able to fully use the MPW…but actually I can’t do anything…

It does not show up when connecting on USB port I can’t upload via FTP due to ‘not enough space’, I can just do ssh !!!

So I was thinking of a complete factory reset (wipe out + reconfiguration) as it was shipped …any idea ?

Lebios


Connect MyPassport Wireless to Home Router
#2

You can do a Manual Reset of the MPW. That should reload all the software and set it back to your starting position. See page 47 of the User Manual. Take note:

MAKE SURE THE MPW IS TURNED ON BEFORE STARTING THE RESET.

If you don’t have it, the User Manual is available here: http://support.wdc.com/product/download.asp?wdc_lang=en&fid=wdsfMP_Wireless

Manually Resetting the Drive

For a system only reset, the battery has to have at least a 25% charge.

  1. With the power ON , hold down the Power and WPS buttons at the same time for around 10 seconds until the drive reboots and the Power and Battery Status LED flashes white.
  2. Wait until the Wi-Fi LED is blue before reconnecting.

#3

Thanks I tried it, but I still a blank  space usage in the dashboard  (tha battery charge graph is ok), and when I try firmeware update it still says “not enough space to do it’”…I have nothing on the drive.Also when connecting through USB my windows 8.1 says that it cannot recognize the device…

* is there a way from SHH cmd line to force a full restore/format hdd thing ? Or check from ssh if actualy something is mis-configured like drive mount, user (root/ftp) setup ?

thanks…


#4

If the full reset doesn’t fix the problem, I think it is time to contact WD Support again, only this time don’t tell them FTP doesn’t work. Tell them you can’t get the drive to show up connected to USB, and that you can’t copy anything to it.

You may have a faulty drive. A few people have had them, and had to return them for a replacement, which then worked fine.

You have spent enough time trying to get it to work now. Over to WD to fix it. Or if you can return it to the place you bought it for replacement easier, do that. Sometimes a retailer will be more helpful than the manufacturer. Your choice.


#5

Thanks

I’ll do that…too many issue on basic usage…

I did a quick df on the ssh session to see disk usage

df -h

Filesystem           1K-blocks      Used Available Use% Mounted on
ubi0:rootfs             102528     84180     18348  82% /
devtmpfs                256024         0    256024   0% /dev
tmpfs                   256132         0    256132   0% /dev/shm
tmpfs                   307200       800    306400   0% /tmp
tmpfs                      512         0       512   0% /media

basicaly it shows that I clearly don’t have 1To available but hundreds of Mo …


#6

Most often after a factory reset, the firmware reverts to the original one (v1.10xx)   So install the latest.  Also, install via the SD card method.  All you need is the FW on the card – no wireless connection or PC connection needed.  It is how I always install the FW.

If you eventuakky deternine you need a replacement unit, take it back to store for an exchange for a brand new one.  Return it to WD if necessary, but you can often get one back that has usually been refurbed from another returned unit.


#7

does reseting the firnware wipe all data? Or does it just reset settings like password?


#8

Miller-Village wrote:
does reseting the firnware wipe all data? Or does it just reset settings like password?

No, resetting or updating the firmware does not wipe all the data.

On the Admin tab of the Dashboard, under “Restore Factory Settings” section, there are two options, “System Only” and “System and Disk”. The second option DOES wipe all the data on the MPW, so be careful with that one.

Page 47 and 48 of the User Manual.


#9

I just wanted to shed some light on the factory reset process. After using both the drive and system resets I restarted the drive, enabled ssh, and logged on. After both, my previous bash history was still present so I wouldn’t trust this reset process to clean up your drive before selling or returning for service. I did however get the drive clean using the following steps.

-factory reset the drive using the web UI
-enable ssh from the web UI
-log in using putty - ssh root@mypassport
-list the drives “fdisk -l”
-wipe the file system partition records “wipefs -f -a”
-plug in the drive to my laptop/desktop via USB
-download install active @ kill disk
-delete the existing partitions if left
-wipe the drive with all zeros using active @ kill disk
-perform the normal hard reset (hold power and wps buttons for 10-15 seconds releasing after the wifi light starts blinking)

after performing these steps my bash history was gone and it didn’t seem like any trace was left of my files. the wipe occured overnight and probably took 10 hours but thats better than sending off any sensitive to some overseas service center to “refurbish” the drive!

happy hacking!
-jerseyweeds