Essentials usb HDD suddenly password protected

Hi everyone,
Needed some photos so connected my WD 3TB external SSD, and all of a sudden: not doing anything. Ran WD Drive Utilities, and it all of a sudden asks for a password.

I’ve never set a password. The hint is also blank. I live alone, don’t feel a need to protect it, and never did. So I have no clue what happened. I have 3 versions of my “master password” which I tried (wrote it first, copied it for spelling check: all wrong.

What now? There are some seriously important files on there. I’m flabbergasted.

ID: WDBACw0030HBK

I guess this is a lost cause…?

No one? WD support? I’ve tried everything, all passwords that I’ve ever used, and there’s nothing in my password overview (were I literally store EVERY password).

I’m 200% sure I never set a password for this drive, and there were some mega important files on there. Gutted. :frowning:

No one?

Same problem here

That’s super interesting. That firmware should reset the password but still keep the data on the drive? Would be a miracle update for me. I’ve sent them a message, let’s keep our fingers crossed… If I get a positive reaction/link, I’ll let you know as well!

Found this on wayback machine, download link works!

Oh man that’s clever! Has been way back since I used that site haha. Downloaded here, will try it today! Did you try it yet?

Do not have a drive that needs it, was helping a poor soul on another forum! Cannot find the link for the MAC updater, so it has to be done under windows.

Disconnect all other non essential USB devices (printer etc) before running updater.

Greatly appreciated. I’ll also do it via my laptop then since I don’t have anything attached to that USB-wise… I’ll report back how it went! I’m not expecting the password to reset though, but let’s see, perhaps there are miracles…

Windows or macOS Cannot Find My Drive (wd.com) I found this to unlock a password protected external drive,not sure if its for your model.
Not sure if the WD Discovery download will delete the data on the drive by doing this?

Thanks for that, I’m trying it but while Windows does make the sound that a usb device is detected, the application doesn’t detect the drive. WD utilities recognize the drive, but yeah asks for a password. I’ll keep trying. Thanks a lot!