DX4000 Boot Drive replacement

I am trying to resurrect one of these with no drives. Is they are way of getting the boot image onto a new drive without it being on the compatible list?

only way is to modify the drive list on the thumb drives before starting the recovery as explained for instance here

https://community.wd.com/t/wd40-efrx-wd-red-successful-install-from-scratch/214852/25

Thanks. When modifying the list where do I get the information to populate the addition?

I think the only real information required in the drive list is the disk drive model which in general can be found on the dirve itself or by utility like Crystaldiskinfo. E.g. for a WD RED drive this would be

Model description=“Enterprise Storage 4 TB” size=“3815448” etype=“constant”>WDC WD40EFRX-68N32N0</Model

Size can be calculated by e.g. datasheet but perhaps this is not strictly needed.

@DTMtech I think when you run the drive enabler it adds a wildcard entry. Can you look, mine is offline now

It seems Explorer search doesn’t find the whitelist file on c:\ - is it renamed or held somewhere else?

If it is a wildcard that would be even better then.

how about
C:\Program Files\Western Digital\Western Digital Drive List\DriveList.xml

The drive enabler program simply rewrites the C:\Program Files\Western Digital\Western Digital System Config\SystemConfig.xml file adding the following section:

<Drive ItemProfile="EnterpriseStorageProfile55" Size="*" 
       Description="Hard Drive" 
       Model=".*" 
       Type="re"/>

found this above, perhaps that can be tweaked for the whitelist?

Still waiting on the drives I ordered to come in test.

WIth Windows 2008 r2 being EOL’ed soon I may look into possibly getting a newer OS on it, but I want to atleast get the base configuration working to before I go that route.

it has been done but it is hard to load a different OS on this without a monitor.

Having the “base” is no help on that venue

thanks, I will try this one on whitelist*.xml next time I will install new drives

So I e-mail WD support to see if I can get the recovery image, but any chance anyone has the latest they can share? I found the .17 link here but I think there is a later version that I cannot find a valid link to.

OK SO I had 3 Seagate 1TB drives all the same, so I figures I would see if I can get them working, but even after adding the serial numbers to the whitelist the log still says they are not in the whielist. This is on the step to create the raid (i.e. middle step)

;Port,Model,SerialNumber,FirmwareVersion,Array,Status,Size,Free,Type
2,“ST1000DM003-9YN162”,“Z1D21ZS5”,"CC4H ",-1,“Normal”,1953525168,1953525168,“Passthrough”
3,“ST1000DM003-9YN162”,“Z1D24GFQ”,"CC4H ",-1,“Normal”,1953525168,1953525168,“Passthrough”
4,“ST1000DM003-9YN162”,“Z1D25Z6T”,"CC4H ",-1,“Normal”,1953525168,1953525168,“Passthrough”

2020.01.03 10:41:03 - INFO - RaidCfg64 detected 3 drives
2020.01.03 10:41:03 - INFO - RaidCfg64 drive Z1D21ZS5: port=2
2020.01.03 10:41:03 - INFO - RaidCfg64 drive Z1D24GFQ: port=3
2020.01.03 10:41:03 - INFO - RaidCfg64 drive Z1D25Z6T: port=4
2020.01.03 10:41:03 - WARN - Drive 0 serial Z1D21ZS5 model ST1000DM003-9YN162 does not match any in white list
2020.01.03 10:41:03 - WARN - Powering drive 2487480 off
2020.01.03 10:41:03 - WARN - Drive 1 serial Z1D24GFQ model ST1000DM003-9YN162 does not match any in white list
2020.01.03 10:41:03 - WARN - Powering drive 2487480 off
2020.01.03 10:41:03 - WARN - Drive 2 serial Z1D25Z6T model ST1000DM003-9YN162 does not match any in white list
2020.01.03 10:41:03 - WARN - Powering drive 2487480 off
2020.01.03 10:41:03 - INFO - Detected drive 0 serial=Z1D21ZS5 model=ST1000DM003-9YN162 SATA=2 led=0

I have tried everything in all the different whitelist.xml files. I am using the .17 iso right now. The only thing I have not tried is to change the size. Mainly because I am not sure what to put in. The log files size listed for the drives is significantly higher than the one already there. Is that normal? I may have a WD drive kicking around to put in and see what the log shows then

The odd thing that I noticed is if I add a line to the whitelist files, it still only parses lines 7 to 25.

Do I have to modify prior to creating the USB drives?

OK so making progress. I recreated the USB stick for creating the RAID, and prior to even inserting the stick into the DX-4000 I changed WHITELISTL.XML and WHITELISTS.XML. there was no whitelist.xml file. So I now have recreate storage success, so on to getting the server USB installed.

Things were going good when suddenly I lost connection to the DX4000 while it was formatting. Not I cannot connect again. I started fresh and the same result when the recovery gets to the connecting to the server after the LCD shows “Recovery Started”, my desktop cannot connect to DX4000. I can see it is getting an IP address on my router.

Looking at the recover.log file and nothing odd in there. The only error I see is at the end:

Microsoft DiskPart version 6.1.7600
Copyright © 1999-2008 Microsoft Corporation.
On computer: MININT-MNJGT9U

Disk 0 is now the selected disk.

There are no partitions on this disk to show.
No EFI partition found!
Disk does not contain proper partitions

2020.01.03 22:32:11 - ERROR - Failed to run partutil.vbs: exit code = 2
2020.01.03 22:32:11 - WARN - Did not create Data Partition flag file on volume ‘’
2020.01.03 22:32:11 - INFO - X:\windows\system32\ServerRecovery.exe
2020.01.03 22:32:11 - INFO - Started MS server recovery

But I think that is correct because nothing has been formatted

this links to the latest
https://support-en.wd.com/app/answers/detail/a_id/5060

same worker PC? Any changes to it? Some PC’s just do not connect for some reason 3rd party AV or Firewall perhaps

Tried two worker PCs, flushed the DHCP cache, even tried going to two drives, different network switches, different cables, power cycled everything… I may try a using a dedicated router with just the worked PC and this m… if not I may throw in the towel and just put linux on it and be done that seems easier than fighting this.

routers and switches should not matter. Does the worker pc have any 3rd party av or firewall? Just one ip on the same subnet as the server gets dhcp