Dropbox Does not work on My Cloud Mirror


I installed Dropbox on my MCM. Then I go to the sign in on the Dropbox menu on MCM dashboard, I sign in, then I am asked if I allow “My Cloud device” to have access to my folders, I click Yes…and that’s it, nothing happens. I dont have Dropbox folder created on the My Cloud Mirror Public folder. When I go to my dropbox account I see that in the list of the linked apps there is “My Cloud device” and it has full read/write access to all of my dropbox folders, anyway on the My Cloud Mirror nothing happens, I can’t see my files.


today dropbox updated to version 1.10, still the problem persists - there is no sign that dropbox is working at all on MCM.

I rebooted the devide, I uninstalled and then installed the app again - no success.

Try rebooting - I’ve seen a few of the apps sometimes work a little strangely on first install but a reboot usually seems to fix it. Must admit that I’ve never had issue with Dropbox in that way though, but I’m not sure if I had rebooted for other things between when I first installed it and once I actually set it up.

But at least on mine it is working ok and synchronising properly. I would also suggest to confirm your log-in credentials are correct, although as you can see the device from the list of linked apps that would suggest that is an unlikely cause (but worth to confirm).

In the P.S. i wrote that I rebooted the device. It doesn’t help.

Ah yes, sorry, missed that :slight_smile:

If you go into the configuration screen of the dropbox app, at the bottom is a link button to select the dropbox sync folders (selective sync). If you click that button it should bring up your dropbox folder structure where you select the folders to sync.

Can you confirm that if you go in there you have your desired cloud folders for syncing ticked? The app will only sync to the MCM folders which you have selected.

Yes, all of my folders in dropbox are ticked in order to be synced. Is there any chance that some of the settings I made to the MCM prevent the folders from being synced ( maybe not because on the dropbox web page of my account in the list of the linked apps “My Cloud device” has the full access so there is connection). I can succesfully use dropbox from the My cloud app on my mobile phone.

On your dropbox on the My Cloud dashboard how many buttons do you have? I have only “Configure” button and On/Off button for running/stopping the app. It seems like dropbox doesn’t have the full options installed (if this is possible).

On the top level app list, also just on/off and configure. That’s fairly normal though, as the app itself is self-contained, so you enter it for set up via the configure button.

If your MCM dropbox folder as-default in the public folder then there should be no issue on the MCM side, as the only thing I could think of is if there was a local permissions error. But the public folder is public, so there are no user permissions to worry about.

My config screen is below (my account email is redacted). You can see the linked account, plus the local folder. Now we can do it, I’ve moved mine to a separate (non-public) share on which admin has full rights and that has sync’d fine.


Sorry, can’t see the config screen.

 The dropbox app didn’t create dropbox folder at all (not in the public folder nore either).

Maybe now (or it may need mod approval before it appears)?

Anyway can you post a similar screenshot of your Dropbox app config screen?

This is the dropbox settings. When I click on “Sign in” opens a window in the browser where I write the name and password for my dropbox account. Then the message if I authorize “My cloud devvice” to access my folders appears, when i click “yes” the window closes and it returns to the dropbox settings again (the screenshot).

OK, so basically either the log-in is failing, or the credentials aren’t being written on the MCM. When you log-in you should see the screen like the one I posted up.

I’d start by going onto the Dropbox website and deleting the app access for the WD Device (to reset everything at that end) and then try again, ensuring that you have the correct credentials (just to be sure).

Unfortunately it doesn’t look like the system logs are any use in this case, at least the standard ones. So beyond that I’m out of ideas, other than to reassure you that it’s not something fundamental with the app itself as mine works. Not much help to you I know, but all I can offer…

Thank you for your time. I’ve allready deleted the app access from the dropbox  site several times - it didn’t help.

I’m starting to think that it is question of port forwarding. I wrote that dropbox uses ports 443 and 80 (standart https and http ports), but they are allready forwarded from my router to the MCM IP address. It is strange the ports to be forwarded to the MCM and the dropbox on my home PC to be still working - the MCM and my home PC are connected to one router and there should be problem for dropbox on the PC to connect (because the 2 ports are forwarded to MCM), but there are no problems with it. Did you make any port forwarding on your router? And last question - in the settings menu of your MCM the “IPv4 Network Mode” is “Static IP” or “DHCP”? Mine is Static - i wrote somewhere that this is how it should be.

Anyway, thanks again for the attention. I hope that someone from WD support will see this post and give some ideas.

My MCM is static IP, and no port forwarding is set on my router. Maybe try removing the forwarding?

Also as an outside shot, one last thing you could try is to reinstall the firmware on your MCM. You can download it directly here and use the dashboard to manually install it (settings > firmware update > manual update then point it at the downloaded image, don’t forget to unzip it first).

I’ve had to do that before as the web file viewer stopped working on me - it just resets things without changing the set-up or damaging the file system.

If I remove the port forwarding I won’t be able to use the mobile app, the ftp server and I won’t have the ability to connect remotely to the dashboard - these things are important to me.

I appreciate the efforts you made to help me!

The question stays open for someone from the WD support, or someone who had resolved the problem.

I have no port forwarding set, but my router has uPNP so where required it can set such things up as needed. You’ll probably need permanent forwarding for the FTP server, but for the other two the router should be able to handle it (presuming you have a capable router, most these days should be).

With my set-up (no port forwarding specifically set), I can certainly use the mobile apps and stream (although generally I have that turned off as I don’t often use it), and I’ve never tried the remote dashboard as for me it’s too big a security risk (again i have it turned off). I have seen a port forwarding rule set up for streaming in my router to the MCM, but it’s a uPNP one which it set up rather than me doing so, and only seems to be there as-needed.

What I’d suggest is to specifically set up the port forwarding only for the FTP server, but see if your router can handle the other two dynamically and also as a test see if Dropbox does work in that configuration. Or just temporarily disable all your port forwarding and see if dropbox starts working, then at least you can confirm that getting the forwarding rules sorted out is the way to resolve your issue and confirm the root cause.


I have the same problem as initially described here.

I crosschecked with the Dashboard on several browsers and operating systems.

To me it looks like a problem in the OAuth procedure with Dropbox. The app gets allows on dropbox.com to access but the My Cloud system does not seem to get the OAuth result back in the callback URL. So it always stays at the register screen.

Did someone sucessfully solve the problem?

MY Cloud firmware and dropbox app version on the device are up to date.



After quite a lot of testing I found the problem!!

This is a bug of the My Cloud firmware…the solution is simple:

The dropbox app will only manage to complete the authorization process if the admins user name on the My Cloud is “admin”.

So the only thing you have to do is to change the admins user name in the My Cloud Dashboard (the one with the green tick) to “admin”. I changed it after installation to my personal name…this makes the Dropbox app fail to authorize.

As soon as I named the user “admin” it worked without a problem!

Will try to report this to WD…but if they read this they should file a bug for this.



Thanks Lineflyer, this was the solution!

Sadly changing from admin unlinks the MyCloud from the MyCloud Online account, besides that also changing shortly to admin and then changing back to the normal username makes Dropbox useless again which is sad.

I’ve now opened a case for this too. I hope they’ll fix this since I don’t want to rely on a “local backup” of my data. What if a house fire happens? Everything would be gone, you’ll never know. This app not working is kinda sad.

Yes, I have the same issue. And changing it to admin did work! WD Really should fix this. Most people would call the server something a bit more personal. But as of october 2016, they have not.

Finally! ■■■■■■■ bug… I’ve trying all of possibilities and it makes me crazy!! Thank you Lineflyer for the solution!