Docker support in OS5?


Did you check out the work done at GitHub - WDCommunity/wdpksrc: Cross compilation framework to create native packages for the Western Digital My Cloud ? There has been a working docker there for EX4100 pretty much since OS5 was released and WD came to the party with supporting it properly in the OS5 kernel. However, we recently managed to also get the latest version to work with the EX4100.



Thanks, I’ll give it a try!

1 Like


If you can’t get it working as a .bin package, you can always install an older version of the docker package from the site, stop docker via SSH, overwrite the docker binaries with the new version and restart the docker services.



1 Like

I am unable to download the docker_19.03.13_EX2Ultra.bin file, it says “Forbidden!”. Is there a mirror of this anywhere?


There are copies of the latest actual docker binaries at and this should work on all ARM platforms running OS5 I believe. You can take the contents of this file and copy into the location where the current docker binaries are and it should work okay.


JediNite it is I am using now

1 Like

that works for me on my firmware version 5.19.117 , passed both hello-word and portainer

This package is working fine :

That bin , while it says 21.04.06 it contains docker 19.03.8. Took me a while to realize why it was failing for seccomp2.
After updateing to the one shared by @jupiterben it all worked


It installed ok for me, but clicking “configure” gives me a message that 192.168.x.x:9000 could not connect. How did you configure it?
Do you have a link for instructions, please?

[EDIT] Just found this on the forum that may explain some about the portainer port 9000.

hmmm… After reinstalling, the config page of Portainer works fine.

Hi all,

I’ve just tried a test generation of the docker packages at Release docker-v20.10.14 · JediNite/wdpksrc · GitHub or Release Docker v20.10.14 for WD My Cloud · WDCommunity/wdpksrc · GitHub. Let me know how they go.



1 Like

I have installed it and so far it works well.

Actually I even installed Release docker-v20.10.15 · JediNite/wdpksrc · GitHub and so far I have no problems.

Update: After tinkering around with the Git repos I built and started using Docker 20.10.16

root@MyCloudPro home # docker --version
Docker version 20.10.16, build aa7e414

Happy to have an up-to-date Docker running on the My Cloud PR4100! :smiley:
Thanks @JediNite

1 Like
root@MyCloudPro docker # docker --version
Docker version 22.06.0-beta.0, build 3e9117b


Update: Reverted back to stable Docker 20.10.16 after failing to run Gitlab-Runner containers properly.

Update 2: Updated to Docker 20.10.17 & Docker-Compose 2.6.0.

root@MyCloudPro sea # docker run docker/whalesay cowsay "$(docker --version) $(docker-compose --version)"
/ Docker version 20.10.17, build 100c701 \
\ Docker Compose version v2.6.0          /
                    ##        .            
              ## ## ##       ==            
           ## ## ## ##      ===            
       /""""""""""""""""___/ ===        
  ~~~ {~~ ~~~~ ~~~ ~~~~ ~~ ~ /  ===- ~~~   
       \______ o          __/            
        \    \        __/             

Happy Sailing!

1 Like

Docker v20.10.15(.bin) for EX2 ultra is not working with firmware version 5.23.114. I can’t configure. empty page at port 9000. I also tried with older versions of docker. Can you help me?

At some point Portainer changed its port to 9443. Please try https://mycloudpro:9443

1 Like

Installed the provided 20.10.14 on my PR2100 and works fine but it doesn’t update my docker-compose version (stuck in docker-compose 1.28.5)
How can I update docker-compose?

You either change the script file to download a newer version of docker-compose.

Or manually download the executable file and replace the old one in your NAS.

Here you can get the newest docker-compose releases (x86-64 for PR2100): Releases · docker/compose · GitHub

1 Like

Most apps on the pr4100 (latest build, but been there for over a year) runs programs like transmission through docker… you have to jump through some hoop to get the CLI worked out, but I have an image that has utilities like rar/unrar or other docker apps.

There is even a Docker App int he Western Digital GUI, mines at 21.04.06

Far smarter folks have writeups on this :slight_smile:


Where did you find it ? Thanks.