DNS blocking

I have 3 WD Nas drives. Two of them are the My Cloud EX2 Ultra, one is the regular WD My Cloud series. This morning, I changed my LAN DHCP DNS settings from to and When I did I didn’t pay much attention to the drives at that time. It wasn’t until later on when I attempted to access it, I encountered an issue with the AFP/SMB on the Ultras. I wasnt able to authenticate to them, and even though they responded to ICMP the web interface would not come up, and neither would the shares. I rebooted them several times, disconnected the network from them, no change. It wasn’t until I changed the DHCP DNS back to that the devices functioned again.

I can possibly understand the web login not working, but why would SMB not work?

Hi @Pirho,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

No, support when it comes to networking have found is pretty useless. When I asked the for assistance on the nas to mas copy app they told me I had to open a port on the firewall for both devices that were on the same network subnet. No matter how hard I tried to explain that to them it didn’t sink in.

I also have a My Cloud EX2 Ultra and change my LAN DNS settings all the time without any problems. Are Dynamic DNS and HTTPS Redirect disabled via the dashboard? What is the current firmware version of each My Cloud EX2 Ultra?

Firmware up to date. Not sure about the other settings. But the odd thing is the devices themselves are set to static IP and static DNS for another ad blocker.

Are you sure? The latest OS5 firmware version is 5.27.157.

Have you tried disabling the ad-blocker? It may be the source of your problem.

My boxes say they are at 5.26.300 which is the latest according to the check updates.

The check updates function is not up to date. Download the latest firmware for the EX2 Ultra and perform a manual update to OS5 version 5.27.157.


Also, be sure to read the release notes, because the 5.27.157 firmware update changed the base distribution from Debian 10 (Buster) to Debian 11 (Bullseye).

My Cloud OS5 Release Notes