Device Offline after update

I’m glad that worked for you, but i’ve tried several times to unplug and plug back in, and it still stays as dim solid white light and is not accessible at all. Maybe they did something remotely to your device.
I talked to level2 tech on Sunday and he had to go confer with the developers about how to proceed. Hopefully they found a solution that fixes the issue for everyone

There is another update available for the app (iOS). I did not downloaded it yet. If you got the same prompt for your phone, you may want to try and see if that will do the fix too.

Hipefully the WD team will get yours fixed soon and for the rest.


I just updated my app to v3.1.0 (1472) on iOS.

Now, the My Cloud Home is again not accessible. Same issue as how i described it under the same Case# i opened — LED light stays dim.

Pls look into this. I strongly believe it has something to do with the updates. I first did the app update on my other device where the access is a “user”. I access My Cloud on all devices and it’s still working.

When I did the update on my own device where i am an “owner” of the My Cloud, it stopped working!

I’m waiting still to hear back from support. They were supposed to call Wednesday but nothing. Maybe they’re still trying to figure out how to fix this mess

Anyone have any luck getting this resolved?

hi, apparently it happened to me again after i updated my app to v3.1.0. these are the things they asked me to do and next to it is the result i got:

  1. unplug and plug-in back My Cloud — did not fix the problem
  2. reboot my router – did not fix the problem
  3. uninstall my app on the phone – did not fix the problem

after all the steps above, this is what i did.

  1. unplug My Cloud
  2. unplug my router
  3. uninstall my app
    – waited for like 5-10mins –
  4. plug my router in
  5. while router is booting-up, i plugged My Cloud
  6. while waiting for both devices to boot-up, i downloaded and installed the app back to my phone.

soon as the My Cloud starts to boot, the LED light was all white, went on dim and few seconds more, it went back on – device is back online/accessible on my app.

hope this helps

1 Like

Sounds like you just got lucky. I don’t see how rebooting router or app will fix anything when the device just doesn’t properly boot up in the first place. Dim white light means not booting. This has nothing to do with your home network. WD just don’t test their updates properly and have no fail safes.

I no longer trust WD with my data. The support techs have no clue how to fix this problem and I’d have to pay for data recovery to get my data back. Then I’d have to RMA the device. WD broke it, but won’t take responsibility for fixing it

I’m just going with a Synology NAS which allow USB access and you have direct access to the drives. WDs product being network only (even though there is a USB port) just reinforces how little foresight went into this product, and they seem to be oblivious that having sensitive data on a device requires much more thorough testing and proper fail safes Incase issues like this arise.

Also the tech support is a joke. They never called me back and now another tech emailed me asking same exact questions first one did (spent an hour on phone with them already).

Very disappointed and will be avoiding WD in the future.

Continuing the discussion from Device Offline after update:

Hello SBrown, I contacted WD support because it seems that I have the same problem as people on that thread have. I don’t know if you could help me with that. My case number is #{REMOVED} . There I describe my problem more detailed, but in the case that you can help me and need more information, please ask me.

Thank you in advance,

I have the same problem with device offline on any platform app and unable to access even with local network
I’ve used this MCH for just 3 days
Before the offline i’ve seen the message from mobile app that MCH have a problem and unable to fix then disk 2 error. I turned on my laptop, went to WD discovery and try to see if there’s any problems but after a few mins no drive Z: detected and device went offline with breathing LED.
Try reboot my router and factory reset but didn’t help!

Hi, I know this is a year too late, but just in case you still have not recovered your data, you don’t have to pay for data recovery, you can just dissasemble the my cloud and conect the HDD to a 3.5 SATA Case, conect it to your computer and then just copy the data with Disk Internals Linux Reader. Best of luck, if you need further help just let me know.

Does this not void the warranty? It seems I need to RMA the drive because support has no clue what to do. I’d like to get my data off of the drive first before sending it.

It will probably void the warranty, because after removing the hdd from the plastic case there are 3 screws to remove the circuit board, and those have a yellow tape covering them, so they will know if you have been messing with th my cloud.

My warranty had already expired, and I had a yellow light (solid, not flashing) on the front, and the device was not showing on my network so I tought “what the hell” and did it anyway. It was really a simple procedure. That was yesterday, I was able to recover 2 Tb of data overnight, and now that I am much more relaxed (having saved all my precious data), I will try to unbrick the my cloud by restoring a clean image.

If I suceed I will let you know. If you decide to do it, and need help, let me know.


Hi all, Just an update from my situation. Western Digital is sending me a new device as it looks like mine was bricked from the update. I did have to send it to Vietnam to get assessed which was the only hassle. I didn’t have any important data on the device so data loss wasn’t a concern to me. Good luck to the rest of you.

Dear, I have the same problem as you and since the beginning of August, when I plugged it in (since I had it disconnected by remodeling the house) it worked without any problem on each and every platform but during the night when I wanted to use it Again I was with the disconnected message. I have contacted wd and the last solution they gave me was to take it to technical service, where they would evaluate and apparently they can change my unit, the problem is how I recover the information without losing guarantee. I would appreciate any input to solve this issue.

Does that really work? Was it easy to dissasemble it? Can you give me some more insights?
Thanks in Advance

Hello. It does work, I did it without a problem.
To dissasemble de My Cloud I followed the procedures in this video, it’s quite simple really:

but there are many videos that explain this procedure.

As for the software to read the contents of the hard drive, you can download it here:

Good luck!

I see you used the My Cloud… Will it work on My Cloud Home aswell?

Hi all,
One of my friend has suggested that we can ask for the replacement My Cloud Home to be sent out to us in advance, prior to sending the defected one to WD.
Once we get the replacement, have the hard disks swapped in order to have the data safe and have it operational. But he is suggesting that if its due to the firmware, then in that case the hard disk needs to be updated once out of the wd my cloud home box manually and then swapped.
Regarding the update of iOS to 4.10, its only associated to the iOS products but we have issue with accessing the my cloud home from all devices, even through the website.
Guys need the feedback and then collectively move forward.

1 Like

any moderator or someone from WD here on the community?

Please reply and update your company that we all here are facing the my cloud home device being offline issue. when ever we call the support team, they reject the possibility of firmware issue by saying that not many people have this issue otherwise a lot of complaints would be pouring in.

They should come here and see for themselves.

Will WD get a bit serious about their product and help us out. we are in this issue due to the software (firmware and app) update.

moderator please reply. this is really frustrating.

1 Like

Did he do that and got any positive results?

1 Like

Continuing the discussion from Device Offline after update: