Device Offline after update

After downloading the new mobile app ver 2.9.3, when i try to access My Cloud, it shows Device Offline. I tried hard reboot my cloud (unplug, wait for almost 30mins, plug back in). I have no issue with the Internet connection as I can browse and stream.
Apparently, its the same even if i access thru desktop app or web access. The led light stays at dim…

I’m having the exact same issue… cannot get my drive to boot after the update. Latest software/firmware seems to have bricked my device. Would like to think it’s a server side issue but my router isn’t even assigning an IP address to the drive.

Hoping to receive a reply from the WD team with regards to this. I still cant access my drive, tried restarting my modem again this morning, same result.

@mrehpine @mbellis have you contacted support?
If yes, PM me your case number

Hi @SBrown, I have sent you the case#. I am not sure if I did it right (sending PM).
Let me know if you received it or
Thank you!

Hi, This is My First Post on WD Community, I am experiencing the same issue, i have update all the devices tabs, mobiles, macbook. Even i did the network setting again( all the things i can do i have done) but still offline. did Reset and lost all my data as i didnt knew that i would lose all my data. :frowning:

My MyCloud Home is offline too since a few houres. Could not locate the problem. Local networksharing is available.

1 Like

Same here. Nice testing WD

1 Like

I just created an account to reply to this thread. Mine is also bricked after my PC’s updated their WD discovery software today. I’ve checked my router and used an IP scanner and the MyCloud isn’t getting an IP address at all on the network. Is WD looking into this issue?


I created a ticket but no response yet. Also can’t figure out how to PM on this forum, maybe I need more posts? @SBrown here is my ticket if you can please look? #071819-13970450

I really need to get my device up and running since it’s my main backup source. My router is showing the My Cloud as offline for 3 days now even though I’ve been rebooting it, changed ethernet cables, etc. I really hope there’s a way to get it reset without losing data

Has anyone gotten this resolved yet? WD Support responded and was useless, telling me to change ethernet cable and reconnect to router, even though I already tried all this. They don’t seem to be aware that it’s a firmware bug

If only WD allowed us to access the My Cloud Home through USB directly, then I can offload data and reset. But since ethernet is only way to access data, it seems we’re screwed.

I have open a ticket too but havent got any response (other than the automated email, ackowledging the ticket) yet as well.

I tried changing cables, even using a different power outlet thinking that my power extension cord might be damaged and is not giving enough power that My Cloud needs lol. I really hope someone is looking into this for us. Cuz just like the rest of us here, My Cloud is my only backup now.

I’ve also logged a ticket with Western Digital. I’m lucky I don’t have any important data on the drive but a reset isn’t working for me either. The device just doesn’t pick up an IP address on the network and there’s no other way to access settings of the MyCloud Home. Seeing that all these responses have come only in the last 3 days, the firmware has to be bricking our devices. Case #071919-13972268

If the MCH doesn’t get an IP Address, check network cables and routers.
Still not getting and IP, could be a hardware issue which means RMA

I wrote a comment about my device also not working, but my tech fixed it in 5 minutes with some IP ■■■■. Do not have the solution, but im selfishly back to happiness.

Re-Edit : it’s back offline. No matter what we do, it shows for 2 minutes with the files on it, then it goes back offline to slow breathing. **** ***** ***** ** **

Re-Re-Edit : found a (the?) problem. When it’s all on its own allocated bandwidth, it’s working perfectly. I turn on one device on the Lan, It’s still there. I turn another one on and paff, the WD cloud duo is offline. I turn this this second device back off : the cloud duo comes back… I turn it on, the duo goes offline… Basically, it seems to need a certain ammount of bandwidth to show online. I had this setup for years… this is new. At least I can access my stuff.

Dear all,

Mine is back online too. A WD agent called me in the afternoon and asked me to do some steps (troubleshooting), however, i was out at that the time of the call. By the time i got home, i plugged in My Cloud Home to turn it on and the led light just completed the whole booting process. I open my app, a message showed “Your data is being merge…” and just a few seconds, all is back to normal across all my mobile devices and on laptop too.

Hopefully, yours will be back online too.

Thanks to WD team, hopefully this will not happen again.

1 Like

Can you tell us the instructions they have provided to you.


The agent asked me to check the back of the device and see if the ethernet cable port has a light turned on. However, as i was not at home when they called, i didnt get access to my device. Soon as i got home, i just plugged (power cable) my device and everything worked.

I dont know if it will help, but 2 nights after reporting this to WD, i left my device completely powered off. While waiting for their resolution, i would once in a while turn it on to check if its working and then power it off again and leave it disconnected.

Try disconnecting yours and then plug it back to see if it will do the trick. If you have opened a ticket with them, you should receive a call from the team.

Exactly the same here …
It was not possible to access My Cloud Home on the network.
(Writing it was offline on the network)
There was light in it and network on.
Unplugged the power plug. Waited a little and put it back in.
Since then, it has been totally dead. really frustrating.
My father had bought it because he wanted to store his old pictures on it. He had transferred the hard to them.
And now we can’t go to them.

He’s been trying to write to where he bought it. But nothing really happens.
We have even tried to get pictures / files out of them but currently. unsuccessfully.

Please see our message we have posted if you may be able to help us. Would be so grateful …

1 Like