Deleting files in my cloud home does not free space

Yeah i have the same proble Thanks wd for you sh*tty service

1 Like

Is this product working for anybody

I have the same issue. I`ve got a Home Cloud with 8Tb, deleting a lot of files, and I am near an out of space problem (less 3%). It is more than a week that I have deleted the files.
Any available help from WD? This is a long time question that might be solved, automatic or force, but a solution…

I had the same issue with my WD Home Cloud 4TB once I deleted many big files to make free space but it turned to 0% available.

I waited a full day for something happen but no changes at all and today, 2 days later from the issue, tried turn on and off couple times of the device power.

Now I can see around 100GB and looks working fine.
This didn’t happen at the beginning of restarting the device but took couple hours to show some available space in the finder window.

Similar issue. Wanted to update about 2TB of data, and now I’ll have to wait a week? a month? a year? to recover the disc space and update. So while waiting, all that info will have to be isolated, and in a transition folder until the space is finally cleared. Ive regretted my 8TB WD NAS drive since getting it. Going forward, i’ll do 2 things.

  1. think of this thing as a tape drive. Only good for long term static storage of unimportant data. (Lots of application there ! :laughing:)
  2. avoid WD from now on. (maybe a decade?) Already replaced this POS with two 8TB from another manufacturer. and slowly migrating ( and you do know what I mean by SLOWLY, right? :joy: ) to my new NAS setup.

WD, what were you thinking? didn’t you do any alpha or beta testing on this?

1 Like

Mr Brown, it is abundantly apparent that NONE of our devices are working. I bought a competitor’s 8tb drive and tried to free up my 2GB MyCloud Home. That was 3 weeks ago, sir. People have had this problem for over a year now. Care to reply? Any admins? Does this guy even work here anymore??? COMPLETELY DISSATISFIED!!!

No

I am having the same issue with 4Tb my home cloud. The device is now unusable. It doesn’t free space after removing more than 1TB of files.