Dashboard problems - MyCloud 4tb


I’m able to access the dashboard, but all the fields are blank, except Firmware, which shows I am using v04.00.00-607

I have tried to reboot, and shutdown, but this doesn’t work either, it just shows ‘Updating…’ but doesn’t actually do anything.

I previously assigned the My Cloud a drive letter and can access my files and folders.

Can anyone help?

I just want to turn it off and on again in the hope that it resolves the issue. Is there anyone who can help?

can you get to settings? if so reboot through there only. if you pull the plug it could take up to many hours to check the disk

how long has it been like this?

what are the lights doing?

what firmware?

Thank you for your responce.

I have tried many times to reboot via settings, but as I mentioned this doesn’t work. I’m trying to avoid pulling the plug for fear of loosing data or doing damage.

I have only discovered this problem today

I am on firmware v04.00.00-607

I have a steady blue light

can you still access the disk share from a computer with Windows explorer?

have you setup SSH access? if so sign in and run top

what was done before this happend? large transfers? firmware upgrade? etc?

Have you got a USB device attached?  I have been having similar problems.  Whipped out the USB and all came back, connected to Time Machine, the lot.  Not much good if I can’t connect my USB device though :frowning:

larryg0 thanks for responding.

In windows explorer I can see and access the public share as a drive with a letter assigned (I did this the other day), but it has disapeared from the under the ‘network’ section.

I haven’t setup SSH.

This is basically a brand new product. A couple of days ago I pluged it all in, updated the firmware, and transfered about 60gb of photos. I came to it today to give my girlfriends mobile phone access and found the problems.

Hi Fuchs915, I don’t have a USB device attached.

without ssh access it is hard to be sure but I assume it is generating thumbnails and indexing all the photos. since you can access the public share it is still running.

if you would be comfortable with using SSH you could reboot and imediatly enable ssh then try the step here to disable this. the main issue here is catching it between the disk scan from the crash and the photo issue starting.

if possiable I would let it run, possiably even several days to finish. depending on the volume of photos you add it may or may not be an issue in the future

if comfortable using ssh and using a Linux system you could do these steps to lower the priority of these processes which is what I have now

I strongly suggest a backup of any file before changing it. this requires SSH access and putty or similier. proceed at your on risk. easy change if you ever used Linux / Unix

edit /etc/init.d/wdphotodbmergerd and /etc//init.d/wdmcserverd  they had  renice 0 -p $$, change it to  renice 15 -p $$

if previously disabled do these 4 commands
update-rc.d wdphotodbmergerd enable
update-rc.d wdmcserverd enable
/etc/init.d/wdmcserverd start
/etc/init.d/wdphotodbmergerd start

If not disabled do these 4
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdmcserverd start
/etc/init.d/wdphotodbmergerd start

Hi larryg0,

Thank you again for responding and trying to solve my issues, but it seems there is some confusion.

I’m unable to reboot the device or shut it down without resorting to pulling the plug. This is allways the first thing I would try.

I had no issue adding the 60gb of photos that are now on the device. My problems are that the dashboard is not functioning and that the device is no longer visable in windows explorer under ‘network’. I assigned the public folder a drive letter when I initially set the device up and I can access the photo via this method.

I have no experience of Linux or SSH.

the dashboard is probably not responing do to the system load from the thumbnail generation and indexing. these process run at an elevated priority and can completly hog the system.

with the blue light on and access of any kind to the public share confirms the device is not actually hung even though it appears to be.

it was good that you had no issue uploading the photos, for many people the tranfer virually freezes and aborts do to this

waiting is your best option at this point, I have no idea how long as I didn’t wait

if you pull the plug you will probably have the same issue shortly after the reboot. if you do pull the plug I would still try to get in as it opens other options even if you don’t want to make permenate changes, you could run the commands below to stop these until the next reboot

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

and these if you want it permenatly stopped:

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable