D-Link DWA-160 not working plz help


i have one problem

i bought D-link DWA-160 but this dont have revision number have H/W Ver : A2  F/W Ver : 1.40

this wireless adapter not recognize with wd tv live PLZ HELP ME

tnx to all employees of Western Digital Company

Make sure your WDTV’s firmware is up-to-date.

If that doesn’t address it, then try testing the adapter on your PC.

If it works on the PC, then the WDTV does NOT support it.


The approved list quotes:

 D-Link Xtreme N dual band USB adapter DWA-160 Not Listed*

* If your Wireless adapter has a revision number on the box, the product may be a newer revision than what was validated and may not work. The tested device did not have a version number listed for the hardware on the box or the device. Wireless suppliers have a history of changing the actual hardware (the electronics design and chip), but keeping the model numbers the same and adding a revision level on the box and/or the device.

Given that WD has not approved version A2 then it is entirely possible that your version will not work.

See also here


and here


I have a DWA-125 Rev A2, also not in the supported device list (only A1 is listed). However, after update to the latest firmware (pre-release), it started to work.  Although initially the light still not blink, but I have an option to set the wireless up (not there before). So try to update, it may helps.

hi where is this firmware


link plz???

As long as your LIVE is connected to the internet, it will discover new firmware automatically.   

What version are you running currently?

D-link dwa-160 H/W ver: A2 F/W ver :1.40

wd live tv :1.2

If you mean 1.2.21 then you’re already at the most current public release.

Your adapter isn’t supported.

I believe the poster who said he got this adaptor working was using pre-release firmware. (1.03.38)

You can get this firmware from here - Use it at your own risk.


You normally have to sign in to see the download link but I see there is an altenative link that works without signing in.


so I just bought this awesome wd media server because of its awesome reputation. I had some crappy d-link media server before that never really work. Before I checked which wireless adapters that really worked, I just pick up some cheap one in the store at the same time as the media server.

Like most of you guys could guess, it didn’t work well at all. Another trip and the to the store with this in my hand:


and I ended up with a dwa-160. After trying to get it to work, without any luck, I found out that I had an A2 version.

So thanks to above poster I downloaded the latest firmwire 1.03.43. here:


I can confirm that it work, atleast for me. It **bleep** that its such a pain in the back to get the wireless network working and next time I probably pick up something with a built-in wireless adapter.

Anyway, I got it to work in the end, so it’s all good.

Considering the fact the the WDTV HD, the WDTV Live and the WDTV Live Plus are all sold as HD devices (although they also work fine with SD material and an SD display), and considering wireless isn’t really the best option for streaming HD material, I wouldn’t count on WD adding built-in wireless to any new devices in the near future.

There’s too many issues out of WD’s control…

  • is the Wireless-N working over bonded 5GHz channels?  And is channel bonding even legal where the device is being used?
  • are there wireless-G and wireless-B devices bringing the connection down?
  • is there interference?
  • is the source material a bitrate that the wireless would even be able to cope with, under perfect conditions?
  • etc…

Adding a wireless adaptor in addition to, or instead of, the wired port would probably just be begging for a whole slew of complaints about networking issues that are out of WD’s control.  Just look now at all the issues people are having with their wireless setups – hoping to get the wireless to work as reliably as, and as an equal to, a wired connection or a direct-connected drive.

I feel like I made the right decision Cause the latest beta firmware got my dwa-160 revision a2 or whatever WORKING AWSOME…Western Digital did not put this fix in their notes but yes it seems they have added this to the list of working USB adapters… Just get a copy of the .43 firmware and it will work…

My right decision not returning the dwa-160 to office depot two months ago