Connection status failed

Uff, I’ve just tried… I’m still having this issue. I have a WD My Book Live DUO.

Regards

I am having this issue since 2 months aprox.
"Connection Status: Connecting "

All the time it says “connecting” I think it had a coincidence with a change of my internet provider. But I am not sure…
Have you fixed this issue?

Please, help me

If it worked previously to changing broadband providers and now doesn’t work under a new broadband provider. Its pretty much a given that your new broadband provider is blocking the ports need by the My Cloud for remote access. Either that or the router is blocking the ports.

If turning off remote access in the Dashboard > Settings waiting a few minutes then turning it back on doesn’t fix the issue then one will likely need to to the manual remote access setting route and also setup port forwarding within their router for the alternate ports.

There is a generic how to setup manual remote access ports in the following post. Even though it’s for the first gen v4.x firmware My Cloud, the process should be similar for the second gen v2.x single bay My Cloud unit.

Had this issue in one of my two WDMyCloud drives.

Basically, my issue was the date and time sync not working (was displayed in July 2016), therefore you won’t be able to connect to WD servers.

You can fix the sync issue manually through SSH:

  • Administrative panel->Settings->Network->Network services->SSH set “ON”
  • Start SSH-client, login as root/welc0me, check your current date with ‘date’ command.
    Then, to change the date to the real date you can use the following command:
    date +%Y%m%d -s “2021123”
    Lastly, to change the time to real-time, use the following command::
    date +%T -s “01:01:46”
    after that you can check that date and time are correct:
    date
    exit
    3)Administrative panel->Settings->Network->Network services->SSH set “OFF”

After the sync is fixed and it is reflected below the NTP Service field, turn off Remote Access and then turn it on and it will connect, if not, verify you have it in Auto mode and try again off-on.

I hope it works for someone.

Regards,
Alex