Connection issues: "Unknown error. Please try again."


#1

Hey there,

I ordered the WD MyCloud Home 2 TB from Amazon. It arrived today and immediately when it came, I started the set-up. Unfortunately, I can’t connect to the device. When I go to mycloud.com/hello I see my device (also the right code), but when I click at the “connect”-button I get an error message: “Unknown error. Please try again.”

What could be the cause for this error?


#2

I have the same problem
everybody has the same problem?
thanks


#3

Update: It works for me now. I did a hard reset - maybe that helped?


#4

Update 2: So yesterday it worked perfectly - I could access the Server from my local network and also from external networks.
Today I woke up and wanted to check if all transfers were finished correctly and - to my surprise - I couldn‘t reach it from my phone wich was connected to a cellular 4G network. As soon as I connected to my Wifi it worked again.

Are there any solutions for this? I really need this feature because most of the time I‘m not at home and need to access my files.


#5

always the same problem error unknown


#6

Just to add…

I bought a 3TB My Cloud Home and tried to install it today.

It too detected the device and showed the ID code, but clicking the connect button returned the rather unhelpful Unknown Error. Please try again message.

I called WD support.

I spent 75 minutes on the phone, going backwards and forwards between my PC and the My Cloud unit (located on different floors).

Downloaded WD Discovery software; Rebooted / Reset my Cloud unit; Disabled Windows Defender Firewall; Disabled McAfee Total Protection; Restarted PC; Tried to connect using a different PC with no Anti Virus software on it.

Nothing worked.

I went into the Router settings and could see it was there, but it wouldn’t communicate with either PC.

The WD support person advised that I had two options, escalate or return the device to the retailer.

I asked if support could be done remotely, so they can see and adjust any settings needed, but was told they don’t do remote access support.

I’m returning it back to the shop this evening. Unsure whether to exchange and try another or just get a refund.

As others are having the same problem just now, I may just take the refund.


#7

WD Community,

Thank you for reporting the issue.
Please try your connections and access again.
A reboot of the My Cloud Home and or the network router may help resolve the issue.


#8

Hi,

Thanks for your reply. It does make a pleasant change for a manufacturer to actually monitor and contribute to a forum.

Unfortunately, I have already robooted both the My Cloud Unit and the router and also checked connections, including trying a different port on the router - none of these worked.

Strangely mycloud.com and the WD Discovery app installed on my pc both returned the My Cloud units code; it was visible in the configuration settings on the router (showing ip address etc) and was visible on the network.

It wouldn’t however connect through mycloud.com or the WD Discovery app.


#9

@Surveyrobuk I sent you a Private Message requesting more information.

Thank You


#10

I bought 2 units and having the same issue. Is there any solution for this?


#11

i have the same issues :frowning:


#12

Same problem here with brand new device. I’m not able to connect and only information is “unknown error” which does not help at all :-/ Please WD, fix this asap.


#13

Same here just bought in Hong Kong, can’t connect to the device…


#14

Same issue on my end with every device (mac and iPhone), the online wd setup page and the apps I tried… bought the my cloud home today in Germany.

Reset and restarted the device as well as the router several times.

Please WD give us a bug fix for the issue, otherwise I’ll return the device asap


#15

I too have problems since a few days. I get random errors now and then saying my device is offline? Reset didn’t help.


#16

Same problem here, in Hong Kong again…Anyone has the solution?


#17

Same here
any solution?


#18

Same problem here. Unknown error please try again. Need a solution asap or I ll return it tomorrow. greetings!


#19

just bought in Taiwan.

same problem here too…

Can WD fix this problem ASAP? or at least customer service do something?


#20

@WD_Admin I have the same problem!!! why it happens?! for now I don’t have access to my data on MCH! you have problem on your side = I don’t have access. It’s not a normal logic if I can’t take my data from MCH on my room, because you server are lost!!!