Connect WD Home duo via ethernet/usb adapter

Dear All
instead of the ethernet port… i would like to connect my WD Home duo to my airport extreme via USB

I have read that should be possible using an thernet/usb adaper

Did anybody try?

Tks for any reply


Why would you think you can connect two USB hosts together and expect them to communicate without any special cable or protocol? Apple wasn’t going to write a USB driver for your airport extreme when it was still supported, they are certainly not going to do it now.

USB hosts (Airport extreme is a host, MCHD is another host) only support USB clients such as USB HDD, USB SSD or flash memory. This is well documented in the owner’s manual and KBA.

Hello, tks for your reply but im not an expert and maybe did not understand properly…

what i want to do is to connect the WD home duo to the airport extreme via ethernet\usb adapter

this because in the WD home cloud is stored my whole music files collection… but airport extreme is old and my streamer (bluesound node) does not see any ethernet-connected NAS to the airport extreme, only USB-connected… so im trying to workaround and having the node reading the WD home via USB using the ethernet\usb adapter

dont know if is clear…

You didn’t mention anything about playing music on your ‘streamer’ in your first post which basically is a two lines description.

If you are trying to play music on your ‘streamer’, you should turn on Plex Media Server on the My Cloud Home Duo (MCHD) and turn on DLNA. This is documented in the owner’s manual and in this forum and you should read it. Very few people would knows what this streamer you have and if it is compatible with anything, but usually DLNA is universally supported.

You are asking about the limitations of the Apple Airport Extreme. You should do that in the Apple support forum and not here. I gave you a link to the My Cloud Home Duo (MCHD) USB Knowledgebase (KBA) and you can help yourself if you read it. There are many limitations to the USB port on the MCHD USB host (similar limitations apply to the Airport Extreme) and if you try to use a ethernet USB adpater on either of them, they will almost certainly fail.

USB Backup Limitations

My Cloud Home and My Cloud Home Duo USB Backup does not support the following USB environments and features:

  • My Cloud Home Duo with more than one USB drive attached - Only the 1st drive that is recognized is mounted
  • USB Hub with more than one USB drive attached - Only the 1st drive recognized is mounted
  • Password protected USB drives - The password must be removed
  • Multi Partition USB Drives - Only the 1st partition is recognized and mounted
  • Mobile phone USB backups are not supported.
  • Digital USB Cameras are not supported.
  • Mobile tablet USB backups are not supported
  • 3.5" Internal hard drive USB adapters and docking stations are not supported


no is not an airport extreme limitation, is a WD home cloud one… in past years the WD home cloud was connected via ethernet to my airport extreme and worked perfectly… i streamed seamlessly for years all my music from the WD home cloud to the bluesound node

recently for some kind of safety protocol reason (BluOS no longer support devices like my airport extreme with outdated NTLM authentication)… the node cannot anymore stream from the WD home cloud if connected via ethernet… this is why im thinking to connect the WD home cloud to the airport via ethernet\usb adapter (because my airport also have an usb port)… hoping to bypass this security problem

this is the reason

This thread has become something completely different from what the original question was posed.

You still have a hang up about Apple Airport Extreme - it is no longer supported, it hasn’t been supported for 5 years. It is deprecated. WD My Cloud Home is still supported, and NTLM v2 is supported by MCH.

My Cloud Home firmware 8.12 and higher provides stronger security by only allowing SMBv2, SMBv3 and NTLMv2 protocols. This may result in previously connected network devices prompting for a username and password to access network resources.

If you just read what BluOS users are saying

I have a Powernode which until a few days ago was connected via Network Share with a NAS (a Vortexbox which is now around 10 years old). The connection was accidentally deleted and I have been unable to restore it. The Bluesound ‘Support Crew’ advised that:
"After reviewing your Diagnostic Logs, I can see that your NAS utilizes NTLM authentication to mount the device.

Our Product Development and Quality Assurance team confirmed that BluOS 3.18.7 includes a security patch to protect the product from possible ransomware attacks due to a network vulnerability. Since this vulnerability resulted from Microsoft’s NTLM authentication, we disabled it for file sharing to avoid potential attacks. Note that Microsoft has also phased out NTLM from Windows.

Unfortunately, NTLMv1 is still the only security authentication used in Apple Time Capsules, for which Apple has not provided an update since early 2019. Like the time capsule, some older NAS devices and older ISP-provided routers also use the outdated NTLM authentication method.

BluOS will no longer support devices with outdated NTLM authentication to avoid security concerns, as mentioned above.

If you are experiencing this issue, please review the NAS/router security settings and change the authentication method from NTLMv1 to any latest security protocol. Contact the NAS manufacturer or ISP for a security authentication update to the NAS/router firmware.

Alternatively, you can directly mount the USB drive to the BluOS Player instead of the ISP router until the router or NAS security settings are updated."

yes i know that i can mount an external usb drive into the usb port of the bluOS node… but my WD home duo only has the ethernet connection

my original question was very simple and stupid (at least for my limited IT knowledge):

if i use an ethernet\usb adaptor can i connect the WD home directly to the airport extreme usb port (or at least in the node usb port)?

looks like nobody knows… i also emailed a couple of times the Bluesound customer care without a real reply … i mean… the reply was: “we suggest to replace the airport with another router”… really?.. such a genius…i did not think about this option…!!.. ahaahaha

anyway tks for support at least you tried… that is much appreciated


If your My Cloud Home cannot be seen on the local network then you have a different issue to address and fix. As the above support article indicates BlueSound uses SMB to access a Network Share. Check the My Cloud Home settings to ensure SMB (Samba) is enabled.

actually my macbook perfectly see and read the WD home cloud in finder\network connections

point is that the BluOS Node streamer cannot see the WD home cloud due to the “safety” protocol restrictions reported above in the previous txt (outdated NTLM authentication)

Have you updated your My Cloud Home Duo to the latest firmware?
If you haven’t done so already, check what ever settings there are for the My Cloud Home to see if you can adjust the NTLM version or check what it is set to.
Have you contacted WD directly (opened up a trouble ticket) to see if they can provide any help?

Please ask your BluOS specific question in the Bluesound community forum because it is difficult for most My Cloud Home owners to answer these questions. If you go to the link below, your questions may have been answered already, in the Bluesound forum

Goodluck Embweze * 2 years ago * Edited
I have successfully attached WDMycloud Home to Bluos via Android app called SMB Server in Play Store. Bluos now indexes and plays flac albums. Just checked and can confirm it is gapless! Using a NAD C658 BTW.

You should also enable the MCH local access option to allow local LAN access of your private files.

Answer ID 34991: How to Enable Local Network Access to Data on My Cloud Home Using the Dashboard with Cloud Services


ok i will, tks anyway… !