Clean OS (Debian), OpenMediaVault and other "firmwares"


#1477

@AleBel,

-bash: gsync: command not found

For run software from current folder: ./gsync (add dot-slash).
Also try: chmod a+x gsync (add execution rights).
ls -la for see/check rights.


#1478

root@MyCloud:/data/shares/gs# ls
en-english.rfs gs-server gs-server.key html-templates
gs-gscp gs-server.crt gsync
root@MyCloud:/data/shares/gs# chmod a+x gsync
root@MyCloud:/data/shares/gs# ./gsync
-bash: ./gsync: Нет такого файла или каталога
root@MyCloud:/data/shares/gs# gsync
-bash: /usr/bin/gsync: Нет такого файла или каталога

I dont know what to do :frowning:
It looks like access deny .


#1479

Try the suggested ls -la to show the file permissions.


#1480

#1481

@AleBel, you are Russian?
For change system laguage do:
dpkg-reconfigure locale and chose your language (with UTF8 support).

About your problem - gs-server can’t find some files. I think he miss few system libs (.so).
Its possible to check via dev tools:
apt install binutils strace
then:
objdump -p gs-server | grep NEEDED
or
strace gs-server | grep error


#1482

hello guys, first post from me, have around 2 years enjoying OMV on myWDCloud Gen1. so first: thanks!
now I’m with a problem, a stupid thing I did on long night hours, clean Debian, OMV 3, lost /dev/sda4 yesterday, maybe some wrong type I did and red light is brilliant now.
i connect telnet for recovery and cant’t mount /dev/sda4 … so I’m stuck there.
opened from the case and used usb with not good luck, maybe because my Mac can’t read ext3 or ext4 or something like.
my English is not better, thx from now, any suggestions are welcome.
CamMx

#18 SMP Tue Nov 24 15:10:48 UTC 2015
Use this info for login:
Login: root
Password: mycloud

recovery login: root
Password:

BusyBox v1.23.2 (2015-10-10 12:34:21 UTC) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

~ # cd /dev
/dev # ls
autofs kmem pts ttyS1
bsg kmsg random ttyS2
bus mem rtc0 ttyS3
cachefiles network_latency sda ubi_ctrl
console network_throughput shm urandom
cpu_dma_latency null temp usbdev1.1
full port tty usbdev2.1
fuse ptmx ttyS0 zero
/dev # cd …
/ # mount /dev/sda4 /mnt
mount: mounting /dev/sda4 on /mnt failed: No such file or directory
/ #


#1483

well, when I was about to surrender debian live, gparted and testdisk give me back my data folder!
partitions was damaged and I could restore 2 of 4 … because data is here I guess will backup 3.6TB to another disk and will try DSM on next week.
anyway, if you think I can restore without risk these 2 partitions (check image) I can try. I’ve got 2 days suffering for my important data.
thanks again


#1484

@CamMty, check your hdd for bad blocks and SMART (apt install smartmontools, then smartctl -A /dev/sdc).
Use parted, repartition your disk:

rm 1
rm 2
mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M 100%
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
set 1 raid on
set 2 raid on
q

then, try start raid: mdadm -As or
mdadm --assemble /dev/md0 /dev/sdb1 /dev/sdb2
and try to mount /dev/sdb4
** Change sdb to your hdd (wd)!

If all good - put hdd back to wd box and power on.


#1485

I think , I need to install librt.so.1 libdl.so.2 libstdc++.so.6 libm.so.6 libpthread.so.0 libc.so.6 .
How can I do it ?

mount /dav/sda4 /data !
May be here you can see something helpful ?


#1486

BEAUTIFUL
thx!


#1487

All libs as i see - from libc6 (Standart library, present in almost all linux distro include Debian), so - no external dependencies.

try strace:
strace ./gs-server | grep open
Or grep “error”. Or dont use grep for see full log.


#1488

I’ve successfully installed your Clean Debian(Not OMV) on wdmy gen 2 with New HDD.
(WDMyCloud-Gen2/Debian/Dev/Debian-kernel-bin_4.14.4_002.tar.xz)

It seems that my wdmc is working well.
The only problem(or question) is…

I’m not sure if wdmc is sleeping or not when it is definitely not used.

Like your instruction, “/etc/rc.local” includes the following lines.

I guess that LED shoud be Blue when HDD is in standby(or sleep) mode.

Usually LED is steady green. Sometimes when there is a hdd access, it blinks yellow.
Is there any log file to check if wdmc goes into sleep mode? or any method?


#1489

Why the Debian or the bash can`t see files ?
Have You got any idea ?

After apt-get install binutils strace I have got this.


#1490

I like Green as default led state. Change it to blue, if you want.
For “Sleep mode” - need some tuning: Move all logs and caches to RAM. I dont add this stuff, because my HDD wors all of the time.
Some info here: http://fox-exe.ru/WDMyCloud/Other/HDD%20Spindown%20and%20sleep%20mode.txt


#1491

@Fox_exe
I followed your unbrick guide but it will not upload the file in safe mode? Thoughts?


#1492

@Fox_exe I looked into the inspect element and /cgi-bin/system_mgr.cgi is responding with a 404 error.


#1493

I followed the installation instructions and all went smoothly. I have sda1 as swap sda3 as system and sda2 for my data. However when I try to create a shared folder no devices show in the drop down menu. I’ve tried unmounting and mounting sda2 and still no joy, Any help appreciated. I have a 2TB gen 2 mycloud. Thanks
James

SOLVED - deleted the sda2 partition and after recreating I was able to mount within gui and create shares on the sda2 partition. Not sure why it wasn’t working


How to increase my partition?
#1494

@Fox_exe Hi Fox, thanks for your guide. Sadly I am completely lost. I have no idea where to start. I cannot find the autoinstall script.

Also, is there any step-by-step guide ?

I’m using a WD MyCloud Ext 2 Ultra

Looking forward to your help !


#1495

https://fox-exe.ru/WDMyCloud/WDMyCloud-Ex2-Ultra/


#1496

Installed Debian and OMV without any problem. But after reboot, i got no access to any service. no webinterface, no ssh, no smb. i can ping the device, but not more. testet usb recovery before i installed debian, worked ok, but now, the mycloud ignores my usb recovery stick, boots from HDD (sounds so) and the front light stays yellow. any ideas?