Clean OS (Debian), OpenMediaVault and other "firmwares"


#1497

@applebenny

rm /etc/udev/rules.d/70-persistent-net.rules
sed '/ipv6/d' /etc/network/interfaces -i
sed '/inet6/d' /etc/network/interfaces -i

#1498

Can you tell me how to create a USB recovery stick?
Did you try the TFTP restore-method?
I used it last night to install clean debian.


#1499

So what can we actually do about held back packages on Debian Jessie?

The following packages have been kept back:
  apt apt-utils bind9-host dbus dnsutils gnupg ifupdown init init-system-helpers
  initscripts iproute2 isc-dhcp-client isc-dhcp-common kmod libdbus-1-3 libkmod2
  libpam-systemd libsystemd0 libudev1 libxml2 openssh-client openssh-server
  openssh-sftp-server procps systemd sysv-rc sysvinit-utils udev util-linux wget

Running apt-get dist-upgrade seems to brick the system (no ssh) and a restore is needed.

Do I need to run apt-get install <package> for every held back package?

I don’t want to restore again but the updates look important.


#1500

Hi Mr @Fox_exe , so I did install Debian on the MyCloud EX2 Ultra, but after having some issues with the network, I rebooted and yeah… The device doesn’t connect to the network anymore, please tell me that there is a way to save this device! :frowning:


#1501

@HRVSTR, Update kernel to 3.2.68 (On my website / g.drive folder).
Its a SystemD issue (No required modules in kernel, so systemd can’t update).

@rspy24, Extract HDD’s, poweron device. After ~1 min. insert HDD’s back and connect via Telnet.
Do:
mdadm -As
mount /dev/md1 /mnt/root
nano /mnt/root/etc/network/interfaces
Check this config or rewrite to default (Replace MAC address to actual/real):

source-directory /etc/network/interfaces.d

iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp
hwaddress ether 00:90:A9:00:00:00

save by [ctrl] + [x], then [y], then:
sync && reboot -f


#1503

Thanks Fox_exe! Sadly the EX2 Ultra didn’t boot without hard drives for me, but i “fixed” by putting the drives on my pc and deleting the partitions and putting them back again on the EX2 ultra, so i did reinstall everything, looking back i should just remove the first 2 partitions and not the data partition too haha but oh well… Thanks !
oh, btw I did try to turn off the WD EX2 with OMV, and the device goes to a weird state where i cant connect to it anymore but the light stay blue and there is some minor noise coming out from it, like a fan spinning, It’s possible to entirely turn off this device with the debian+OMV combination?


#1504

confused with what model I have. It has a gen 1 codename but has 512mb ram like the gen 2. Am I able to put linux on?


#1505

Device won’t sleep, because “Weltrend MCU” (Microcontroller) still online.
(Led and Fan controlled by this mcu)
For turn off MCU: mcu_ctl sys_shutdown

Something like:
nano /etc/systemd/system/mcu_poweroff.service

[Unit]
Description=Complete power off device

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/sbin/mcu_ctl sys_ready
ExecStop=/usr/sbin/mcu_ctl sys_shutdown

[Install]
WantedBy=multi-user.target

And enable it: systemctl enable mcu_poweroff


#1506

hi! I tried to read this entire thread but i didn’t find any answer to my doubt… so, sorry for asking but, after installing debian is there a way to go back to the original WD software? I have the WD EX2 Ultra

Edit: I tried one of your tutorials, this one http://anionix.ddns.net/WDMyCloud/WDMyCloud-Mirror-Gen2/DSM/_Info_en.txt

But after restart i have Red blinking light on the power, and Red/Blue blinking at the same time on the HDD… is there a way to recover from this?


#1507

I got a mycloud gen 1 with debian 7. (local disk space 74%)
and a mycloud gen2 with debian 9 (local disk space 76%)

on gen2 i can only copy files to hdd as root, since i reached 75%.
regular users can not transfer data. not enough space.

root@wdmc2:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda3 6.9G 3.3G 3.3G 50% /
devtmpfs 10M 0 10M 0% /dev
tmpfs 249M 0 249M 0% /dev/shm
tmpfs 249M 7.8M 241M 4% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 249M 0 249M 0% /sys/fs/cgroup
tmpfs 249M 32K 248M 1% /tmp
/dev/sda2 7.3T 5.4T 1.8T 76% /mnt/hdd
192.168.0.11:/data/USB-Musik 1.8T 784G 958G 45% /mnt/nfs/musik
tmpfs 50M 0 50M 0% /run/user/1000
tmpfs 50M 0 50M 0% /run/user/0

are there any regulations of the filesystem ?
i checked the conf files (netatalk/samba), found nothing.

any idea ?

thx


#1508

So first of all. Thank you @Fox_exe and everyone else who’s making this happening.

I tried to follow your tutorial, but got stock after the first REBOOT.

> > 
> ======= INFO ===========
> /dev/sda1 - Swap
> /dev/sda2 - User data
> /dev/sda3 - Rootfs/Boot (Important for bootloader)
> ======= FW SETUP =======
> # Copy uImage, uRamdisk and rootfs-jessie.tar.xz to /boot/boot (Overwrite all)
> **# Reboot**
> # Connect via telnet

After reboot nothing happened, except my WD MyCloud wouldn’t pass the yellow-red blinking light and never found a way to connect via Telnet, no matter how much I tried.

After two days of reading and trying (imagine this is a sign of bricking) I decided I could try to connect my HD directly to my Ubuntu desktop to first try to recover my files. But after that, I believe I could either restore the files I overwrote (uImage, uRamdisk) or even better, try to do the partitioning while in Ubuntu.

I really would love to hear your thinking about this. I have a 2TB WDBCTL0020HWT-10 which I believe has 512MB of RAM, that made me believe to follow the guide for Gen2 so please if you think I’m doing something wrong, let me know.

Thank you again.


#1509

@ZeryOs, check CPU type in your device (And what version of original firmware installed previously?)
BCTL - Is a Gen1 device. Maybe you have some modification. But really important - CPU model/type.


#1510

I have a
Marvell 88F6720-A0-C080 which I believe (internet says here) a Processor ARMADA 375 RISC 32-Bit 800MHz 511-Pin TFBGA with a H5TQ4G63AFR that I believe is the RAM… now what can I do?

Thank you so much @Fox_exe


#1511

@ZeryOs, ok, its Gen2 device. And idk whats wrong. Maybe you miss something? Try “USB Recovery” method.
And notice: MAC changes, so IP changes too. See DHCP logs on your router for find new IP address of device.


#1512

@Fox_exe is it possible fo do the whole process while attached the HDD into my Ubuntu PC? Or it must be done via Network?

Thanks!

EDIT----

I tried the USB Recovery Mode, but wasnt possible for me to find it on any IP adress and my router wouldnt show any device but my computers connected.


#1513
Fehler #0:
exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; hostname --fqdn 2>&1' with exit code '1': hostname: Name or service not known' in /usr/share/php/openmediavault/system/process.inc:175
Stack trace:
#0 /usr/share/php/openmediavault/system/net/dns.inc(46): OMV\System\Process->execute(Array)
#1 /usr/share/openmediavault/engined/rpc/system.inc(379): OMV\System\Net\Dns::getFqdn()
#2 [internal function]: OMVRpcServiceSystem->getInformation(Array, Array)
#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
#4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getInformation', Array, Array)
#5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('System', 'getInformation', Array, Array, 1)
#6 {main}

openmediavault_control_panel

The Installation on my WDMC 1Bay Gen2 went smooth with the instructions added here from fox and other users. Many thanx guys.
But once OMV started I get this error. Anyone any idea?


#1514

Does anybody have access to a video with the whole process? I’d loved it to be about the GEN2 but and the process would work just fine for me to follow the steps I’m missing.

At the moment I have neither a Wd Mycloud working nor a CleanOS. And I really want the later one.


#1515

@ZeryOs have you lost all your files and data?


#1517

@hippyfox When connected to my Ubuntu OS I was able to recover the files I cared about. But I really want to do this so I decided to do the recovery process via Ubuntu and after I have Debian running fine, I’ll do the process all over again until it works. Afterwards, I’ll try a recovery process to get my data back.

I could probably back them up but I’d take up to one day or more while using this process.

Regards


#1518

I really wanted to try installing the Clean OS, but it seems I did something wrong. And not only that. My device got bricked.

I followed the process of installing via SSH but something went wrong and got “bricked”.
I was still able to access the files if I’d used a SATA-USB adapter connected to my Ubuntu computer.
Recover what I wanted and tried to follow the process with the PC. Tried the USB recovery process but nothing would happen.
Tried to do a full install on the PC and ended up wiping everything and a blinking red-yellow led.

The closest I’ve been to recover functionality in MyCloud is by using Ubuntu to recover the HD but the result a dead-end.

This is what I end having while “updating the firmware” in WDMycloud Recovery Mode.

What I think is that in order to install any custom firmware, I must have one running because I made several attempts and modifications to @Fox_exe method and the result was never good tough different colors and blinkings in my led.

What I think might be an alternative (unless you think otherwise) is to install it from a “virgin” copy of the HDD, which I do NOT have. I accept any alternatives at this point and ideas.

Thank you so much!

EDIT—
I have a Gen2 MyCloud 2TB.


Recover a Gen2 My Cloud HDD from brick
[GUIDE] Debrick a completely dead MyCloud