Clean OS (Debian), OpenMediaVault and other "firmwares"

(@Fox_exe):

Yo, I just PMed you. And I’m headed off to work right now, so it’ll be later today.

Anybody runinng debian + omv had success to send the HDD to sleep permanently?
I tried many things already including the instructions provided by fox_exe to spindown the hdd (ramlog etc.). But no success. Would be a shame if I have to go back to stock firmware :confused:

@seb_r
its definitelly posibble to spindown the disk with clean debian. Works for me just well for more than year. OMV, however, adds lot of garbage so not sure if you can achive this. Anyway, instructions from Fox_exe are a good start but then i did lot of googling and testing arround spinning down the disk under debian.

@defcon
just wondering, i am now running clean debian on mycloud gen1 for 1+ year. Is there any good reason, besides fancy ui, to install DSM? Thanks

Nope. Debian more flexible.
If you need “Fancy UI” - Install in debian OpenMediaVault, WebMin or Ajenti.

I have a very simply question that I could not find by searching the thread. Is the access to my device from the WD mycloud.com website still possible after this OS/Firm change?

Thanks!

Hey, Have the DSM 5.2 running on my wd cloud 2t. Does anyone know how to get the usb port working? I would like to plug an external stroage to it.

I am having an issue. I upgraded my kernel to 3.2.68, with iptables_filter. I am not sure how to add ipset in the kernel. would you be able to help me out Fox. Thanks

WDMyCloud-Gen2
3TB version
Copy uImage, uRamdisk and rootfs-jessie.tar.xz to /boot/boot (Overwrite all)
then Reboot
the LED became red and yellow, can not boot

open the box connect the HDD to ubuntu OS

cp uImage-wdrecovery /mnt/boot/boot/uImage
cp uRamdisk-wdrecovery /mnt/boot/boot/uRamdisk

the WDMy Cloud-GEN2 resume to normal

how can i change it to debian and OMV firmware

Telnet accessable? (Device will get NEW IP, because MAC address changes).

check the router log , no client get the IP
My GEN2 CPU is Marvell Armada 375

Does it support clean Debian ?

Yes. (WDMC Gen2 in my terminology).
https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/Debian/

Hello Fox,

I have been following your posts in WD forum for quite sometime now and found your explanations much easier.

I would like to seek your guidance to host a web server with few websites running.

From past 3 months I was spending time learning Linux technology as I wanted to setup a mini scale web server hosting couple of websites only, as such I learnt Fedora and Apache.

Eventually, I purchased WD My Cloud v2.21.111 and was under the impression that I could implement the webserver and pages…but to my distress I did not even understand this infrastructure; however, I have understood from all these posts that there is a possibility.

Hence, would you please guide or point me to a direction to know how can I implement this - need Apache + Joomla or Drupal + OwnCloud.

Regards
Raj

Hi Fox,

thanks for your guide ,my WDMC Gen2 installed OMV
but now the OMV can not add a shared folder for instance, I have no device listed. It shows blank.
check the OMV file system . the /dev/sda2 automatic mouted , can not umount and delete

Need unmount data volume in fstab and mount it from WebGui (This add’s new, correct, record to fstab and omv database)

I get this error while trying to run apt-get command via chroot - bash-4.3

Error Message: apt-get: error while loading shared libraries: libapt-pkg.so.4.12: cannot open shared object file: No such file or directory.

Hi Fox!

Thanks for your effort in the first place. I managed to get DSM installed and running for now… but i have a little problem, if i reboot, it only will reboot if i put the usb stick in for 10 seconds while booting. otherwise it will give me a red light.

i tried to create a boot folder in the / directory and put the same uImage and uRamdisk in it that i have on the usb… but didnt work. is there any way to get this fixed? thanks!

Need put this files to 3rd partition (/dev/sda3, /boot folder). sda3 mounted as /volume1 (if I am not mistaken).

yeah that did the trick. shame on me for not trying this ^^

i got one more for you haha, i managed to setup a cronjob that mounts the sda3 on reboot… but here it comes, after i reboot, my shares in the filestation disapear. you have any idea whats wrong here?