CHKDSK not working (DIRTY)

Hi,

I have looked pretty much everywhere and i can’t seem to find a proper fix. I currently have a 3TB hard drive that i have format in ExFAT so i can crossplatform it for MAC and Windows, i was working on some files yesterday and i unplugged it in a hurry without doing the safe exit. Since then, i am unable to edit, create or delete files of that drive. I am a computer tech in life and have tried many possibilities. I have done a chkdsk /r, i have run a chkdsk on startup, use WD tools to try to repair, looked into Hex editors to try and modify the Dirty Byte to recover it quickly. ExFAT seems to be pretty complicated when it comes to repairing since everything led me to failure. Chkdsk gave me and error. When trying to write to the drive i also get an error (Error 0x80071AC3). I am a bit out of ideas here and was wondering if anybody had some suggestions.

Any suggestions will be greatly appreciated,
Thanks,
Michael

Hello,

I believe the partition might be corrupted. If you wish to recover the data on the drive I recommend using a data recovery software and then format the drive so you can use it again.

Hi,
I am faced with the same issue on an 8TB drive, and reformatting it isn’t really an option for me. I bought this drive specifically for backups.

Did you ever find a working solution for ERROR 0X80071AC3?

Thanks in advance for letting me know.
Cheers,
Colin

Same issue here, WD My Book 4TB … Got locked out because of a quick disconnect even though the drive is supposed to be set for not having to use safe eject. ( so much for that feature )
So now windows flagged it as a “dirty” drive, which makes it read only.
I tried everything as well with commands etc, seems ExFat is a real pain when it comes to trying to clear the “dirty” status.
I’m not going to even try messing with a HEX editor.
Anyone find a solution to this problem yet ?
One guy said, just buy another 4TB drive transfer all the data to that and reformat the “dirty” drive.
That may be my only option since WD doesn’t seem to have a fix for this.
I’ll dig around on Microsoft and see what I can find, since it really is a windows issue and not really a WD issue, the drive has worked flawlessly, physically speaking and tested as well.
Just a real frustrating issue.

Hi,
I am also facing similar issue, same error message and it says disk as Dirty.
I can read data but cannot write into it. Can I copy entire data on my c/d/e partition and format my portable hd? Pl. advise?

I want to share my experience on successful tackling of rather unexpected and seemingly insoluble issue with my external HDD (preformatted as exFAT).
A couple of days back when I hooked up my 8TB My Book to a notebook with Win8, which I had been doing quite regularly and without any hassles, all of a sudden the system popped up an intimidating message that Windows discovered errors on the drive and suggested that they should be checked and fixed.
But the checkup (first done from a menu, then with the standard chkdsk tool from a command prompt) eventually failed returning advice to scan the HDD once more. All other subsequent attempts appeared futile. The system said it spotted the errors and refused to sort them out. Apparently the HDD has been marked as “dirty” and read-only.
I suspected that the problem was more likely attributed to the faulty USB port or outdated system drivers or whatever else, rather than my fairly new (several months old) HDD, which I used to treat like a princess. The suspicion grew when I double checked the disk with WD Drive Utilities and Data LifeGuard Diagnostics and all the tests, including overnight 15hrs thorough physical sector-by-sector scan (more than 15.6bn sectors on an 8TB disc by the way) passed without any issues. Now when I was 200 pct confident that my disk is in no way “dirty” and the problem lies in Windows checking and error reporting pattern, I focused my online search on the instructions on how I can get rid of the annoying and unreasonable notification preventing normal disc usage.
I watched numerous dumb youtube instructions, the majority of which reduced to “simple and reliable procedure” involving… chkdsk (which, as I said, never worked in my case). How original!
Some enthusiasts advised to manipulate with HEX-editor to remove dirty bit marking, to upgrade drivers, to reinstall Windows, and finally suggested that the SAFEST if not the SOLE solution for the drive with exFAT is unavoidably backup-reformat-copy trick (which, in terms of a large capacity drive, may take days to complete).
When I was so desperate, on the verge of resorting to the latter variant, I incidentally came across an interesting thread discussing the inadequacy of standard chkdsk tool, which is incapable of proper addressing the exFAT volumes integrity.
It turned out in this regard that Microsoft had long ago proposed a small hotfix for the chkdsk tool:
https://support.microsoft.com/en-us/help/2843376/chkdsk-tool-incorrectly-reports-exfat-volume-file-system-as-corrupted
They say it is designed for Windows 7 or Windiws Server 2008, but its 64-bit version fitted my Win8 64bit machine like a glove.
After installing the hotfix I plugged the “doomed” WD My Book to a USB3.0 port. The message on the (nonexistent) errors expectedly popped up suggesting again to check the disk, which I willingly did. But this time the checkdisk finally did its job right. It took a mere 20 seconds to implement a short scan, after which the system advised that my HDD is clean and has no errors.
From now on my favorite My Book purrs like a cat, without any issues whatsoever.
Hope this may be helpful for somebody out there, who had enough patience to read my entire post. Good luck.

3 Likes

WOW! You are the Living $hitz mate! I humbly bow to you!

:smiley: FINALLY, a solution to what appears to be a VERY obscure thing that I had never encountered before. Finding that VERY obscure Windows fix was precisely what I needed. Thank you! Thank You! THANK YOU!!!

Just to say again, REALLY REALLY appreciate you taking the time to write out nicely and clearly your situation and how you found an answer to it. Frigg’n LOVELY man!

1 Like

Dear Aboming,
Thank you for your answer.
could you please send me or put the hotfix somewhere that I can download it.I have still windows 7 and I could not find it since it is removed and only for windows 8 is available,which does not work for my windows 7.

Thank you very much

Hi sso14,
Kindly be advised that I sent to your email the link to the older hotfix allegedly suitable for Win 7 64bi that I found for you on a random site. Hope it may be suitable for your case.

Hi,
For long time, I am also facing similar issue. I have Win 7 and run 64bit Adobe Photoshop program. I have issue with Hard disk though it is allowing access (after running chk dsk) but I cannot save or write into it. I don’t know if “hot fix” referred by you would solve my problem but I want to take a chance. So, kindly send me the file in my email mybidikar@gmail.com
Thanks…

PORTABLE HDD NOT ACCESSIBLE – I found ‘trick’ by chance. I was stuck with my 1TB WD Elements with NOT ACCESSIBLE issue for long. I tried ‘hotfix’ suggestions offered here but none worked. Then I chanced upon following software which is for Data transfer – in the link multi options exist from Trial version to Paid ones. I took chance and downloaded ‘Mini Tool Power Data Power v8.5’ from following link

https://www.minitool.com/data-recovery-software/free-for-windows.html

After downloading s/w, I plugged my redundant hdd and allowed it to scan and run for transfer of data. But, as there was huge data on disk, the time went on revising for 7-8 hours to 30-40 hours. Yet, I ran the TRIAL version for about 10-12 hours and then fed up for not wasting any further effort on this, decided to PAUSE AND EXIT the data transfer. Luckily, it did not stop me from safe exit. MIRACLE – Then, I thought of running checkdsk (though I had attempted this several times earlier without above trial run) by using usual command prompt chkdsk(gap)(drive):f\

Above, check disk again went on for atleast 8-10 hours, but this time I allowed it to complete.

After, completion did safe EXIT and hooked my DEAD HD…BINGO…!! It showed all my data without any corruption and could REVIVE IT.
Anyone, who is still stuck with this issue for Win 7 (64bit) and later issues may probably try this TRICK… BTW… I am not a NOVICE in Computers. Thanks…

Hello Abominog! I too need the Windows 7 64-Bit version of the Hotfix. May I also have the link to the file you found? Kevin =)

Hello latheofheaver! I too need the Windows 7 64-Bit version of the Hotfix for my exFAT drives. May I also have the link to the file you used or the executable itself? Kevin =)

Hey Bro! Dude, to be totally honest, I don’t even remember quite what this issue was. I will hafta go back and read and then see whatever it was that I did!

Sorry about that, but I will take a look and see what I can find mate! Cheers!

Thank you L!

I await your good word when you can. =)

Kev

=)

The link is further up in this thread above where Abominog first posted it. I clicked on it and it appeared to go to the Microsoft page. Didn’t you try that…?

I did… But it only show Windows 8 rather than Windows 7.

=\

Well, FWIW, I am running W8 :slight_smile: and, TBH it’s been quite a while, but it must’ve been the one I used.

Copy that. Thank you for the response!
Enjoy!

Kev

=)

Hello latheofheaver! I also need the Windows 7 64-Bit version of the Hotfix for my exFAT drives. May I also have the link to the file you used or the executable itself? BradP👍
msrpirani@yahoo.com

1 Like