Can't write to usb attached storage devices

I’m fairly pleased with my new My Cloud 3TB. Reed and write speeds are very good for me (up to 75 MB/s write speeds for large video files) and after some initial hickups seems reliable so far (uptime = currently ~5days after setting static ip).

However i’m having one big issue. I am not able to write to any external storage device connected to the usb port (tried usb 2.0 and 3.0 hard drives + various usb 2.0 flash drives).

The drives are freshly formatted (NTFS) and safely removed from a Windows 8.1 machine before connecting to the My Cloud. They are immediately recognized by the My Cloud and reeding off the external drive does seem to work (after copying files when attached to my PC). I get an error something like “This folder already contains a file named …” (= excuse me for any translation errors). Already tried enabling SSH and copying data straight from the NAS itself to the external drive using WinSCP, same kind of error.

Any ideas what’s going on here or anyone having the same issue? I really like the My Cloud but this issue is a dealbreaker for me if it can’t be resolved.

Thanks in advance for any feedback!

Have same problem. No help so far :(.

Same here…  I attached a WD Passport Ultra and I can read files from it but I can’t write to it.

Running the latest firmware, I mount the external drive as a network drive in Windows 7.  When I drop a small (1kb) file on it, it’s really, really slow.  At some point, a copy dialog pops up and about 30 seconds later, it goes away.  A zero size file of the correct name is created on the drive but no data is ever written.  Sometimes the file doesn’t actually show up in the folder window but if I try to copy the same file, I get a “do you want to replace this file” dialog.  Plugging the external drive into my desktop computer shows the files were created but all of them are zero size.

I’ve checked that I have write permissions, turned off media sharing for the external drive, plugged it in and let it sit for an hour to see if there was some startup job that needed to finish, etc.  I guess I’ll hope this gets resolved in a firmware update or if I’m feeling really ambitious, I might try ssh’ing in and looking around the linux file system to see what’s going on.

That sounds like the exact same issue indeed.

I already created a case for this with WD Support, but haven’t received any feedback yet. I’ll certainly update this topic when (or if?) the busy folks over at support look into this issue.

If anyone has any further ideas, please don’t hesitate to share them here.

Just for completeness, it looks like someone else reported this about a month ago here:

No solution there either.



most problems (user problems with something) since Windows 7 are related to access rights.

Just run Windows Explorer, or commander (like or Total Commander) as Administrator and that’s it!

To do it e.g. hold on keyboard and then right click over commander icon - list will appear. Select “Run as administrator”, input password, use disk attached to WD My Cloud.


So, WD solution seems to be OK. Users just do not think about their systems etc.

Mounting disks, writing and deleting files works even with password locked WD drives (encrypted - eg. WD My Passport).

Hey Marcint,

I’m afraid I can’t verify your solution because I already returned my device and bought a Readynas 102. It does indeed sound like it probably will be the solution.

If only I knew this a few days earlier… I would probably have kept the My Cloud.

Thanks for the solution, as it might serve others with this problem!

Let me check this method out! Thanks for your suggestion!

Okay, just try. Not working for me :(.
Btw, I am using win8.1.


I’m not sure I believe this is a solution.  Why would the My Cloud drive share be perfectly usable and the external USB not be usable?  That’s not a problem w/ my Windows permissions - that’s a problem w/ how the cloud drive is presenting the shared drive to the system.  If both were unwriteable I could believe it’s Windows, but it’s just one of them so My Cloud must be doing something different with them.


First question - it does not work for you or you are not able to see “Run as administrator” when launching Windows Explorer?

I tested it on Windows 8.1, so it works on Win 8.1.

I have met a few times IT guys which could not pass some folder problems. It always was related to security permissions for user or groups. So, this is why I followed this way and now i am able to write to USB disk without any problems.

Sharing is performed  by My Cloud - as hardware of course. Software - I am not sure. Most of us want to secure our files with passwords, so we create accounts with passwords. So maybe My Cloud or Windows (because of some My Cloud’s settings) asks about password to protect files.

Look - if you could connect USB disk and it would be accessible without any password, you would complain a lot about lack of security.

I have just input my administrator password in Windows Explorer (when launching it) and that’s it. I am not sure, but maybe you can set it to be remembered by system (not recommended).

You do it once per session - the same as when logging in to My Cloud panel.

If network share asks you about user and password, use your My Cloud admin password - to be sure of highest access level.

I am ready to help, because I am sure it should work.