Cant Transfer files over lan to my Wd My cloud EX2 Ultra(2TB WD RED))

I don’t know the problem. but no a days i can’t transfer files from my win 10 PC to WD My Cloud EX2 Ultra NAS.
NAS is connected to my home modem +router(ASUS DSL AC68U) via Gigabit ethernet cable. My PC is also connected to my router vai gigabit ethernet cable.

Earlier i was getting transfer speed of around 75-100 MBps while transfering file bw NAS and PC.

Recently a problem has started occurring. On the NAS in a share I have folder where I store all my family photos and videos(size ~ 279 GB). When I try to access that folder using WD My Access utility, the file manager browser don’t responds at all. Its like the NAS has become unresponsive.

When I try to copy some images or video to or from that folder, I get initial spped of 344 kbps and after some time I get error " 0x8007003B".

I searched this error and found some troubleshooting steps to avoid this error from officail WD community page"0x8007003B Windows 10 & WDMyCloud".

All this troubleshooting did was that it changed the initial transfer speed to 28 MBps, and then speed crashes down to kbps.

Don’t know whats wrong. I have done Full Disk Test and System Test in Utilities in setup menu of “WD Setup MY Cloud” portal

Hi mahipalwd,

You can refer to the link mentioned below to resolve the issue with WD My Cloud EX2.

@john15 PC Config----i5 6600k | Asrock Z170 Extreme4 | GSkill 16 GB DDR4 2400MHz | Asus GTX 1080 | OS Drive Samsung Evo 850 EVO 500 GB | Secondary Storage WD 500GB 7200RPM

WD My Cloud EX2 - 2TB WD RED HDD

My MOBO has Gigabit Ethernet lan port. So WD NAS is connected to my home modem+router Asus DSL AC 68U via cat6 cable. And my pc is connected to modem+router via cat6 also. I have tried most of the the troubleshooting. done WD nas reset as well. But nothing worked.

I doubt that data is fragmented in different sectors in the hdd on nas.that’s why nass hdd has became very slow to access via windows file manager.

do you have any idea, how to de fragment data on hdd in My Cloud EX2 Ultra??
or could there be any other reason??

Has the pc recently gotten the win10 version 1903 “update”? I have similar problems on two pc’s that got that “update” recently.

Edit to add: I am scouring the net. I see references of SMB 3 being “rev’d up” in this build of Windows, and not playing nice with components running SMB3. I know my EX2 ultra has SMB 3 enabled. My next step will be to disable SMB 3 on the NAs (I won’t be able to try this for 24 hours).

Also, I have an older MyCloud single bay unit. Windows 10 version 1903 seems to work fine with it. (I don’t know what SMB protocols it uses)

No joy on disabling SMB3 on the EX2. :frowning:

Opened a support case with WD. . . . .lord only knows how that will go.