Can't connect to My Cloud server from Mac Finder


#1

I just set up my MyCloudEX2 Ultra server. So far, I have only been able to drag and drop files onto it using MyCloud.com. I have not been able to connect locally to it using Mac Finder.

When I open Mac Finder, I see the MyCloudEX2Ultra icon appear in Finder. So, I know it is discovered on my network. However, when I click on the "Connect As’ button, the connection fails regardless of how I try to log in. I’ve tried logging in under my name as a registered user, as well as using admin and the password I created for my account. I’ve even tried logging in as ‘Guest’, all with no luck. All that happens is the log in window disappears and I see a connection failed message in Finder.

I’ve been able to add folders and files to the server using MyCloud.com. But I need to resolve this because I’m not able to sync my devices, plus now I want to point my Sonos system to this NAS device.

Has anyone encountered this issue and does anyone have any suggestions about how to resolve it?

Thanks,
John


Mac "Connection Failed" Message
#2

[quote=“John_Berg, post:1, topic:182351, full:true”]
I just set up my MyCloudEX2 Ultra …[/quote]
You may want to post your question to the dedicated EX2 subforum where people more familiar with the EX2 Ultra may be able to help. This subforum (My Cloud) is generally for the single bay My Cloud units. Generally if you are prompted for a user/login name and password to access the My Cloud from the Mac Finder or Windows File Explorer you would input the login information from an account (administrator or Users) created using the My Cloud Dashboard.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2


#3

Thanks for the advice. I will repost on the other forum. But what you address in your response is precisely the problem I am having. I am unable to log in using the login information I created using the My Cloud dashboard.


#4

Do a 4-second reset. This will clear the admin account details. Read the User Manual for details.


#5

The 4 second reset didn’t do anything. I can connect via admin or the user id when I connect to the local URL. But I can not access anything by connecting in Finder.


#6

Check the Shares list, see if there is a share called “.twonkymedia”. If the share exists, delete the .twonkymedia share and then try the connection through Finder again.


#7

How exactly are you trying to connect via Finder? Like this?

Do you have any other devices you could use to try to connect to the file server? Kodi? Android devices? iThing (e.g. File Browser)? Can Sonos access an SMB server, or only DLNA?

Just trying to see if the MyCloud file server is running and it’s a Finder problem, or if the MyCloud is not working properly. The MyCloud is obviously visible on your network if you can access the Dashboard.

I seem to recall some mucking about with keychains on the Mac; have a search on the forum. I don’t own a Mac, so can’t gve detailed help.


#8

Thanks so much again for helping me solve this. I followed Timothy_G’s advice and deleted the twonkymedia share and lo and behold I am now able to log in MyCloudEX2Ultra. Hooray! You have no idea how much time I spent adding/deleting users and changing permissions. Thank you again for helping preserve my sanity. It makes me wonder why the profile is set up this way by default if it has the potential to mess up user access.

My next task is to get the EX2 connected to my Sonos system. This issue was blocking my ability to do that. So, thanks again for helping me clear this hurdle. You guys rock!


#9

Wow, that’s weird. Must be an EX thing… Nice spot.


#10

That .twonkymedia share is created after a system restore. It was a bug that has been fixed in newer firmware.


#11

It wasn’t, by any chance, a sensible bit of coding to save the contents of the twonkymedia folder before doing a restore, and then putting the folder back in place? That would have been nice, and would have saved Twonky being destroyed by system restores… I’m not sure if v4 MyCloud firmware does that. And I’m not going to experiment to find out…

Does that mean that John might be better served by updating his firmware, or do you think that .twonkymedia share was lurking there from a system restore performed some time ago, with the old firmware?

EX devices: it’s a whole new world out there… :wink:


#12

that share is empty, none of the drives files are stored in it. Updating to the latest firmware would be the best way to prevent this in the future. Deleting that share has no effect on the media server.


#13

In my case, I’ve only had the server up and running for about a week now. When I first installed it, the system prompted me to do a firmware update, which I did prior to having the problem I described. The twonkymedia share was created by default. I’m on firmware version 2.21.119 which is the most current version according to my system settings.

Everything seems to be working quite well now, including adding the music library to my Sonos system. Its awesome.


#14

I am having a similar problem, however, I’m not sure what or where the “share list” is. Can you tell me? Thanks.


#15

It’s the list of Shares that exist on the MyCloud. You can find it via the MyCloud’s Dashboard User Interface. See Chapter 7 of the User Manual (‘Managing Shares’) for details.


#16

The WD Access software still is an issue with Mac OS Sierra and fear it will only become more useless when High Sierra is available. WD Access has not been updated since 10,0.4.2019 in 2016. I can continue to wake the drive with an older MacBook running Lion but not Sierra. Although flaky, I can connect with Sierra and most times shut the My Cloud EX2 down, I feel WD has fallen behind in updating the software for the Apple platform.

Bill


#17

Not sure what WD Access is supposed to do; I’ve never used it.

You can map shares into Finder, and use the Dashboard to shut the device down


#18

Getting to the dashboard has alway been flaky as well. The drives are AWAYS thrashing so the unit seems too busy to respond to the web browser. I’ve tried Chrome, Safari and Firefox, all with the same results when the unit refuses to respond, I end up pulling the plug. WD Access allows you to Upload Files, Open the console, go to Settings, and Shut Down. The WD My Cloud is connected to a Gig Port and the MacBook is also using a wired connection to the same router.

Bill


#19

I finally was able to connect with Finder on m MBP. I followed the instructions from someone in here who said from finder/go/connect to server and the + but what was throwing me off was that no username or password I would put worked and somewhere I read to connect as Admin which worked. I tried every user account on my WD and PC info etc.

I’m now able to connect after using Admin and password*

WD has the worse software, finder is a much better software for viewing/uploading files. I like the phone app but the OS version should be 3000 times better. Uploading is a pain because it doesn’t even recognize if a file already exist so it will pretend it doesn’t and upload it while there’s a version already on the server. It’s a pain and awful software… finder works best.


#20

I have run into the same problem.

Can not acess WD cloud from Mac-mini’s finder and itune suddenly, but from chrome.

WD Cloud can still be seen from finder but not itune.

Although I can acess my WD Cloud Home fom Chrome, I can not acess it from finder and itune.

Because that the download of itune movie was stopped suddenly.