Can't connect android Phone to the WD passport device


#1

Hello I’m Roland.

I just bought a WD My Passport wireless HDD.
Everything on my PC with Windows 10 is working fine.
I can also access the drive from the explorer.
My problem is i can’t get a connection from my android phone to the disk.
This, because i get an authentication error message.

Can anybody help me on this one?

With kind regards, Roland


#2

Hello,

What is the make model and version of Android of your phone?


#3

my phone is a MOTO G 4 Play with Android 6.0.1


#4

This may be similar to the Moto G3 wifi issue.
I’ll escalate the G4 to engineering.


#5

Thanks for the reply and your work, although it is not the answer i was looking for.
hopefuly there are some changes in the near future.


#6

#7

I know this is an old issue and I’m not sure if this has been resolved already. I’m experiencing the same wifi connection problem with my Xiaomi Max running on Nougat. The WDMP works fine with an older Asus phone running on Kitkat.

Any advise on this?


#8

Issue is still not resolved. No further information from WD. Still haven’t found a workarround for my phone. With iPad it’s working fine.


#9

Hello Roland_Hermkens ,

Unfortunately, there is no updates yet. As discussed , Moto G3 and G4 Android 6.0.1 cannot connect to My Passport Wireless Wifi.


#10

Almost one year ago and stil no solution to this problem. It would be verry nice if some could tell me what this is about. Is WD still working on a solutiont, or there will be no solution in the near future. Just so that I know what to expect.


#11

Hi Roland,

I know that this is more than a year old thread, but if you still have this problem it may help you. Also it may help other people with Motorola phones having the same issue with the WD MPW/MPW Pro drives.
Last month I’ve bought 1TB WD My Passport Wireless. I was looking specifically for the first version original MPW as it is much more compact and light than the Pro successor.
Soon as I’ve got it I realized that I have the same problem connecting my phone to the MPW’s built-in Wi-Fi. My Phone is Motorola Moto G5S (with Android 7.1.1) and suffers from the same issue like the previous generations G3, G4. I guess that more Motos are affected.
Last few days I was very disappointed and angry about this problem and because there is no solution for more than a 2 years from WD…
I’ve started digging in this problem and finally yesterday I’ve found a reliable solution!
Here is a relatively short description how I’ve identified the problem and how I’ve resolved it.

I. Identifying the problem:
I’ve turned on the Developers Options in the Settings menu of my Moto G5S and than under Networking I’ve turned on “Enable Wi-Fi Verbose Logging”.
This showed me that phone attempts to connect to the MPW’s Wi-Fi it constantly gets “NETWORK_SELECTION_DISABLED_AUTHENTICATION_FAILURE”.
As I was unable to think of how to get more error logging from the phone I looked at the logs of the MPW. They could be downloaded under the Support tab\System Reports in the MPW’s Dashboard, when you connect to it with a PC.
When I’ve downloaded the .zip file with the Logs I’ve extracted it and in the file “rsysmessages” (Open with Notepad or text editor) I found multiple connection errors from my phone.

There were repeating error lines with the MAC address of my phone’s Wi-Fi:
MyPassport hostapd: wlan1: STA “Phone’s Wi-Fi MAC address here” IEEE 802.11: authenticated
MyPassport hostapd: wlan1: STA “Phone’s Wi-Fi MAC address here” IEEE 802.11: associated (aid 1)
MyPassport hostapd: wlan1: STA “Phone’s Wi-Fi MAC address here” IEEE 802.11: disconnected due to excessive missing ACKs
MyPassport hostapd: wlan1: STA “Phone’s Wi-Fi MAC address here” IEEE 802.11: deauthenticated due to local deauth request

The I’ve started searching in Google for the “disconnected due to excessive missing ACKs” error and soon found that there could be an option for ignoring this behavior, as the other side of the connection may not process these awaited ACKs.

II. Resolving the problem:
As the internal system driving the MPW is some Linux, I’ve first enabled the SSH access to the MPW trough the Dashboard under Admin section.
I’ve used Putty (I’m using Windows PC) to make SSH connection to the MPW using the default internal IP of the MPW (192.168.60.1, credentials are provided when SSH is enabled in Dashboard).
Then I’ve searched for a config file for the Wi-Fi and found it in /etc/hostapd/. File is named “hostapd.conf” and in it almost et the bottom of the file there is the option preventing most Moto phones from connecting.
The option is called “disassoc_low_ack” and by default it is set to “1” (disassoc_low_ack=1). I’ve used “vi” in the PuTTy session to edit the “hostapd.conf” file and changed the option to 0 - disassoc_low_ack=0. Saved the file and rebooted the MPW.
After the reboot I was able to connect to the MPW’s Wi-Fi with my Moto G5s without any issues. Connection is stable and haven’t had no dropouts at all ever since.

I guess after every Factory reset of the WD MPW you have to do this change every time to re-gain connection to the MPW’s Wi-Fi, but this should not happen often.
I hope that someone at WD sees my post and if they still support the original MPW may consider this fix and release a new firmware update.
I guess some models of Xiaomi may suffer from the same problem also there may be other phone brands and models having same or similar issues.
Also I suspect that the latest versions of the MPW - Pro and SSD may suffer from the connection issues with some phone brands and/or models. Examining the Logs from the MPW and altering the options in the Wi-Fi’s config file may resolve most of these connection issues.

I hope this will help someone and I hope if this solution works for more people that it will spread over the Internet so more people may become happy with their purchase of WD MPW/MPW Pro!

Regards,
Daniel


#12

Daniel, as a customer, please accept a big thanks for the sleuthing and documentation work. I’m surprised you haven’t gotten a positive response from WD, but many large companies behave this way. I would assume that your post is trickling its way up to an engineer who knows enough to respond.

I’m trying to login to my MPWP, and the logs and other techniques you describe may be very helpful in this regard. Again, a big thanks, and hoping that WD takes note.

Mike Russell