Can't access Dashboard on WIndows 10

I have tried to download WD Quickview from WD Support and it won’t install. I have tried to access My Cloud with http://WDMycloud/ and that doesn’t work have tried to access with http:// local IP address of My Cloud and it doesn’t work. I was working and I was using a camera to FTP Images to My Cloud before I upgraded from Windows 7. I also still have another PC that is remote that has a camera that is still using FTP to store images from a camera on this My Cloud device.

I need some help in getting this to work on Windows 10.

There have been many posts on Windows 10 and the My Cloud … have you searched the forums?

Please see, for example: Can’t access Dashboard on WIndows 10

Thank you for your response.

I believe that I have done as you suggest. I indicated that I had tried the suggestions and that they had failed. I tried using both the http://WDMYCloud/ and the local IP address UI in the URL. Neither worked. Is there something else that I need to try?

If you haven’t already done so you should go through the following thread that SectorGZ posted. There are a variety of methods listed in there to deal with a variety of Windows 10 issues. In particular ensure the network is configured for Private not Public. Ensure NetBIOS over IP is enabled.

I have read all posts and recommendations and still don’t have a clue how to get Dashboard back on my local PC. My camera in Thailand seems to be continues to be record on FTP in my local WD MYcloud using its motion detection.

Your suggestion seems to say that the Windows 10 suggestions should fix the problem. After reading all of the suggestions I can’t even figure out what problems they are fixing.

Does anyone have any suggestions that can get WD MYcloud working with windows 10. If someone has a solution it would be great if they could great if they could write some instructions to follow directions. Why hasn’t WD done this? It has been over 3 weeks and I haven’t seen anything that says we are any closer to get this working. If a solutions doesn’t arrive soon Wd MYCloud will have to go in the trash bin.

@Pittmanj, The My Cloud will work with Windows 10. Is this Windows 10 PC on the same local network as the My Cloud, or are you trying to access the My Cloud remotely with Windows 10?

First step is to ensure you have updated Windows 10 with all the latest Microsoft Windows 10 updates. Microsoft pushed out an update on March 1st that fixed one specific issue between the My Cloud and Windows 10.

Second, on computers running later versions of Windows (7, 8, 8.1, 10) there are various settings within Windows that can prevent access to the My Cloud on the local network. This includes having NETBIOS over TCP/IP disabled. Or having the network connection configured for Public rather than Private. The link posted earlier in his thread have the general steps/procedures listed for how to fix those two particular issues. Specifically steps; Windows 10 Specific Method 1 and Windows 10 Specific Method 2 in that link.

Third, do you have another computer, or mobile device that you can use to access the My Cloud on the local network?

Fourth, have you tried any of the WD software programs (WD My Cloud Desktop, WD Discovery, WD Quick View, WD Access) to see if they can find and access the My Cloud on that Windows 10 computer? WD software can be downloaded from the WD Support site:

Desktop does not find MYCLOUD, Quick View does not show dashboard, Wd access show Mycloud

If the WD Access program is showing the My Cloud then you should be able to launch the Dashboard from the WD Access program by right clicking on it in the task bar, then mouse over “WDMyCloud”, then select “Settings”. That should launch the web browser and attempt to open the Dashboard via the My Cloud’s IP Address. One alternatively select “Open” and the WD Access program will attempt to open the My Cloud using Windows File Explorer to show you the Shares on the My Cloud.

How does this help?/ I still can’t access the device so I can’t update the firmware in the device.

Can’t get access to Dashboard via WD Access settings. It says not authorized access to /UI

What is the exact error message or wording that is display on the web browser when attempting to access the My Cloud Dashboard user interface?

Have you tried a 4 second reset to see if that would solve the access problem? What about a 40 second system restore?