Cannot sign up for a mycloud.com account

Hi All, thanks for taking the time to read.

Just got a mycloud 4tb and during the initial setup it failed to send me an email when I entered my email address when setting up a mycloud.com account, i cannot log into mycloud as it says there is no account registered to that email but i did recieve a product registration email, i performed the 40 second reset and can access the drive via the admin log in but cannot sign up without getting the error - Device not registered. (400143). Could anyone help, i have tried different emails and i seem to be stuck in a loop. help ! ! ! !

I’m having the same issue, except I was registered and had no problems… and for some reason the connectivity stopped and I can’t connect once I tried resetting everything.

Not sure, but this might have something to do with it: ** My Cloud Mobile App Connectivy Issue **

Check out the Learning Center and view the Helpful Topics.
http://www.mycloud.com/learn/?id=mycloud#setup-computer

I was having the same issue last night - not receiving the email to setup my password, but did receive the email that the device was registered - so I decided to bookmark this thread in hopes someone will reply. I also decided to sleep through it hoping the next day the email will be sent.
I just went again through mycloud.com/setup procedure and entered the information again and it worked this time and I received the confirmation email with setting up the password. I set it up and it works now. My best suggestion would be to try it now once more, as I believe that they had some problems with the server last night/yesterday and it’s fixed now.

Here are the pictures that support the same problem I had last night:

  1. First it showed there was an error:
    http://prnt.sc/boet8d
  2. I tried going through the setup again, but it didn’t work:
    http://prnt.sc/boetph
  3. Going through the first link to go to device settings was impossible since I don’t have a password, so I couldn’t log as an administrator:
    (can’t post more links since I’m a new member)
  4. Trying to go to the second link to “my files” didn’t work either, because it claims that my email is not associated with a MyCloud account, when I tried to reset the password:
    (can’t post more links since I’m a new member)
  5. Going through all the PDFs in the Support area for my device (MyCloud 3TB), and seeing that I need to get the email to setup my password, which never came:
    (can’t post more links since I’m a new member)

In any case, I believe I had the same problem as you, and how I solved it is by waiting until the next day and went through the setup again and got my password and successfully managed to log in. I hope it works for you, too.

Hello

Hi, I think I may have accidentally sent an email here earlier, not having a good time with this new drive and thought that a reply above was from customer support.

Getting back to the problem, I still couldn’t set things up automatically and went via the dashboard again and logged in as admin, this time it did allow me to input an email address and when I then tried to create the password it got stuck in another loop saying creating password. I checked my emails and it had sent another email that said setup complete, I tried logging in the with details I had input and magically I was able to log in. So it looks as though I am halfway there, will update you all later on how I get on, what a faff though, it shouldn’t be this difficult, apologies if you read my earlier rant that was meant for customer services, it does look as though there are problems at WD end and that has what has made this exercise rather painful.

That’s correct and I did receive it.

I am an end user just like you and was trying to provide you with information that might help you. Myself, I see no reason to rewrite what WD has already provided online. However I will copy and paste the following from Helpful Topics.

How to setup your My Cloud via computer
1.Power up the My Cloud device
2.Connect the My Cloud device to a router
3.Go to www.mycloud.com/setup
4.Click “Get Started”
5.Enter the info you would like to use for the MyCloud.com account
a.First name
b.Last name
c.The user name you would like to use on the device
d.The email address you would like to use with the MyCloud
e.Confirm the email address

6.Check your email for the confirmation email
7.Create a MyCloud.com account password
8.Sign into the MyCloud.com account to access files from MyCloud.com
9.Option to download and install WD Sync to help move files from a computer to the My Cloud and keep the folders in Sync across devices
a.Enter the password for a user account
b.Select any additional folders you would like to keep in sync with the My Cloud
c.WD Sync will begin scanning and syncing files

I read the entire User Manual before I picked up my WD My Cloud from Best Buy. I also watched this from Best Buy,
My Cloud │ How it Works.

Hello Cat0w

Sorry about that, its been a very stressful experience and I had logged an online support email, I didn’t take the time to read the email I received properly and assumed I had been sent a link to something I had read multiple times, I do appreciate your time and apologise profusely.

It looks as though there was a fault at WD’s end when setting up my device, I got there in the end more by luck than anything else, the setting up of the password didn’t appear to work correctly either but I got an email confirming the setup of my account somehow althought the webpage timed out/was stuck in a loop.

Keep helping people, it is appreciated.

Hi Mai

Thanks for your comments, I think you are correct in that WD have been having some problems, things appear to be working a bit better now although I seem to have got there in a roundabout way, my next thing to learn is how to read emails properly and not assume they are from technical support, I upset cat0w by accidentally sending him a rude email, thought it was an answer to my support ticket i had logged, ooops !

Hello I remember creating a account to log into mycloud device but when i went to the website had the same issues turns out that the website requires a number in the password but the device does not. Change your password in the device to include a number and see if the account works on the site. Just putting it out there dont know if this will exactly help.

Hello efrain_r

Thanks for your response, you may well be correct there, I did change the password to include numbers and managed to set things up locally via the dashboard. I can now log into mycloud remotely and everything seems to be ok. Its been much more complicated than it should have been, it all went wrong during the initial setup when it failed to send me a password and as you mentioned it was either it didn’t like the password or there was a problem over the weekend for new users setting an account up that was resolved yesterday. Thanks again for your input.

Looks like that was the problem; despite not actually stating clearly what the problem was, your thread is listed as being a symptom:

I am having a similar problem but except when I create a new user I put in the username, first name, last name, and then the email. When I put in the email I click ‘apply’ I get an error called ‘undefined’. Literally no numbers, just one word, ‘undefined’

On the ‘Cloud Access’ page on the dashboard and it says ‘Connection Status: Ready’ so I don’t really know why I am not able to get a signal to create a simple account?

I set everything up correctly, I have done a factory reset, 40-second reset with no cigar. I really dont want to send this thing back but if I am having problems already I think I will have to, ~$200 will not be wasted.

Any help will be appreciated and I will be prompt with any answers you have on my configuration.

Did you resolve this problem as i have only just got the device and i am having the same problem ?

I have the same problem as it is not recognizing my email address

Yes, I will return the device…lol

I have the same…
I also made a change to the DNS server - as instructed:

Unfortunately, nothing helped.
Does anyone know how to fix this problem definitively?

Alleluia! I did :slight_smile:

In general settings I disabled the NTP service - because it was impossible to set the correct time automatically (the date was 2000), nor could I enter my own NTP UTC server.
That is why I disabled the NTP service, I entered the time and date manually - downloaded from the computer.
That solved the problem!
I will chide you and help you - let me know if you have also succeeded.

It is a shame that as users we have to deal with it ourselves.
Where is support?!

Not on this user forum.

They are here:

They should be there, but they are sleeping.
They could not provide information.
For a few days I was waiting for an answer and nothing.

Not only did I have such a problem, just read the forum.