Cannot connect remotely

I cannot connect either from my mobile or via the internet.

Using WD2go and WD Photo apps on my Android device (samsung galaxy 3); after inputting activation codes, I receive a message on my device: “Network Connection failure (1000)”

When I attempt to access MyBook Live on line (,,) the device shows up but the link does not work (“waiting for mybooklive device…” shows up in white bar at the bottom of the browser screen, and stays there until I close the browser page)


Check this thread

Thanks for the tip.

I viewed the previous post, and checked re network connection for my device (I do have connection via wifi and cell). I removed the apps from my phone and reloaded them, WD Photo and WD2go Pro. Same issue, but this time with different error codes

WD Photo – “Unable to access device”

WD 2go  “Network connection failure (668)”

Also, when I try to connect remotely using web access I get to my landing page but under the heafing “My WD Devices it says: No devices available”

Any thoughts?

What firmware version do you have?

Try enabling and disabling remote access on the dashboard

1 Like

thanks – I am using version MyBookLive 02.11.09-053 : Core F/W

I tried disabing remote and then re-enabling, but no luck.

Actually, I tried again and it works! Thanks.