Cannot access any of my shared networks

Product: WD TV Live Streaming Media Player (Gen 3)

Model number: wdbhg70000nbk-02

Firmware: 2.01.86 (12/2013)

I turned on my WD player and I could not access my Windows shares from my Laptop (windows 8) and PC (windows 7), when searching for my shares it doesnt even recognize and does not even come up when it is being searched for: 

I have tried everything that I can think of:

– reset my router 

– restarted both PC and laptop

– cleared the saved info on the player 

– reset to factory settings on the player 

– Checked my homegroup settings for both devices and everything is shared/allowed

– Checked my security settings on both devices and they are also set to shared/allowed

I am stuck at what I should do next, I have never had this issue before. I dont use the player everyday so I have had the issue where it wouldnt remeber my password info so I would normally just clear the saved info on the player or reboot one of my devices. 

Doe anyone have any ideas on what I should do next ?

ok well i fixed it …

apparently the time on my device wasnt the same as my network share devices, even though it was set to Pacific time(my timezone) the update daylight savings wasn’t checked …go figure …


Thank you very much for coming back and sharing your solution. This will be helpful to future Users under similar circumstances.