Can SickBeard be installed on EX4?

So, I would like to install sick beard on my EX4. Is it possible?

Yes it’s possible. Pretty easy if you’re running My Cloud OS 3. The whole application system uses docker, so you can install any armhf/armv7 docker images.

If you ssh into your device (enable it in your network settings) simply run the command

mkdir /shares/Downloads/.sickrage
docker run -d --name sickrage -v /shares/Downloads/.sickrage:/sickrage -v /shares:/mnt/wd/Public -p 8081:8081 --restart=always madtech/sickrage-armhf

That is assuming you have a share named Downloads.

I personally haven’t run sickrage but I have sonarr running without issue using this method on an EX4100. Bear in mind the ex4 is pretty underpowered to run applications like these, so the interface and post-processing will likely be pretty slow.

1 Like

I will try tonight and I will report back . Thank you for help.

I am on fw 2.10.310

after running the second command line it says:

-sh: docker: not found

I also tried to follow [GUIDE] Sickbeard on MyCloud, but after running

/usr/bin/python2.7 /usr/share/sickbeard/SickBeard.py

I get

-sh: /usr/bin/python2.7: not found

Any suggestions?

I can’t really comment on other tutorials, but I wouldn’t recommend directly installing packages into the OS unless you know what you’re doing, and it really isn’t necessary with My Cloud OS 3. It’s sure fire way to void your warranty.

Docker should be available based on your firmware version (given the release notes), unfortunately I don’t have the same hardware as you to check.

I’ve also built apps in the WD native app container format, they may or may not be entirely stable (I only got my WD NAS about a week ago), but NZBGet is definitely more stable than the one available via WD, they’re all upgradable as well. I don’t have a build of sickbeard/sickrage but I do have Sonarr, which is much better IMO.

If you go into apps, then click add (+), then select install app manually and upload the following it ‘should’ work.

NZBGet : download
Sonarr : download
Couchpotato : download

All of them rely on having a share called Downloads. To access your post-processing folders everything will be mounted and accessible at
/shares/SHARE_NAME/

1 Like

Thank you for apps, but looks like I am out of luck for now. I tried to install each app but all give the same error.
Failed to install app. Please check the network connection and try again.
I can see in the browser that the file is uploading but after that EX4 shows the error.
Under Settings>utilities>System Logs nothing showing that I think could be related. One error isCIFS: Authentication for user [**username**] has FAILED.
p**

rophetvx I really apreciate your help!

**

No problem, sorry I couldn’t help you out. It appears that even though documentation suggests the EX4 has docker support, it isn’t functional at this point in time according WD staff. The CIFS error is completely unrelated by the way, the network connection error is just a generic error whenever WD has a problem with the app container in my experience.

the SDK is build on Docker containerization, but Docker is not working / being availbale on EX4.
If you want to participate, even with being listed as official Third-Party App, then your platform is Marvell ARMADA 385 of My Cloud Mirror Gen.2 and EX2100, Marvell ARMADA 388 of EX4100 or Intel Atom C2350 (DL2100) and Intel Atom C2338 (DL4100).

source

Thanks, I tried with new FW 2.11.133 but same luck. The log for this fw did not suggets any changes tha would suggest anything new related to my pain.

Release notes for Firmware Release 2.11.133 (1/27/2016)

`Resolved Issues:
 Resolved issue of unable to connect to device while syncing/uploading files from multiple clients
 Resolved issue of unable to access dashboard
 Resolved issue of media crawler crash during resizing certain 1024x1024 images
 Resolved issue of incorrect credential message when opening dashboard after onboarding from mycloud.com
 Resolved issue of iSCSI iSNS client being OFF by default after a power outage and back online
 Resolved issue of misleading Power Supply “Failure” alert text on the WebUI
 Improved analytics logging support`

WD support here from stuff I guess is not permited. :smile:

You can run Python scripts just typing python. No need to type the full path.

i would love to try it, but I just started to learn linux… could you give me some pointers?

First of all, you must learn how linux works, and maybe later you will be able to install apps manually.

Without this knowledge-base, you won’t be able to install apps because you have to know how linux works, and how MyCloud systems operates through Linux.

I get it, but if I had a better understanding I would not be posting here. The harsh reality is that I spent my money on the wrong product, and I can only blame myself for that.

I ended up installing SickRage and SAB on my OpenELEC box. Running very well on Haswell NUC I3.

P.S. if you want good 3-rd party app support forget about WD EX4 or WD.

I tried installing Sonarr and Couchpotato on my EX4100 on the latest firmware, with no luck. Do you happen to have newer images that are compatible? I just get the network not available error message.