Backup Failure - cannot backup my Windows 8 desktop LAN computer

I just got a Sentinel DX4000 12TB to replace my ailing HP EX487 WHS.  I have a problem that I didnt see described elswhere.

The server set up smoothly and I am successfully transferring files from the old server to it.  All drives appear to be healthy.

But, so far I have been unable to backup my desktop computer, a Dell running Windows 8.   I get an alert message each morning that it failed to backup because there was not enough space.  There should be 9 TB available, more than enough.

After the first time this happened, I made sure that I excluded all the USB drives attached to my Win8 computer and I indicated that I only wanted to include C: and the Recovery in the backup.  This should be less than 1 TB total.  When I look at the Managing Server Folders and Drives tab, I noticed that the server was partitioned into C: and D: Drives, with the D: drive much larger.  (Oddly, most of the media folders pointed to the much smaller C: Drive, which I changed.)  I made sure that the Client Documents were pointing to the D: drive (which indicated >6TB available).

But still it failed because there was not enough space.

Am I missing something?  Is there a place where I should configure where Backups should be written to on the server?  Do I need to teach the server the password for my Windows 8 computer?  Could this be a problem with Windows 8?  (My HP used to back up my Win 7 machine well, but it stopped working when my school switched me to Win 8.)

Any help appreciated.

What is the configuration of your Windows 8 PC (i.e. Dell, HP, Homebuilt, etc)?

How old is it?

Here are my suspicions:

1)  Your system is from one of the Major Manufacturers

2)  It came with Windows 8 pre-installed

3)  If the two above are correct, this could be a case of your system being configured in the following manner:

Most of the new systems coming out with Windows 8 are now using UEFI/GPT configured HDD to boot from.  UEFI/GPT are not currently supported for backup. 

If you would like to be able to backup your system you will need to reconfigure your HDD.

But let me clarify what you will need to do before doing so.  Verify with your PC Manufacturer the configuration of the HDD, if they confirm that you do have UEFI/GPT then reconfiguring would be your only current option.

Thanks for the response.

My PC is a Dell that was originally a Windows 7 64 bit machine - about 3 years old.  I work at a university where our IT staff rebuilt my machine with Windows 8 - orignal hardware, just software upgrade.  Being a university, they may have used an early release version of Win 8, but I have kept it updated with all patches.  

How can I check if it is using UEFI/GPT configured HDD?  (what is UEFI/GPT?) 

If that is the case, is one solution to use the Win 8 File History tool and have it back up my computer to the Server?  If so, what parameters should I use for File History so that it doesn’t grow to take over my whole Server?


All the shared folders should be pointed to D:

In particular client PC backups, not documents

Use the move folder wizard if they are not on d: from the dashboard

and don’t worry about the password, when you installed the connector it did all it needed.

You can open dics mgmnt on the local pc and look for an efi partition

How big is your primary HDD, I do not mean your partition but the total space of your HDD?  Over 2TB will fail do to a 2TB limitiation.

Thanks Gramps and Zbeeblebrox,

Client Computer Backups is pointing to D:  (This is unchanged)

The C: drive in my Win8 machine is a 1TB drive listed as NTFS in Properties.  It has about 613 GB on it, and 316 GB of free space. Backup is set to back up Properties and C: only (I have excluded Program Files and Program Files (x86) from backup.)

Among the backup items is an item called “Windows Home Server Drivers for Restore.”  Could that be causing a conflict? Shoudl I exclude it from the Backup?

The message in the alert is:

Insufficient storage available for backup

Backup cannot save a snapshot of the volumes on this computer because the computer does not have enough storage space available.


I guess I will see what happens tonight.  Do I need to delete the failed attempts somehow?

thanks again for the advice.

Are you sure that the folder says “Windows Home Server drivers for restore”?  It should say “Drivers For a Full System Restore”

Any idea if bitlocker is enabled?

Try this just for testing, open the dashboard, go to computers tab, right click your computer, customize backups, and un-select system reserved.

Then try a manual backup.

As well do not worry about cleaning up the failed backups

I have seen this issue crop up in the past from time to time.  In general the problem can occur when the desktop PC has software that tends to write code to the Microsoft System Reserved partition (which should not happen).  But in rare instances this does occur.  Here is the problem:  The system partition requires 40MB of free space in order to do an image backup, if the free space has been decreased below this you will receive this error message.  So you can do file and folder backups, however an image file is preferred for full recovery.  There is a fix that is supported by Microsoft however it will require some very intrusive steps and you will need contiguous space available on the system drive.  Plus this is not for the faint of heart, you have the potential of losing your data across all of your storage.

Just so you understand this issue is on the PC side and not the Sentinel, so anything you have on the Sentinel will not be effected.  The Microsoft fix is for the PC with the backup problem.

Thanks for all your advice.

To Gramps’ question, it definitely says “Windows Home Server drivers for restore”   Remember that my old server was a WHS from HP  E487.   I suspect that it put some software on my system. 

In fact, I wonder if it is responsible for the the issue that zbeeblebrox raises? 

Although I am not faint of heart - I once had to rebuild my WHS from the bottom because the system HDD failed - I am not sure I want to take the risks that are implied by your PC fixes.   That last effort was enough stress for me, which is why I got the WD Sentinel when my WHS started ailing again.  (I replaced all the drives on that server with WD drives which have been stable ever since.)

I will try the manual backup recommended by Gramps.   I will also try automatically backing up another computer in my house to confirm that this is a problem specific to my PC. 

If it is a problem with my PC, am I stuck doing manual back ups?  I really want something that does incremental backups - only adding the new files instead of having to delete a backup and add a new one.   Can I set up something automated from the Win8 side?  I.e., push it from PC instead of pulling it from the server?  File History?  .  Should I install some other software to automate it?


Yes using file history would be a good option. 

On the road again/phone

it will do auto backups

if the small partition is the problem

let us know what happens

The folder drivers for restore is not a problem, but you can delete it anyway.  It gets created ever backup and is supposed to be deleted when the backup completes.  It is not unusual to see one hanging around on the local hard drive.

If you open any backup from the dashboard you should see a similar folder.

We just need to figure out if the system reserved partition is what is causing your problem, if so we can decide if it is worth the effort to fix it.

If that is the problem, it should still do automatic backups with that folder exculed, but efforts to do a full BMR will be hampered.

And yes, it is simple enough to also configure win8 file history to point to a share on the DX, but an alternative location may be preferred.  No real desire to put 2 copies of a file on one server.  If you create a home group, a share in there can be used as a history location

Here is a brief update.

I followed Gramps’ advice and removed the “System Restore” from the backup and left it overnight to see if that would allow the backup.  That did not work.  However, the error message changed.  Instead of the message about insufficient space, I got a generic error that an unexpected error occured and it could not complete the backup.

Then this morning, I took the same configuration - that is, backing up ONLY the C: drive from Win8 - and started a manual backup from the Dashboard.  That appears to be working.  When I left for work this morning it was up to 29% complete.  This is by far the farthest I have gotten, and the first time that my Server window doesnt say “Backup Failed.”  I will see how it did when I return. 

I guess the next question will be whether it will be able to backup automatically, now that a manual backup is in place.

I will keep you posted.

General failure. One of the 2may have rebooted with updates during the backup

More updates.

I am not sure how to confirm this but it appears that the backup ran automatically last night.  At least it said “successful” in the column under backups on the Computers and Backups tab. 

I left the setttings unchanged after my manual backup.  The only change I made was to shift the start time back by an hour based on Gramps’ suggestion that my “unexpected error” might have been a scheduling conflict.  

This backup excluded the RECOVERY section.  I wonder if it would be worth trying to add Recovery back.  Or I could try adding back the subfolders of Reovery (Boot, recovery, System Volume Information) one at a time to see if any of them is the problem.

But I am very encouraged.  It is clearly on the right track.  Thanks for your help.

No real need to change the backup time window, it was prob a one time issue.

In the dashboard where you saw successful, right click the computer name and view details.  There it will list the backups.

The problem apparently is that the recovery volume does not have 50mb of free space to do the shadow copy for a backup.  So I doubt selectively selecting items will make a difference.

Let it backup for a while, while you decide if you care that it is not backing everything up :wink:

As is, it means you cannot do a full Bare Metal Restore.  IE: if you put a new hard drive in the lappy and boot from the thumb you can only restore C: and not the hidden partition.  (As I type I cannot swear it would not work, Windows 8 is very forgiving, but it is much safer for me to say it would not)

What I think you could do fairly easily is do a fresh install of win8 to a new drive, then restore C:.  The install would create the partitions and the restore would put all your stuff back.

Another option is to try to expand your system part a tad, but that is tricky/time consuming/etc.

No clue what size drive, how hard it is to swap, and if you have the $$$.  If you bought another hard drive you could experiment.  I actually had an extra drive for one of my lappys once.  It was easy to change.  I would do a full restore to it before I traveled.  So if it died on the road, I could just plug the spare in and be good to go.  I was getting my email from my exchange server, so it was basically up to date even if I swapped a drive.

You should also go ahead and test restoring files or folders.  Rename some document/music/photo whatever on your lappy to something else and then restore the file(s) from the server.

Glad you got it sorted out.  How did you other systems do?

Thanks for the tip.  Yes, that confirmed it, it did automatically backup again last night without problem.

This sounds like good advice.  I will certainly have an extra HDD around once I retire the old HP Server.  But for now I willl live without the Recovery section.  The most important thing is to have the files backed up. 

For the most part, the rest of the sytem appears to be ok.  I have transferred most of the public files from the old server and they open fine.

I do have a warning alert saying there is an “Important update” that should be installed on the server.  I tried doing this manually, but it just hangs.  I have the sytem set to do automatic updates, so I will see if it updates tonight by itself.

I also cannot get remote access to work, but I suspect that is my ISP (Cox) which I believe is blocking port 443.  I know they block UPnP, so the automated setup will not work.  I tried manually port forwarding and nothing I do there works.  (I am using a Lynksys E4200 router, which seems like it should be fine for this.)   

Getting the backups working was a priority.  Now that those seem to be fine, I will connect the other computers in the house up and get those working. 

Then I can call Cox and sort out the Remote Access.  I dont really need the remote access, but it would be convenient to have.  It is all a process.

i really appreciate all the advice. 

yea boyz

Did 443 work with WHS?

Was the update for Windows or WD?  If WD it just looks like it is hung as the thermometer does not move

I could never get the the 443 to work with the WHS either.

This is a windows update and it didnt work automatically last night either.  It just hangs at “Preparing to Install” with the green color rotating around the fill bar instead of filling it.  Yesterday it hung in this position for hours.

it is a secuity update for Microsoft visual C++ 2010 redistributable package.