"Authentication Required" Window appears when using Remote Access via Web Browser (wd2go.com)

Hello Everyone,

I can successfully login to www.wd2go.com with my e-mail and password but when I click on “My WD Devices” (My Book Live) I have a pop up that requests a username and password. I have attempted to use every single username and password possible. I have different users setup with different shares.

  • I have enabled and renabled “remote access”.

  • Tried IE, FF, and Chrome

I’m running 02.32.05-046 : Core F/W.

  • Windows 7 Home

What do I do to gain access to my files remotely? Is there any alternative methods such as VPNing? Is it my router settings?

Thank you for your responses.

It’s asking for the “Network Drive Password,” which is the password you assigned to the user account you “paired” with the WD 2go account.

In other words, when you enabled remote access, the MBL asked you which user to associate with the mobile access account.

The password it’s asking for is the password for that user.

I have attempted to put the username and password many times, I even changed the password to something more simple to see if I was making a mistake. I even tried all the other usernames and password combinations. I also setup another user account with a new e-mail and same problem. It doesn’t seem to want to accept anything :frowning:

I’m sorry.   When I first responded, your screen shot wasn’t visible and I made an assumption.

The weird thing, now that I *can* see your screen shot is:   I’ve never seen that pop-up.   

This is what I see immediately after clicking the drive icon:

…  so mine is behaving differently than yours.

In YOUR case, your PC is prompting for authentication.

In MY case, the WD 2go application is prompting for authentication – completely different.

Incidentally, I also just created a new user (instead of using Admin) – worked the same way as before.

I also tried locally doing it from home network (previous screenshot was from my office).

All worked fine.

   Linux via Chrome and Firefox (though Linux doesn’t allow an actual connection, the authentication worked OK.)

   Windows 7 on a home machine using Chrome and IE – worked fine.

   Windows 7 on a work PC on my corporate network using Chrome, IE, and Firefox – all worked fine.

So there’s SOMETHING in your setup that’s intercepting the authentication webpage and not displaying the webpage itself, but instead asking you to authenticate.

Are you on your home network?  (In other words, is the PC you’re trying this from on the same network as the MBL?)

And, if so, is the IP address displayed above (the 192.168.2.something) the IP address of your MBL?

And if the answer to THAT is yes, then here’s a different kind of question:   Why would you be using WD 2go when you’re on your own network instead of using a direct connection via WIndows Shares?   (But either way, it should work fine, as a local connection via WD 2go DOES work.)

And FINALLY, make sure you have the latest Java client installed on the PC correctly.

Lots of stuff to check.  :)

TonyPh12345 wrote:

 

So there’s SOMETHING in your setup that’s intercepting the authentication webpage and not displaying the webpage itself, but instead asking you to authenticate.

 

Are you on your home network?  (In other words, is the PC you’re trying this from on the same network as the MBL?)

 

And, if so, is the IP address displayed above (the 192.168.2.something) the IP address of your MBL?

 

And if the answer to THAT is yes, then here’s a different kind of question:   Why would you be using WD 2go when you’re on your own network instead of using a direct connection via WIndows Shares?   (But either way, it should work fine, as a local connection via WD 2go DOES work.)

 

And FINALLY, make sure you have the latest Java client installed on the PC correctly.

We think alike.

I tried on an outside network no success.

  • Firefox says I have JAVA (SE 7 U9 10.9.2.5) also Java deployment Toolkit 7.0.70.11 10.7.2.11

192.168.2.69 is the IP assigned to the MBL in my router settings. I took this screenshot when I was connected to the network. It behaves the same way, even if I’m on an outside network. " https://server.device######.wd2go.com"

I am using windows shares.

What sort of java settings should I look at?

I also tried on another Windows 7 Computer and were getting the same user dialog.

For the time being, I’m using the FTP connection until we can fix this.

I have also tried port forwarding 80,443 and also 20,21 to the MBL.

At this point it’s either the Router intercepting, or the MBL is getting funky. I might have to try another router if I can find one.

If I click cancel I get redirected to this page:

[“https://server.device######.wd2go.com/Admin/webapp/htdocs/securityCheck.php?deviceUserId=#######&deviceUserAuthCode=#####****#####***####*#*#*#*#*#*#*#&useDefaultPage=true”](https://server.device######.wd2go.com/Admin/webapp/htdocs/securityCheck.php?deviceUserId=#######&deviceUserAuthCode=##### ##### ###########&useDefaultPage=true)

#'s and *'s are masking actual numbers and letters

Just for giggles.

When you’re on your INSIDE network, When it pops up the authentication box, try typing your ROUTER’S admin user ID and password.

If that actually opens up your router, then you know your router is intercepting the authenticaion.

It’s funny when you say that because I thought maybe that could be the case. I attempted to do it externally but I don’t have remote admin access enabled on the router. I’m waiting to get back to my office to see if our hunch is true.

If it is, do I have to get a new router? I’m using the one supplied by my ISP (Bell Fibe in Canada) . Thinking of getting the Cisco RV220W

I doubt it…  But at this point, I’m kinda out of ideas.  :(

I tried using my MBL on another router and I setup all the port forwaring. It’s not connecting after I click the MBL icon. I don’t get a password dialog anymore it just times out using xp.

I’m so frustrated now. The only variable now is that I’m using ISP Routers. One was a “connection hub” from Bell and “2Wire” on the other. I can only try another router to see if that’s the issue.

I have no idea what to do now. Is there a step I’m missing?

Hi, I have the same problem, have you resolved it?

Can you explain me how you did?

I can’t find any other threads that talk about this problem

Thanks

Unfortunately this thread came to a dead end. The only work around is using the FTP service and connecting it with an ftp client.

What router are you using?

BTW, on the port forwarding configuration on the MBL, have you tried setting it to XP COMPATIBILITY mode?

I have a belkin router, on the port forwarding configuration on the MBL i tried all choice but any one works.

Seems the port one, default 80, ask me a device user password, even if i create a remote account for my friends, this doesn’t have sense.

I don’t see XP Compatibility mode.

How do I contact WD to recognize this post?

bpm2012 wrote:

 

How do I contact WD to recognize this post?

This isn’t tech support from WD – this is a user community.  

To contact WD, use the contact info at 

http://support.wdc.com

up up

Any news?

i have update java, my book live’s firmware twice, browsers, but this problem still exists…

I have finally found what cause that problem, I had a share folder named “Admin” this name is the guilty, just rename and everything work fine :smileyvery-happy: :smileyvery-happy:

1 Like