Audio sync errors only on a couple of films?


#1

Hello all

New to the forum - having a bit of an issue:  I have converted many (over 100) of my DVD’s into MKV files using MakeMKV.  All of them play perfectly on my WD TV Live.  However, there are a couple that have audio sync issues.

I am using the latest firmware (1.02.21) not the beta.  

One of the films in question is StarWars Episode VI, I have tried putting the MKV on an external hard drive and attaching it to the WD TV Live and also tried putting the MKV on my NAS and have it streamed as a media server.  Both times I am getting audio sync issues.  All the other films that have been converted don’t have this problem.

When I look at the MKV on the computer the audio is in perfect sync so the only thing I can think of is the WD TV Live box?

Why is it just doing it for this film and not for all the others?

Any suggestions.  Thanks.  John


#2

Hmmm.   You mean Return of the Jedi, right?  How’d you MKV It?

I have MKVs of all six Star Wars movies and didn’t have an issue.   

I used Handbrake for all six.  

I’m assuming that HOWEVER you did it, you used the same preferences or profile on all six?


#3

Thanks for the reply

I use MakeMKV for all my MKV files - it does a straight conversion not re-encoding as Handbrake would do.  There is no need for any profiles - MakeMKV does a direct copy of the DVD (perfect for backup) so the end MKV is exactly the same size as the original DVD.


#4

MakeMKV has been known to have issues like this.

However, you don’t need to use it at all (it’s actually not any advantage in this case).  If you are just ripping regular DVDs then just concatenate the VOBs at the command line using the concate command and load the final one into mkvmerge and create the MKV file from there.  This is far more reliable and shouldn’t cause any issues for the Live.

OR – if all you want is a straight DVD copy, then just copy the whole thing to your disc.  The Live will play regular DVDs (and even navigate the menus) just fine.  No need to go through MakeMKV at all and it also preserves your options down the road (in case you ever do want to use Handbrake to save space without losing quality).


#5

Thanks mkelley

However, you lost me at “concatenate the VOBs at the command line using the concate command”

what software do you use with this concate command?


#6

In Windows just:

copy /b DISK1.VOB+DISK2.VOB+DISK3.VOB Together.VOB

at a command line prompt.


#7

Mkelley - thanks for that

Merged all the vobs together into one - but still have a few problems:

after adding the large vob to mkvmerge the end mkv no longer has any of the chapter information or the subtitle information?  how do you get this into mkvmerge?

but the main problem, playing the new mkv on the WD TV LIve has no sound?  playing the file on the computer shows that it does include the AC3 soundtrack and it can be heard.  However, when played on the WD TV LIve no sound is present?

Any suggestions?


#8

If you are using the current version of mkvmerge this is a well known issue – either use an older version or uncheck header compression (more info here: http://community.wdc.com/t5/Firmware/If-your-having-sound-issues-aparently/td-p/32724 )

You cannot preserve chapter info with concatenation, I do believe (although I *think* mkvmerge has the ability to import chapters so you could create your own, but I just woke up and may not be thinking clearly).  In any case, use the 10 minute fast forward or reverse and chapter stops are kind of moot.


#9

Apologies for this - It’s too hot and getting very tired:

I am using the mkvmerge GUI - how and where do you uncheck the header compression?

On the input tab I have an additional tab saying extra options - in this there are 3 options.  Cues, Compression and User Defined Options.  I can select any of these for either the video track or the Audio track.  Is this where the Header compression is?  and do I select none for both audio and video or just audio?

I know - not done this so its all new to me.

Thanks.


#10

You’re in the right place.  It’s under the AUDIO tracks that you want to set it to NONE.


#11

Thanks for all the help - got the audio to be heard. 

However, still getting the audio and video out of sync - driving me crazy.

I have tried loading a merged vob into mkvmerge - still out of sync.  also tried just loading the first vob into mkvmerge - it then finds all the associated vobs and creates a whole mkv file - still a little out of sync.

Why is this happening?  Any other thoughts?

I have tried ripping the original dvd with both DVDFab and AnyDVD - both get the same results when it is converted to a mkv file


#12

When you say “a little out of sync” how much are you talking about?  And how have you attached the audio and video to your TV?

I use AnyDVD on hundreds of DVDs and blu-rays, converting to MKV and have NEVER seen a sync issue (and would be surprised if there was one).  However, when you feed the audio through a receiver and are feeding the image through HDMI to a modern HDTV which needs to decode it the image will “lag” behind the sound slightly due to the image processing time

This is normal and is so common most receivers have a setting for it (usually calling it “lip sync” or “audio delay”).   It varies by device and by how much processing is doing on in the image (modern HDTVs can do a ton of image processing nowadays).  Usually you can delay the sound by up to 100ms (which is enough for almost any problem).

In my bedroom setup, for example, I have set the delay to around 70ms.  However, on my HD projector I don’t have a delay set at all (either it’s doing less processing or it’s much faster than my TV, because both are fed by a Live unit with the same sources, and both are running through a similar AV receiver).

To eliminate this as an issue, try feeding one of your files from your Live unit to an older TV via composite (and older set that doesn’t have HD, of course).  If the image doesn’t lose sync there you know what the problem is.


#13

mkelley, thanks for the reply

I understand what you are saying, however, I am unable to try as we only have the one TV and it happens to be an LCD.  I would agree that there may be some sort of delay with the audio and the way it is attached to the TV, but this should then happen with every MKV.  Instead it is just happening with a couple so I doubt that the way it is connecting to the TV is the issue.

I have been doing a few more tests and some of the results are interesting:

I tried converting the Vob through Handbrake to both an MKV and an M4V.  (both require re-encoding unfortunately) the results were that the MKV showed the same audio sync errors, but the M4V was perfect?  

I also just tried to play the actual VOBs straight from an attached HD and from the NAS.  Interestingly both showed the same audio sync error.  This kind of makes me think that perhaps it is DVDFab causing an error when it is ripping the movie to the HD.  I usually use movie only mode.  I will try ripping the whole DVD untouched to see what happens there. Will also try ripping to an ISO and see if that has the same problems.

Like I mentioned, it is only happening to a couple of movies - very strange.  All the rest, including full BluRays play perfectly so if there was any processing time it should be worse with the BluRays as the amount of video information if vastly larger than a standard DVD?

Please, I welcome any other suggestions.  Perhaps it is simply a firmware thing?  OR the way it is being ripped?

I’ll pass on my results as I get them.


#14

If you suspect a ripping problem try AnyDVD HD (the gold standard of ripping – there is a free demo).

Also something you said about Handbrake set off alarms – what version were you using?  In the standard release (very old now, last September or so) there were issues with some DVDs in terms of frame rate (the workaround is to force the frame rate and NOT keep the default “same as source”).  That *might* have something to do with it – it’s worth a shot (just go into the video options and change it from “same as source” to whatever rate the video is – usually 29.97 if NTSC).

Also, to be fair, I nearly *always* passthrough the AC3 or DTS audio in Handbrake, so if there are issues with converting it to AAC (the default) I would not ever notice them.  I don’t remember if you said whether you do this or not (but another thing worth trying).


#15

I am using the latest version of Handbrake - but I think i usually leave the frame rate as same as source - I’ll try and MKV and manually set the framerate.

I’ll also use AnyDVD to rip the dvd to see if it makes any difference.  I only liked DVDFab as it could extract the movie only - can AnyDVD do this too?


#16

AnyDVD will rip the entire disc to your hard drive – that’s all I ever use it for so I’m not sure about the rest.

Unless you have one of the snapshots or nightlies you do NOT have the latest version of Handbrake – if all you are using is the .094 release it’s more than six months old (you would know if you downloaded one of the nightlies, as they are not in the regular download section).  See this thread for details on where to download later versions:

http://community.wdc.com/t5/General-Discussions/Video-problems/td-p/26359


#17

sorry when I said latest - i meant the latest available one from their download page.  As it happens I do have one of the nightly versions too, but tend to use the main version from the download page.

My nightly version is 0.9.4.3280 as it allows you to specify specific chapters if you want to.

thanks.


#18

Well think I have found the problem :frowning:

Mkelley was right about the audio delay - this seems to be the issue.

I generated several different MKV files, some from AnyDVD, some from Handbrake and some from DVDFab.  All showed the same sync errors using the same DVD as the source (in this case StarWars)

My current set up is - WD Live TV box connected to LCD via HDMI and using an optical cable to connect the WD Live TV box to my surround sound system (rather an old one truth be told, it does not have any HDMI inputs too old for that)  I have my WD Live TV set to output the audio as digital since I am including AC3 or DTS audio in all the MKV’s and want to get the full surround sound.

Here is the problem.  Set WD Live TV audio to Digital Ouput, when you play a movie the TV displays English AC3 (Digital) and the surround sound box displays DolbyDigital.  Unfortunately the sound is ever so slightly out of sync for some movies. Should mention that the sound is lagging behind the video picture and not the other way round as MKelley suggested.  Suggests that it is the audio decoding that is taking slightly extra time.

Set the WD Live TV audio to Stereo Output, when you play a movie the TV displays English AC3 and the surround sound box displays PCM ProLogic II.  BUT the sound is in perfect sync with the video.

So, which is to blame?  the WD Live TV box and its digital setting, or the surround sound box and its decoding of the digital signal?  

Any suggestions?  My aim was to create a large archive on an external HD with all my movies in full format with their surround sound, but it is looking like either my setup or something else is now stopping this :frowning:  Having the sound reduced down to stereo and then converted to ProLogic II to me is really a backward step.

As I mentioned, some movies play perfectly, some do not.  I wonder, are some more susceptible to the sync error? or as I know the film so well I am just picking up the sync errors?

Thanks.


#19

If it truly is the audio lagging behind the video (which I doubt – usually it’s the other way around and *usually* video which leads audio is less noticiable) then the answer is simple: get a new AV Receiver (because the one you’re using is WAY too old if it can’t work faster than your display can).

A modern AV Receiver will also have HDMI inputs/outputs, which may solve the issue then and there (usually 1.3 HDMI specs will keep things synchronized automagically, although like I say I need to delay the sound on one of my receivers.  But it’s probably because my Sammy is doing a lot of post processing).  I cannot recommend the Yamaha line of AV receivers highly enough – they are quality products (the modern day Marantz) and as inexpensive as they come (my 5.1 bedroom receiver was around $200 and would serve most living rooms.  Even my theater room 7.1 receiver, driving a 20x30 foot area with wall to wall sound, was less than $500).

Even if the audio is ahead of the video a modern receiver can adjust for it, so you’ll win in any case.


#20

I really do think that it is my AV surround system that’s off - I am having lots of problems with it - especially with BluRays playing from my BluRay machine - speach is very quiet but background noise is very loud so you constantly keep your finger on the volume button putting the sound up and down depending on what is happening.  It has Dolby and DTS decoding, but don’t think it works with newer technology as it does not have HDMI.

I suspect that my WD Live TV also does not work well with it. - on the plus side - a good excuse to get something new :slight_smile:

Mkelley - thank your for all your help - you’ve been very patient.  :-)