Apps from WD Support DL4100 downloads

There are no apps listed for DL4100 (firmware: 2.21.119) in Dashboard > Apps. I downloaded apps from the WD suppot site (http://support.wdc.com/downloads.aspx?p=209) and extracted the folder containing the apps I want; specifically WordPress. The folder extracted from the download is “WDMyCloud_NAS_Apps_GPL_20150226\Apps\WDMyCloudDL4100_WDMyCloudDL2100” The apps listed in that folder are aMule, Dropbox, IceCast, Joomla, phpBB, phpMyAdmin, SqueezeCenter, Transmission, and WordPress. There are some notes in the file WDMyCloud_NAS_Apps_GPL_ReleaseNote.txt that explain how to build the app “using mksapkg to create the apps that could be install in the Web UI”. The instructions “mksapkg -E -s -m WDMyCloudDL4100” are not recognized by Windows 7, so I am assuming it has to be run loaded in through SSH.

Does anyone know how to created the file that the Dashboard Install Apps browse window is looking for?

So you’re saying when you go to the APPS tab on the dashboard, and click the “+” button, nothing ever shows up?

If that’s not showing up, then something else is wrong.

You may be making things worse by trying to compile the apps from GPL source and then “shoehorning” them into place…

There are no apps listed.

I have not tried to install anything outside of Dashboard, nor do I want to. I was just trying to update the list from what is available from the Support site.

[quote=“Weimsguy, post:1, topic:182128, full:true”]
There are no apps listed for DL4100…[/quote]
Because your using the DL4100 you may want to post to the dedicated DL subforum where people more familiar with that unit can help. This subforum, My Cloud, is primarily for the single bay My Cloud devices.

https://community.wd.com/c/network-attached-storage/my-cloud-business-series

Thread moved.

Thanks for moving the thread I thought that was were I was. I was there to start with, but must have done something that took me here.

Right Tony, the app icons are blank now and have been for a few months and the Dashboard shows a notice with this text:

Add an App
Apps bring additional capabilities to your My Cloud system. Please review the details of the app before installing.
No available Apps.
To install an app manually, click here.Choose File

And, “Clicking here” takes one to a folder in their NAS (where supposedly they downloaded the particular app to).

WD could definitely do a better job of explaining where to find the darn apps!
Other people have also complained about this, and since I got the apps I wanted before this happened, I have no idea how to find them now either.


1 Like

That’s odd… I grabbed the screenshot I posted above just a few minutes prior to posting it. I’ve not had any issues on my DL4100…

@SBrown Why aren’t the .bin files included in the files currently posted on the support site. i.e. WesternDigital\WDMyCloud_NAS_Apps_GPL_20150226.tar.gz. The bin files you get from the XML files referenced in these articles are much older than the applications you get by downloading the above mentioned file. The only thing missing from the download is the .bin files that the Install Apps function is looking for. Hopefully there will be a update the app option after installing the older .bin files.

Having to reset the DL4100 to update the apps folder is, in my opinion, a little extreme. I know the 4 second reset is supposed to be “Not Data Destructive and will not impact user data on the device”, but there is no guarantee that something might go wrong, but I guess there are no guarantees is life except death and taxes. I will just go the downloaded .bin file route.

The 4 second reset shouldn’t cause any issues. However, it’s always safe to err on the side of caution and make a backup of at least your most critical files.

Tony, this is downright weird. Why can you see this and not others and myself? I am using the current firmware on my DL2100. I checked both the IE and Chrome browser and both show the not available notice. I sent a PM to Bill S who notifed SBrown and he has posted a reply here, I’ll go take a look at the reply.

OK, I took a look as SBrown’s post and decided to do the 4 Second Reset, and save doing the 40 Second Reset for later if needed.

Well, fortunately, (and miraculously) the 4 sec reset did the job!

Yes, the menu of available apps shows up in both Chrome and IE browser again; additionally, the download arrow next to Plex installed app was showing again, indicating a new update was available – I had not seen that in a long while until this reset.

Thanks SBrown!

Hey, how do I mark this as Solved?

You don’t. Only the OP can do that. :slight_smile:

The file WDMyCloudDL4100_WordPress_1.03.bin, that was referenced in the XML file, installs v3.5.2 of WordPress. Running the WordPress Dashboard update function reports that it is up to date, but the current version from wordpress.org website is 4.6.1. Anyone know why the update will not bring in the newest version.

As to the original post, I will do the 4 second reset tonight to see if it rebuilds the application list and report back if it resolved the issue.

@Weimsguy

To restore the App menus, follow the insructions from SBrown’s post describing fix for “My Cloud Apps are not available for installation”
The resetting took around 5 minutes to complete. I did not reboot my router or any other of my devices prior to reset – I only did the 4 sec reset on the DL 2100 NAS which fixed issue…

@mike27octI plan to do that tonight and will report back. Our DL4100 is in production and I can not do any resets during the day unless there is an emergency. Unless I can get WordPress to update to the current version, rebuilding the App list will be a moot point, but I do want to know if this solution works.

You should be able to delete Wordpress once you restore the App menu, then place your cursor over the app so that it is highlighted and then, to the left of Add an app is Delete an app. Delete it, then add it from the Add menu. You may even want to reboot the NAS to clear any traces from the device, just in case there is any, then install Wordpress from the App menu. It may not be the most current version, but there are ways to get it afterwards. In the case of Plex, there is a notifying Down arrow displayed.

Be optimistic about all this. :smile_cat:

The 4 Second Reset did not fix the empty application list. I really do not want to start over by using the 40 Second Reset (System Only Restore), so I guess I’ll just use the manual download and install of applications. However, the manual install of WordPress does not update to the current version…

Thanks to everyone for their interest and replies. I’ll come back if I ever get this fixed by any other means than starting completely over.