[APP] MiniDLNA original/patched for firmware V4+ (08/2017)

Try the v1.1.4-patched as well see if you have the same issues. Those patches are directly from SourceForge. Unless there are new patches to fix, I can’t help much as I don’t have the C series to personally produce any code fix. Mine is E.

I purged the 1.1.3-patched and installed 1.1.4-patched

  1. Remember last position-OK

  2. srt subtitles-OK (including subtitle settings in tools)

  3. Virtual folders Latest-OK (missing virtual folder Last viewed)

  4. Fast forward and rewind-OK

  5. Play,Stop and pause-OK

  6. Thumbnails-OK

Everything seems to be working fine. The only thing missing is the virtual folder Last viewed.

Well… I can live with that. I’m sticking with this version.

Thank you very much for your work!

If you decide in the future to include the virtual folder Last viewed, this version will be 100% perfect! But it is just fine this way too.

Thanks again!

Well I will only do changes if there’s newer version or patch. Else this will be all. If there’s any new updates please inform me.

1st thanks for the effort on providing the package.

Then on the install issue. 

I get the error below

Installing (1)-> libvorbis0a_1.3.2-1.3_armhf.deb 95.7KBytes…
Error-1: Unable to install required files! ‘libvorbis0a_1.3.2-1.3_armhf.deb’

After trying to  manually install it (hope you don’t  mind :)) I get

root@nas minidlna # dpkg -i libvorbis0a_1.3.2-1.3/libvorbis0a_1.3.2-1.3_armhf.deb
dpkg: package libvorbis0a pre-depends on multiarch-support, which is not installed or flagged to be installed

should this be installed by default?

Also tryied to get that package from a debian dvd (as multiarch-support_2.13-38+deb7u6_armhf.deb)

but I get

dpkg: package multiarch-support depends on libc6, which is not installed or flagged to be installed

Am I doing it wrong? Just asking before I try to install too many things.

I’m using the last firmware (1.05.30) on MyCloud EX2

Linux nas 3.2.40 #3 Tue Jul 29 18:09:51 CST 2014 armv7l GNU/Linux

Linux version 3.2.40 (kman@kmachine) (gcc version 4.6.4 (Linaro GCC branch-4.6.4. Marvell GCC Dev 201310-2126.3d181f66 64K MAXPAGESIZE ALIGN) ) #3 Tue Jul 29 18:09:51 CST 2014

thanks,

florin

@florin.d

No problem about the manual install if you know what you’re doing. The installer meant to be fool proof as I did all these to prevent newbies breaking stuffs :laughing:

The package I put together was meant for WDMyCloud, not EX2 because I don’t have that device to test. WDMyCloud has this multiarch-support installed by default:

root@TeaNazaR4TB:~# dpkg -l|grep multiarch
ii multiarch-support 2.17-93 armhf Transitional package to ensure multiarch compatibility

And you can’t just install certain package from a debian dvd or repo, it may need 64K page size memory patch which needs manual build. But for multiarch-support it seems to be ok since it doesn’t have any libraries or binaries.

But the issue here is with libc6. Please check if the package is installed properly. It should have “ii” flag on the 1st column else it’s broken (you installed anything before manually?):

root@TeaNazaR4TB:~# dpkg -l|grep libc6
ii libc6:armhf 2.17-93 armhf Embedded GNU C Library: Shared libraries

If it’s broken you either need to reinstall by building eglibc manually or try a repo maintained by a user here name Fox_exe.

While writing my message it poped into my mind that yes, it might be that the package you provided might not be for EX2.

So I will try to use Fox_exe’s repo after I’m able to get apt installed. It seems apt-get is not available as a command on my wd.

thanks!

florin

@florin.d

Noted. It would be great to update us of your progress. May be I could include missing dependencies for EX2 as well.

Hi

I am trying to run subtitles with minidlna on Sony TV using WD my cloud 4 TB but it does not work. Is there any workaround with this? Tried installing all versions but no help.

Thanks

@krasimirm

The least is *.srt should work. I have no issues on my samsung tv/blu-ray. Can you confirm your sony tv supports subtitles via dlna? Some device only reads subtitle from usb and not dlna as the subtitles are streamed not transcoded.

Hi Nazar,

Thank you for the response. *.srt does not work.

I don’t know whether my tv supports subs via dnla - where can this be checked at?

Here is the model 

http://certification.dlna.org/certs/REG22071088.pdf

Regards

@krasimirm

Sorry I’m afraid your TV only support subtitles via USB.

If you search “KDL-42W650A dlna subtitle”, wdmycloud is not the only nas which can’t stream subs to your TV. The fact that your TV doesn’t read subs via DLNA even if the server (twonky/minidlna) support subtitles.

If you really need subs, you could however use transcoding of subs on-the-fly as such supported from Serviio. For this, you’ll need another system/pc to run Serviio (wdmycloud can’t run sun jre, yes I’ve tried to compile, I only managed to produce java alternatives gcj which won’t work). Then point the video shares on wdmycloud to Serviio’s media settings and connect from your TV. Your subs will appear but embedded, meaning you can’t adjust (on/off/sync/resize) from your TV.

There’s others to try if you’re running DLNA server from your pc such as WMS and XBMC.

Thanks, Nazar,

Let’s hope that Sony will update the firmware to allow this functionality although this seems to be an issue for quite a long time. 

Regards

Hi,

at first: thanks for your great work. I’ve installed the latest version 1.1.4.patched-1 and it works fine.

I have only one question: I’m from Germany, so is it possible to use localized strings for the clients?

My Samsung TV shows ‘All Video’, ‘Folders’ and ‘Resently Added’. I want see here german strings like ‘Alle Videos’, ‘Ordner’ and ‘Kürzlich hinzugefügt’.

I’m not very good with linux and I tried to google a solution but nothing worked for me.

Is there an easy way to see localized strings in my DLNA-Clients?

Thank you very much!

Chatfix

I’m not sure if the dlna server language on the tv will change if you change the locale though it’s included in the minidlna packages. I’ve never tested this before.

But you could try test below then restart minidlna to see if it works before adding them permanently to the file /etc/init.d/minidlna:

export LC_MESSAGES=de

or

export LC_MESSAGES=de_DE

Hi Nazar78,

thanks for your help.

I’ve tried the following exports:

export LC_MESSAGES=de

export LC_MESSAGES=de_DE

export LC_MESSAGES=de_DE.utf8 (because this locale exists under “locale -a”)

None of these worked. The clients always shown the english strings (after restart minidlna with “service minidlna restart”).

When I check locale with “locale” all LC_XXXX-Variables have Value “C”.

Maybe you have another idea?

Thanks

Chatfix

EDIT:

I tried “LC_ALL=de_DE.utf8” and then “locale”.

Now, all LC_XXXX-Variables are ‘de_DE.utf8’.

The LANG-Variable is empty, “LANG=de_DE.utf8” does not work.

But after restarting minidlna (with LC_XXX=de_DE.utf8) the clients show english strings also.

I also tried to copy ‘/usr/share/locale/de’ to ‘/usr/share/locale/de_DE’ (de_DE does not exists before). This doesn’t work too.

I can’t test it at the moment. Maybe this post could give you a hint about the locale? http://sourceforge.net/p/minidlna/discussion/879957/thread/f5be1f6e/

Hi Nazar,

first of all, thanks for your contribution. I’ve been using transmission and minidlna (installed them using your tutorials) on my new my cloud for a week now and they work like a charm.

There’s only one thing I’m having a small “issue” with. Minidlna seems to be preventing my disk from entering standby mode.

I’ve been doing some tests turning some services on and off and after turning off minidlna my cloud disk goes to sleep after 10 minutes.

At night all my dlna compatible devices (TVs, Laptops, etc) are turned off, but even then my cloud does not sleeps

I “solved” the issue by turning the dlna service off at night via cron but I’m sure that you will agree with me that that’s not the definite solution =P.

 So, here is my question to you (and to the community as well) do you know of any reason why this could be happening (dlna database being refreshed, etc)

Thanks in advance.

Try checking the minidlna log see any hints or if there’s any media fail to index which can cause it to retry scanning everytime. 

You could also off the inotify in the conf but it will need manual scan when new media added. Your idea of cronjob is quite acceptable but yes it’s not a proper solution. 

Sorry I can’t test this further. As you would have know, I’m running this installer off my wdmycloud (nginx+fastcgi), also several other sites so it hardly sleeps.

2 Likes

Thanks for the tips :wink:

Is the source down?

Checking resources…
Downloading -> minidlna_1.1.4.patched-1 (6,894,245Bytes)…
Error-8: Unable to retrieve required files! Server issued an error response.