Alternative Firmware (Debian Jessie, Synology DSM6)

Hello, i had ubuntu on my my cloud mirror gen2 for a long time but now i want to return to give this NAS to technically not so advanced people. I tried it by pulling out the HDDs and by flashing the wd recovery in the dev/wd-recovery folder as well as writing the mtdblock4 bin. Now i have a telnet access but still no web address or so showing of to flash the original firmware. Wnat am i doing wrong?

Nope. I sold my device few years ago, so, no any future updates.

Can anybody reassure me that I am doing the right thing here?
I’m at EOL with my My Cloud Mirror Gen 1, and concerned that the issues in the official firmware leave me exposed. I’d prefer to get the maximum lifetime out of my hardware, so going @Fox_exe’s route of an alternative seems to be the right one.

I pulled one HDD (2x 3TB RAID1) a few weeks back to serve as an emergency backup because of this vulnerability, so can I shift firmware and straight re-access the data on my newest version HDD after changing firmware? Lastly, do I have an escape if I screw up somehow, and have to:

  • throw it at the wall
  • nuke it from orbit
  • launch it into the sun

…and have to buy a new NAS like a Synology DS720+? The integrity of my data is paramount, and I’d rather not do this without knowing that I have a way out, even if that way out is buying a new unit (worst case).

Was there ever a new process for taking a Mirror Gen2 and using the Debian app to run a Chroot after installing OS5? Or is still recommended to not upgrade to OS5?

Backup old chroot folder (/mnt/HD/HD_a2/Nas_progs/debian or something similar).
Install this: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Apps-OS5/WDMyCloud_Debian_8.0-1.bin
Replace chroot folder to old one. Disable and enable app. Try to use.

1 Like

try using different browers, clearing cache. etc…

So: What made you roll back?

fair enough. :wink:

If there is no Firmware version - thats means config partition contains wrong/damaged/outdated configs. So, reupload defaults:

cd /tmp
wget https://fox-exe.ru/WDMyCloud/WDMyCloud-Mirror-Gen2/Original/config_mtd5_default.img

dd if=/dev/zero of=/dev/mtdblock5 2>/dev/null
dd if=config_mtd5_default.img of=/dev/mtdblock5 bs=2M

Then reboot and try again install official firmware.

1 Like

guys I read you for a few weeks and I have a doubt:
But if I take the MyCloud’s hard drive and I mount another for tests …
In the end if I put the device back back as before? or do I still have to reinstall all the software?
Please take this doubt

First, This is your DATA. If your just testing around with a spare drive,. good. You install from whats called CLI or command line interface, oldschool call it console. i call it terminal. or SSH, All if FOX Firmware from what i have used are safe. always default back to original. no problem.

1 Like

Hello Fox_exe,
I am a “complete noob” in this, but wanted to have a “file sync” app on my GEN 1 WD My Cloud (Firmware version 4).
I downloaded all your files (from: Fox_exe file archive), unpacked these and ran the ./install.sh
After sometime, the drive booted and the IP had changed. I can access (using SSH) the drive on the new IP address, but there is nothing else I can do. I tried accessing it via the WebGUI, but the IP is not recognized. Only SSH login works.
I have ZERO debian experience.
Is there a quick way I can get this alternative firmware installed?

The only thing I can see is the ROOT directory:

Please (HELP), need t get this drive to work again. Hopefully there is a “simple” solution I can follow to get things working again.

THANK YOU
KUDOS everyone!

your in the /dev directory. you need to type cd ~ then ls and run the program runme after reboot. also use putty. could be the console your using. also it would help if you said what mod your installling, in that dir there are about 6 different mods.

Hi @Fox_exe! I tried following those instructions above after updating to OS5 (5.18.117), and got the following error when trying to install the Debian app:

App Installation Failed

  • Incompatible app package file. Please check the app package and try again.

Any ideas? To reiterate, I’m on a Mirror Gen2. Much appreciated, in advance

@Fox_exe I installed Debian Jessie on my WD My Cloud Mirror Gen 1, and after doing the reset the device has been blinking the main power light a couple of times per second and both the drive lights are blinking blue very fast for the past several hours. I’ve tried to SSH into the device but I get a “connection refused” error. Is this process meant to take so long, and if so, how long should I give it before it might finish? Or is there something wrong? Is there a way to inspect what it’s doing?

After leaving my WD My Cloud Mirror Gen 1 syncing the RAID1 overnight, I was still unable to SSH into it (connection refused) so I took out both drives, deleted all the partitions on them and began again. I’ve gotten it back to a state where Debian Jessie is booting fine, I’ve installed SAMBA onto it and configured shares, and I reckon I’m happy with it as is.

The only slight annoyance now is the flashing power light, and adding the command

echo -n -e \\xfa\\x03\\x01\\x00\\x00\\x00\\xfb > /dev/ttyS1

into /etc/rc.local doesn’t do anything.

If anyone can offer any advice to get the power LED either solidly on or solidly off, that would be a huge help.

Download this: https://fox-exe.ru/WDMyCloud/Other/Weltrend_MCU/mcu_ctl
And use it: ./mcu_ctl sys_ready
Also possible control fan speed: ./mcu_ctl fan_set_50
./mcu_ctl -h - show all available commands.

Possible to contol HDD leds:
cat /sys/class/leds/hdd1-blue/trigger # Get available triggers (Controllers)
echo cpu > /sys/class/leds/hdd1-blue/trigger # Set trigger

echo 1 >/sys/class/leds/hdd1-blue/brightness # Turn ON
echo 0 >/sys/class/leds/hdd1-blue/brightness # Turn OFF
Available leds: hdd1-blue, hdd2-blue, hdd1-red, hdd2-red
Power led controlled by mcu, not available in /sys/class/leds (In kernel).

I download, set to executable and run mcu_ctl with a command eg. sys_ready, and it returns

<<: 69

and has no effect on the LED.

If I run a fan command I get the response

ERROR: Worng answer: 13

I’m not sure what I’m doing wrong but I don’t get the expected results.

I’m running Debian Jessie on the WD My Cloud Mirror Gen 1 and it seems like the Weltrend MCM Daemon only works with the Mirror Gen 2, is that the issue?

“System ready” command is same. Difference only in “sys led on/off”.

Gen2: sys led on: 0xfa, 0x03, 0x06, 0x01, 0x00, 0x00, 0xfb
Gen1: sys led on: 0xfa, 0x03, 0x06, 0x01, 0x00, 0x01, 0xfb

But you can try this:
./mcu_ctl 3 6 0 0 1
./mcu_ctl 3 6 1 0 1

None of the commands work, the power LED still just blinks. I had some issues when installing the Debian initially. Does the MCU_CTL program rely on any other files? Maybe I should check if there are missing dependencies?