Alternative Firmware (Debian Jessie, Synology DSM6)


#14

Hello Fox,

I tried the “debian-jessie-firmware-test” from your Gdrive. And the problem in the manual (If you see both red (purple) hdd leds - something went wrong. Connect to WDMC via Telnet and repair (Or prepare disks manually).) happened to me.

How can I repair/prepare disk manually? Do you have some instructions for that?

Many thanks, as always!


#15

Update to previous: I tried to use the Recovery method from the MyCloud Gen1. I do get the DHCPREQUEST but the TFTP does not seem to start to upload. Can you please assist me? Thanks!


#16

Recovery package only for Gen1 device. For other WDMC’s need different methods.
About Debian for Mirror - Press and hold reset button while led blinking (release, when stop blinking).
After that - wait ~5-10 min while HDD formats, then try to connect via SSH.
Note: There is no drivers for Fan or Led’s. So, its not controlled (Fan runs at max. speed, possible to control manually - read info in Developing section on my GDrive/site)


#17

Thanks for your response, Fox.

I’ve tried holding the reset button for at least 120 seconds yet nothing happens. The power led blinks blue (2x per second) and the HDD1 LED is purple the HDD2 LED is red (not inserted).

I’ve tried various times. Holding the button right from the boot, holding button when HDD1 purple HDD2 red. Does not seem to do anything.

Any ideas left?

Thanks!


#18

I did manage to get it to work, this might help others:

You should wait when booting when the HDD1 led turns from blue to purple, then you should push the reset-button and hold it until the HDD LEDs are blue again. You should reset the device after the process is finished; it will show a blue power LED, purple HDD1 led and red HDD2 LED. After the last reset the device will finish the installation!!

Thanks! :smiley:


#19

Hi Fox,
have now been much read in the thread Clean OS (Debian), OpenMediaVault and other "firmwares" and in https://community.wd.com/t/alternative- firmware-debian-jessie-synology-dsm6 / read 156551/13, i am now confused.

Is there a way to install Debian on the MyCloud Mirror Gen 2 ???

If so, what is the right guide for this???

Apologies bad English, my native language is German and I used the Google translator.

Best wishes
Karl-Walter


#20

WDMC Mirror Gen2 not supported - different CPU.
I can build kernel, but need UART for testing / debug.


News:
DSM v6.0.1-7393 available for download.

  • Can’t install from webgui, need reboot to DSM recovery (installer) for install.
  • Just power off device, extract all HDD’s, power on, wait ~1 min, place back HDD’s, install DSM via web-installer. Your data is safe, but DSM setting will lost.

#21

Hello Fox,

that is very nice of you.
Would lead out to me the serial port, to then work with it.
What else should I do ??
Best wishes
Karl-Walter


#22

Hi is the (DSM) 6.0+ supported on the WDCM gen 1 ? Or is only the gen2 supported ?


#23

I´m a bit confused now what is the diffrent between the WD My Cloud Mirror and the WD My Cloud Gen1 ?

I´m not sure which one i have…

root@WDMyCloudMirror root # cat /proc/cpuinfo
Processor : Marvell PJ4Bv7 Processor rev 1 (v7l)
BogoMIPS : 1196.85
Features : swp half thumb fastmult vfp edsp vfpv3 vfpv3d16 tls
CPU implementer : 0x56
CPU architecture: 7
CPU variant : 0x1
CPU part : 0x581
CPU revision : 1

Hardware : Marvell Armada-370
Revision : 0000
Serial : 0000000000000000

root@WDMyCloudMirror root # uname -a
Linux WDMyCloudMirror 3.2.40 #4 Fri Jul 31 16:04:18 CST 2015 armv7l GNU/Linux

Is it possible to install DSM6 on my WD ?


#24

Difference?
CPU:
Comcerto C2000 - WDMC Gen1
Armada 370 - WDMC Mirror or EX2 (Same)
Armada 375 - WDMC Gen2

For now - i support DSM6 only for Gen2 and Mirror.


#25

Ok then i can use your firmware :slight_smile: :heart_eyes:

Is Plex supported by DSM 6 with the ARM cpu ?
Its very important for me :slight_smile:


#27

Is there a way to recover the Original WD software or install Debian when the DSM was installed ?


#28

I have a problem for installing dsm6 for my gen2.
the step 5 :format disk err 35.
maybe I need to format the disk before I install?


#29

So i have the amv7 mycloud ex2 ultra which i guess is just the mycloudmirror gen2 with more memory. I dont suppose dsm6 would be supported on this ? I’m having all sorts of issues trying to run docker on their OS. Busybox is terrible. I’m consistently getting systemd errors on images and they’ve disabled / not included a huge number of commands in the busybox terminal locking it down. I can’t even upgrade the docker version.


#30

For me the DSM firmware wanted to build a new raid. After this the install was successfuly.

The DSM firmware is alot faster as the original WD. IPv6 support too.

But you cant go back to orig.


#31

Why? rollback available via WD Recovery (Both for Gen2 and Mirror. Read info in _howto.txt)

About Docker in original WD firmware - use Chroot’ed Debian. Its solve many of problems, but add one another - Hard to make Autostart for chroot.


#32

Which howto you mean ?

i found this: Index of /WDMyCloud/WDMyCloud-Gen2/Debian/_howto_en.txt


#33

Sorry, “Unbricking” placed in “Dev” directory. I move it to root folder. (Unbricking_en.txt)


#34

hmm didn´t find any (Unbricking_en.txt) in root folder.

I need this 2 files
/WDMyCloud/WDMyCloud-Mirror/Developing/Original
uImage 21-Oct-2015 06:31 3 MB
uRamdisk 21-Jan-2016 08:18 2 MB

for restore the WDMyCloud-Mirror ?